1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

High pitch electrical tone when pressing brake pedal...

Discussion in '2nd Gen. Tacomas (2005-2015)' started by sleestak, Nov 13, 2010.

  1. Nov 13, 2010 at 10:55 AM
    #1
    sleestak

    sleestak [OP] Active Member

    Joined:
    Nov 13, 2010
    Member:
    #46114
    Messages:
    29
    Gender:
    Male
    Hi all,
    Had my Tacoma for around 25,000 miles now and just began to notice a very high pitched, constant, electrical tone whenever I press the brake pedal. Easiest way to hear it is to press the brake pedal with the truck off...definitely noticing it every time I touch the pedal now and I never heard it before.

    Anyone else ever notice this? It's really quite annoying, having the fan or radio on will drown it out, but I'm wondering if it's common or I'm experiencing something unusual.
     
  2. Nov 13, 2010 at 11:53 PM
    #2
    island808

    island808 Me l've got brains.

    Joined:
    Oct 9, 2010
    Member:
    #44414
    Messages:
    1,892
    Gender:
    Male
    First Name:
    Jedediah
    hawaii
    Vehicle:
    '10 6speed 4x4 access cab
    No I've not noticed it. Could it be a relay buzzing? Do "american" cars use brake light relays? I'm more used to the mercedes monster relays.. don't deal in dash boards too much.
     
  3. Nov 14, 2010 at 12:14 AM
    #3
    fireturk41

    fireturk41 I like to break shit!

    Joined:
    Dec 23, 2008
    Member:
    #11857
    Messages:
    4,798
    Gender:
    Male
    First Name:
    Kevin
    High Point, NC
    Vehicle:
    280k miles
    SAS, Locked front rear, Ufab sliders and bumpers, air compressor, 35" BFG KM2 on steelies and 36" TSLs
    could it be the electric motor that helps the brake booster with vaccum, or possible a teeny vac leak?, maybe even the brake light switch?
     
To Top