1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

High Pitch Noise coming from windshield

Discussion in '2nd Gen. Tacomas (2005-2015)' started by photosbyrex, Dec 14, 2010.

  1. Dec 14, 2010 at 1:49 PM
    #1
    photosbyrex

    photosbyrex [OP] New Member

    Joined:
    Dec 14, 2010
    Member:
    #47690
    Messages:
    3
    Gender:
    Male
    Baltimore
    Vehicle:
    07 Tacoma 4x4
    Whenever I go 70mph or more on a really windy day there is a really high pitch noise that comes from the windsheild. I was told by the dealer that it was bad wipers but the problem persists now for 2 years. Another 07 owner told me he had the same problem. I suspect it is a bad windsheild seal. Any suggestion? I have a 07 dbl cab shortbed.
     
  2. Dec 14, 2010 at 1:52 PM
    #2
    Hunter500ky

    Hunter500ky Well-Known Member

    Joined:
    Dec 2, 2010
    Member:
    #47031
    Messages:
    2,521
    Gender:
    Male
    E-Town Ky
    Vehicle:
    06 Tacoma 4x4 SR5
    Weathertech Mats, Toolbox, 6k HID fogs, Hardwire Escort 8500 x50,
  3. Dec 14, 2010 at 1:59 PM
    #3
    roadking1

    roadking1 Well-Known Member

    Joined:
    Sep 28, 2010
    Member:
    #43941
    Messages:
    307
    Gender:
    Male
    n.j.
    Vehicle:
    sr5 trd 4wd
    I had it fixed on my 2005..The dealership did a really sloppy job on it.they put silicone under the windshield molding.It did take care of the noise.There is a TSB on this known problem.
     
  4. Dec 14, 2010 at 2:02 PM
    #4
    bowstoy

    bowstoy New Member

    Joined:
    Nov 1, 2010
    Member:
    #45559
    Messages:
    3
    Gender:
    Male
    First Name:
    harry
    okeana ohio
    Vehicle:
    05 tacoma
    mine does the same thing i have an 05 reg cab i changed wipers still did it i sealed windshield still did it but i did notice that when you sprayed the windsheild washer it would quit until it dried
     
  5. Dec 14, 2010 at 2:11 PM
    #5
    Hunter500ky

    Hunter500ky Well-Known Member

    Joined:
    Dec 2, 2010
    Member:
    #47031
    Messages:
    2,521
    Gender:
    Male
    E-Town Ky
    Vehicle:
    06 Tacoma 4x4 SR5
    Weathertech Mats, Toolbox, 6k HID fogs, Hardwire Escort 8500 x50,

    +1 everytime from now on, when I hear a new sound just going to crank the radio.
     
  6. Dec 14, 2010 at 2:21 PM
    #6
    ::childstoy::

    ::childstoy:: Hi-Tech Rednek

    Joined:
    Sep 30, 2009
    Member:
    #23556
    Messages:
    723
    Gender:
    Male
    First Name:
    Mike
    Southeast, PA
    Vehicle:
    Black 2010 TRD Sport
    TRD Exhaust, Tint, Stubby Ant., Debadged, Weathertech Mats, Grillcraft... Currently collecting donations for a New Tires Fund.
    Friend of mine had an 05 that the windshield seal started to go and he would only notice it at 65mph+. He had to have his windshield reseated.
     
  7. Dec 14, 2010 at 2:38 PM
    #7
    Ferg350

    Ferg350 Member

    Joined:
    Sep 19, 2008
    Member:
    #9339
    Messages:
    21
    Gender:
    Male
    Mississippi
    Vehicle:
    2010 Sliver TRD-OR 4x4
    5100s set at 2.5, 2" Toytec AAL, Nitto Tera Grapplers
    My 2010 DC did the same thing and i had to have a new windshield. Since the new windshield it doesn't make a sound.
     
  8. Dec 14, 2010 at 2:57 PM
    #8
    WNYTACOMA

    WNYTACOMA Well-Known Member

    Joined:
    Nov 23, 2008
    Member:
    #10961
    Messages:
    1,333
    Gender:
    Male
    Clarence, New York
    Vehicle:
    09 Metalic Grey TRD OFF ROAD
    Toyota Nerf steps Bugflector 2 Tool box Weathertech floor liners Wet Okole F/R - Bk/Char
    The dealer replacing the lower corner exterior trim piece fixed mine. (Warranty item)
     
  9. Dec 14, 2010 at 3:12 PM
    #9
    05Moose

    05Moose Middle-Aged Member

    Joined:
    Jan 18, 2010
    Member:
    #29613
    Messages:
    2,535
    Gender:
    Male
    First Name:
    Jim
    In the snow (NorCal)
    Vehicle:
    '05 4x4 DC LB SR5 #8 (LSD, Tow Pkg)
    '05 4x4 DC LB SR5 (LSD & Tow Pkg), Timbrens, AAL, 5100s (.85), Owned: 12/3/04 Mods: Fog, Map/Dome Light, Illuminated 4wd Switch, Washable Cabin Air Filter
    Ah yes, the old "reed" sound from the windshield. I was really glad to get a new windshield last year. Try taking I-5 at 75+ mph (speed limit is 75) and listen to that for 800 miles!!!!! I sure don't miss it.

    I attached the TSB in case it's easier to just look at it here.
     

    Attached Files:

  10. Dec 14, 2010 at 3:22 PM
    #10
    muddog321

    muddog321 Member

    Joined:
    Dec 22, 2009
    Member:
    #27973
    Messages:
    11
    Gender:
    Male
    fl
    Vehicle:
    09 tacoma doublecab 4wd trd w/e locker
    TSB NV006-07 fixes.
    Simply apply masking tape to the upper rubber windshield seal to roof (do not cover/tape over the glass) and see if that solves it. If not try the sides. The dealer usually calls a glass shop (if not under warranty go directly to a windshield glass shop) and they use a plastic pry tool to lift the windshield lip to body and apply sealer (look at it and it has none now and vibrates in the wind stream and different directions, crosswinds, etc cause it to vibrate or actually hum like a kazoo and it drives you crazy).
     
  11. Dec 14, 2010 at 4:15 PM
    #11
    uscg2008

    uscg2008 Well-Known Member

    Joined:
    Nov 6, 2009
    Member:
    #25537
    Messages:
    2,890
    Gender:
    Male
    First Name:
    coby
    San Diego, CA originally from Huntington Beach, CA
    Vehicle:
    06 trd sr5 four door 4x4
    CLICK ON SIGNATURE>>>>
    im having that same problem on my '06 when i hit 75-80 on the hwy. does anyone knw about how much it is to get this problem fixed?!?!?
     
  12. Dec 15, 2010 at 6:14 AM
    #12
    Lurkin

    Lurkin Well-Known Member

    Joined:
    May 21, 2009
    Member:
    #17497
    Messages:
    10,871
    First Name:
    Rod
    Pearland, TX
    Vehicle:
    09 PreRunner SR5 DC
    My 09 does the same, but it's only with a left to right crosswind. Haven't done anything about it yet though.
     
  13. Dec 16, 2010 at 5:25 AM
    #13
    photosbyrex

    photosbyrex [OP] New Member

    Joined:
    Dec 14, 2010
    Member:
    #47690
    Messages:
    3
    Gender:
    Male
    Baltimore
    Vehicle:
    07 Tacoma 4x4
  14. Feb 12, 2011 at 8:04 PM
    #14
    rsbmg

    rsbmg Well-Known Member

    Joined:
    Oct 24, 2010
    Member:
    #45160
    Messages:
    1,062
    Gender:
    Male
    First Name:
    Rob
    Vista,CA
    Vehicle:
    2011 Tacoma Doublecab TRD Offroad
    Front Aluminum bumper by Relentless Fab. Smittybuilt Winch Complete set of skids by ATO TC UCA's Fox Ext. Travel Front Reservoirs.
    Going through this problem with my 2011. Dealer sent it to a glass shop for new sealant but that did not fix it. Since there is no tsb for the 2011 I have to go through a bit of a process but the dealer seems to be working with me at least at this point. It only has 900 miles on it so hopefully we get to the fix soon.
     
  15. Feb 12, 2011 at 10:28 PM
    #15
    island808

    island808 Me l've got brains.

    Joined:
    Oct 9, 2010
    Member:
    #44414
    Messages:
    1,892
    Gender:
    Male
    First Name:
    Jedediah
    hawaii
    Vehicle:
    '10 6speed 4x4 access cab
    Just be glad the days of chrome trim around the windshield has gone by. Everything used to buzz after a few years.
     
  16. Feb 13, 2011 at 7:16 AM
    #16
    Rocketball

    Rocketball If The World Didn't Suck, We'd All Fall Off

    Joined:
    Mar 18, 2009
    Member:
    #14869
    Messages:
    1,517
    Gender:
    Male
    First Name:
    Scott
    Westminster, MD
    Vehicle:
    08 Speedway Blue DC Sport 4x4
    Pioneer head unit, PAC steering wheel control modual, Hard wired Sirius radio, Hard wired radar detector, Hella Supertone horns, Blacked out badges, Smoked Tails, BHLM (color matched Speedway Blue), T-Rex Eyelids, Black Powder Coated Billet Grill, Color Matched Engine Cover, Lund in channel vent visors, FJ Cruiser wheels, Leer 100XQ shell, OEM bed mat, Piezo beeper for locking doors, Tinted front side windows, Black Westin bull bar, Aires tube steps, Mini Maglite Mod, D-Cell Maglite Mod, Weathertech Digifit Floor Mats
    Subed....
     
  17. Feb 13, 2011 at 8:37 PM
    #17
    rsbmg

    rsbmg Well-Known Member

    Joined:
    Oct 24, 2010
    Member:
    #45160
    Messages:
    1,062
    Gender:
    Male
    First Name:
    Rob
    Vista,CA
    Vehicle:
    2011 Tacoma Doublecab TRD Offroad
    Front Aluminum bumper by Relentless Fab. Smittybuilt Winch Complete set of skids by ATO TC UCA's Fox Ext. Travel Front Reservoirs.
    I applied by own silicone today between the glass and the seal. Now I have to drive 115 before I can get any sort of noise. I have it narrowed down to a small space between the center of the windshield and the driver side edge. A bit more silicone and I should be good to go. I didnt want to keep screwing around at the dealership. 9-10 times I can figure things out and fix it myself saving me hours of driving the truck in an out of the dealership while they try to figure it out. Its to bad dealerships don't hire real mechanics that are able to diagnose and figure things out for themselves.
     
  18. Feb 14, 2011 at 4:13 PM
    #18
    Rocketball

    Rocketball If The World Didn't Suck, We'd All Fall Off

    Joined:
    Mar 18, 2009
    Member:
    #14869
    Messages:
    1,517
    Gender:
    Male
    First Name:
    Scott
    Westminster, MD
    Vehicle:
    08 Speedway Blue DC Sport 4x4
    Pioneer head unit, PAC steering wheel control modual, Hard wired Sirius radio, Hard wired radar detector, Hella Supertone horns, Blacked out badges, Smoked Tails, BHLM (color matched Speedway Blue), T-Rex Eyelids, Black Powder Coated Billet Grill, Color Matched Engine Cover, Lund in channel vent visors, FJ Cruiser wheels, Leer 100XQ shell, OEM bed mat, Piezo beeper for locking doors, Tinted front side windows, Black Westin bull bar, Aires tube steps, Mini Maglite Mod, D-Cell Maglite Mod, Weathertech Digifit Floor Mats
    Has anyone had this done that is out of warranty?

    My 08 is doing this and I'm way over the 36,000 miles.
     
  19. Feb 14, 2011 at 4:16 PM
    #19
    rsbmg

    rsbmg Well-Known Member

    Joined:
    Oct 24, 2010
    Member:
    #45160
    Messages:
    1,062
    Gender:
    Male
    First Name:
    Rob
    Vista,CA
    Vehicle:
    2011 Tacoma Doublecab TRD Offroad
    Front Aluminum bumper by Relentless Fab. Smittybuilt Winch Complete set of skids by ATO TC UCA's Fox Ext. Travel Front Reservoirs.
    You dont need a mechanic to put silicone on your window seal just go buys some at any auto parts store and apply it at the edge of the seal and the window its not difficult.
     
  20. Feb 14, 2011 at 5:23 PM
    #20
    KenLyns

    KenLyns Lord of War

    Joined:
    May 23, 2010
    Member:
    #37674
    Messages:
    25,125
    Gender:
    Male
    Belly of the Beast
    Vehicle:
    4x4 TRD Off Road Full-Auto
    All-Pro Bumper, CBI Sliders, Icon Coilovers, BudBuilt Skids, aFe Intake, Icon VS Rear Shocks, Timbren Bumpstops, All-Pro UCAs, JDM Steering Wheel, ViAir Compressor, Klearz LED 3rd Brake Light, Pop-N-Lock Tailgate Handle, Husky Front Flaps
    I used to get a similar sound (sounds like interference when you put a cell phone next to speaker) above 80 mph. After I installed my All-Pro bumper, the sound disappeared. Maybe the distinctly unaerodynamic bumper changed the turbulence characteristics.
     
To Top