1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Hitting the breaks Turns on my lights! electical prob.

Discussion in '2nd Gen. Tacomas (2005-2015)' started by meloncolly, Feb 9, 2011.

  1. Feb 9, 2011 at 9:25 AM
    #1
    meloncolly

    meloncolly [OP] Driver

    Joined:
    Jul 26, 2010
    Member:
    #40769
    Messages:
    11
    Gender:
    Male
    First Name:
    Jordan
    black moutain nc
    Vehicle:
    White Base Model w/ convenience package
    painted wheels (gunmetal) dark tinted windows
    Ok i am in need of serious help! when i press my break pedal my dash lights come on, and sometimes when i turn on my turn signals the dash lights flash in sequence with the turn signals. Also my front parking lights come on when i press the break pedal. at one point my break lights would stay on when i turned on my parking lights or my headlights. My truck is not even two years old and i already have electrical problems. :mad: anyone know what i can do, other than taking it to a mechanic?
     
  2. Feb 9, 2011 at 9:37 AM
    #2
    jhodge83

    jhodge83 Any dog under 50# is a cat and cats are useless... Moderator

    Joined:
    Apr 27, 2007
    Member:
    #1432
    Messages:
    28,096
    Gender:
    Male
    First Name:
    Jamie
    Moncks Corner, SC
    Vehicle:
    09 Timberland Mica DC 4WD Sport
    wat?
    are you still under warranty? have you done any mods for lights, etc that required tampering with any electrical?
     
  3. Feb 9, 2011 at 9:47 AM
    #3
    kws129

    kws129 Well-Known Member

    Joined:
    Jan 23, 2009
    Member:
    #12880
    Messages:
    248
    Gender:
    Male
    PA
    Vehicle:
    TRD Off Road Double Cab
    It sounds to me like you are "backfeeding" the electrical system. This most often happens when you get a bad buld that allows the current to jump to teh wrong location in the bulb. I've also seen this happen when you use the wrong bulb in the wrong location.

    Pull each buld starting with the brake lights in sequence and see which one makes the problem go away.

    Then replace that sucker and you should be OK.

    Otherwise there is a short somewhere.
     
  4. Feb 9, 2011 at 10:54 AM
    #4
    meloncolly

    meloncolly [OP] Driver

    Joined:
    Jul 26, 2010
    Member:
    #40769
    Messages:
    11
    Gender:
    Male
    First Name:
    Jordan
    black moutain nc
    Vehicle:
    White Base Model w/ convenience package
    painted wheels (gunmetal) dark tinted windows
    i did replace the parking light bulb, do u think that would do it?
     
  5. Feb 9, 2011 at 11:03 AM
    #5
    pyro13g

    pyro13g Well-Known Member

    Joined:
    Dec 1, 2010
    Member:
    #46991
    Messages:
    264
    Gender:
    Male
    First Name:
    Will
    Florida
    Vehicle:
    07 Tacoma Access Cab 4-CYL 5-Lug
    2.5" Lift, Add A Leaf, ridding on 30's, Sound Mat in floors and doors
    Dude i know exactly what it is... Who the he'll installed your wiring for your trailer lights? They don't understand that the tacomas have a red brake wire that can't just be spliced in with other wires. I know this because I did it like an idiot, but I learned...

    It's your trailer light harness... Check it
     
  6. Feb 9, 2011 at 11:10 AM
    #6
    macgyver

    macgyver Well-Known Member

    Joined:
    Aug 14, 2009
    Member:
    #21173
    Messages:
    3,590
    Gender:
    Male
    First Name:
    Brad
    Canton, GA
    Vehicle:
    '13 Tundra double cab SR5 4x4
    This could be the problem ^^

    BTW it's BRAKES not breaks
     
  7. Feb 9, 2011 at 11:13 AM
    #7
    brutalguyracing

    brutalguyracing BIG DADDY

    Joined:
    Jun 28, 2009
    Member:
    #19000
    Messages:
    24,038
    Gender:
    Male
    F.U> GUYZ
    broken mods
  8. Feb 9, 2011 at 11:51 AM
    #8
    meloncolly

    meloncolly [OP] Driver

    Joined:
    Jul 26, 2010
    Member:
    #40769
    Messages:
    11
    Gender:
    Male
    First Name:
    Jordan
    black moutain nc
    Vehicle:
    White Base Model w/ convenience package
    painted wheels (gunmetal) dark tinted windows
    u know, i've been suspecting that might be the problem, i did have an after market hitch put on. These suggestions are great. Please excuse any grammatical errors as i am almost dead asleep:D
     
  9. Feb 9, 2011 at 11:56 AM
    #9
    pyro13g

    pyro13g Well-Known Member

    Joined:
    Dec 1, 2010
    Member:
    #46991
    Messages:
    264
    Gender:
    Male
    First Name:
    Will
    Florida
    Vehicle:
    07 Tacoma Access Cab 4-CYL 5-Lug
    2.5" Lift, Add A Leaf, ridding on 30's, Sound Mat in floors and doors
    Oops typing too fast... Yes it is brakes not breaks but it will be breaks if you don't fix it haha
     
  10. Feb 9, 2011 at 12:00 PM
    #10
    TacoNinja12

    TacoNinja12 Well-Known Member

    Joined:
    Oct 8, 2008
    Member:
    #9810
    Messages:
    52
    Gender:
    Male
    Boone NC
    Vehicle:
    99 2.7L SR5
    3 inch lift
    same thing happened to me except when i hit my brakes my turn signals would stay on, check and see if your trailer light hookup is still good. thats what mine was, i had to replace it. the stuff got corroded and crossed the wires. sometimes its where it plugs in and sometimes you have to follow the wires to the box and sometimes you have to follow the wires to the tail lights to see where the problem is.
     
  11. Feb 9, 2011 at 1:13 PM
    #11
    joes06tacoma

    joes06tacoma Well-Known Member

    Joined:
    Jan 1, 2010
    Member:
    #28588
    Messages:
    3,056
    Gender:
    Male
    First Name:
    Joe
    Central Coast, CA
    Vehicle:
    06 4x4 Off Road Access Cab v6 6spd
    LEER Shell with dome lights operated with 3 way switches, aux backup lights with relay and 3 position switch, modified wiring to compass/temp display and clock to include switch that disables dimming function (poor man's DRL solution), Scan Gauge 2
    X2 check those brake light bulbs first especially.
     
  12. Feb 10, 2011 at 12:52 AM
    #12
    island808

    island808 Me l've got brains.

    Joined:
    Oct 9, 2010
    Member:
    #44414
    Messages:
    1,892
    Gender:
    Male
    First Name:
    Jedediah
    hawaii
    Vehicle:
    '10 6speed 4x4 access cab
    be funny prank.. jumper someone's trailer hitch to make them insane.
     
  13. Feb 10, 2011 at 2:03 AM
    #13
    ruslanus

    ruslanus Well-Known Member

    Joined:
    May 5, 2010
    Member:
    #36608
    Messages:
    330
    Gender:
    Male
    First Name:
    Rus
    Wasilla, AK
  14. Feb 10, 2011 at 9:57 AM
    #14
    island808

    island808 Me l've got brains.

    Joined:
    Oct 9, 2010
    Member:
    #44414
    Messages:
    1,892
    Gender:
    Male
    First Name:
    Jedediah
    hawaii
    Vehicle:
    '10 6speed 4x4 access cab
    I think I'm going to put a flasher on my horn and wire it to my reverse lights.
     
To Top