1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

How did you mount your toolbox?

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Synapse, Sep 1, 2008.

  1. Sep 1, 2008 at 12:45 PM
    #1
    Synapse

    Synapse [OP] Well-Known Member

    Joined:
    Apr 18, 2008
    Member:
    #6059
    Messages:
    93
    Birmingham
    Vehicle:
    2008 Tacoma
    :confused: I bought a Kobolt toolbox and went out and tried to use self tapping screws (stupid) like I did on my old ranger. Of course it didnt grip and I have serveral holes where I tried didferent size screws.

    I did a search and saw where people were using j-hooks but I cant find a pic or directions how its done. Anybody have pics or know how its done>
     
  2. Sep 1, 2008 at 7:45 PM
    #2
    Synapse

    Synapse [OP] Well-Known Member

    Joined:
    Apr 18, 2008
    Member:
    #6059
    Messages:
    93
    Birmingham
    Vehicle:
    2008 Tacoma
    Crap! Thanks for your help, I wasnt thinking about the sliders when I read about the j-hook.

    I guess that means I could slide the tool box fwd if needed?

    Thanks again!
     
  3. Sep 3, 2008 at 11:03 PM
    #3
    Synapse

    Synapse [OP] Well-Known Member

    Joined:
    Apr 18, 2008
    Member:
    #6059
    Messages:
    93
    Birmingham
    Vehicle:
    2008 Tacoma
    Cool thanks, install went flawless!
     
  4. Sep 3, 2008 at 11:08 PM
    #4
    tacomaman06

    tacomaman06 Carolina Alliance: Lead, follow, or get the hell o Staff Member

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,305
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '13 Silverado ext cab
    glad to hear you got it hooked up man. when i had my 06 and my kobalt box....i used large self tappers...they worked, but werent pretty at all. the j-hooks woulda been way better if i had thought about them way beck when i got it!!
     
  5. Sep 5, 2008 at 12:26 PM
    #5
    PatHLC128

    PatHLC128 College.

    Joined:
    Aug 29, 2008
    Member:
    #8867
    Messages:
    1,267
    Gender:
    Male
    First Name:
    Pat
    Austin, TX
    Vehicle:
    09 TRD Off Road 4x4 AC
    OME complete 3" kit, 265/75/16 Cooper STTs, Pro Comp 7089 wheels, Shrockworks sliders, UWS Low Pro Toolbox, AFE Pro-Dry S, OEM Bedmat, Ventvisors, Husky Liners, Tint, De-badged
    i dont quite understand, im thinking of buying that same kobalt box though. anyone have any pics of the install and or a j hook?
     
  6. Sep 5, 2008 at 2:59 PM
    #6
    PatHLC128

    PatHLC128 College.

    Joined:
    Aug 29, 2008
    Member:
    #8867
    Messages:
    1,267
    Gender:
    Male
    First Name:
    Pat
    Austin, TX
    Vehicle:
    09 TRD Off Road 4x4 AC
    OME complete 3" kit, 265/75/16 Cooper STTs, Pro Comp 7089 wheels, Shrockworks sliders, UWS Low Pro Toolbox, AFE Pro-Dry S, OEM Bedmat, Ventvisors, Husky Liners, Tint, De-badged
    ahhh now it makes sense... i dont know why i couldnt picture that before. thanks
     
To Top