1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

How lond before intake needs to be cleaned?

Discussion in 'Performance and Tuning' started by TacomaGus, Jan 4, 2010.

  1. Jan 4, 2010 at 7:46 PM
    #1
    TacomaGus

    TacomaGus [OP] Well-Known Member

    Joined:
    Jun 30, 2009
    Member:
    #19121
    Messages:
    1,163
    Gender:
    Male
    First Name:
    Gus
    Morgantown, WV
    Vehicle:
    08 White TRD Sport DC
    Tinted Tails, TRD Shift Knob, Kenwood Headunit, Ebay BHLM Lights, Trimmed Mud Flaps, 265/70/17 General Grabber AT2's, WeatherTech Mats, Black Badges, Sylvania ZXE Bulbs, AFE Stage 2 Si Intake, 17x8.5 Level 8 Guardian Wheels, URD SS, Custom 2.5" Catback with Aero 2525 and Vibrant Ultra Quiet Resonator, URD MAF CAL, JBA LT Headers, OME 884's, Nitrochargers, Dakars with 3rd lead removed, Light Racing UCA's
    I have had my K&N intake for about 6 months now and i love it and i bought the recharge kit to give it a quick clean but when i looked at it it honestly doesn't look any different from when i bought it and to top it off i was afraid to pull off the actual filter part b/c after i loosened up the clamp that was around it, it was still on the house so tight i was afraid to keep pulling on it haha

    any advice?
     
  2. Jan 4, 2010 at 7:48 PM
    #2
    1337Taco

    1337Taco Sold all 3

    Joined:
    May 9, 2008
    Member:
    #6504
    Messages:
    7,373
    Gender:
    Male
    First Name:
    Kevin
    NorCal
    Vehicle:
    2012 4x4
    Kings
    When it looks dirty or starts to turn color. How many miles have you driven with it on?
     
  3. Jan 4, 2010 at 7:51 PM
    #3
    jab08

    jab08 Well-Known Member

    Joined:
    Sep 17, 2009
    Member:
    #22883
    Messages:
    1,576
    Gender:
    Male
    Alabama
    Vehicle:
    02 T4R 4wd
    Use a flat head screw driver, slip it under the rubber part and gently go around pulling and prying it will come off eventually.
     
  4. Jan 4, 2010 at 8:09 PM
    #4
    TacomaGus

    TacomaGus [OP] Well-Known Member

    Joined:
    Jun 30, 2009
    Member:
    #19121
    Messages:
    1,163
    Gender:
    Male
    First Name:
    Gus
    Morgantown, WV
    Vehicle:
    08 White TRD Sport DC
    Tinted Tails, TRD Shift Knob, Kenwood Headunit, Ebay BHLM Lights, Trimmed Mud Flaps, 265/70/17 General Grabber AT2's, WeatherTech Mats, Black Badges, Sylvania ZXE Bulbs, AFE Stage 2 Si Intake, 17x8.5 Level 8 Guardian Wheels, URD SS, Custom 2.5" Catback with Aero 2525 and Vibrant Ultra Quiet Resonator, URD MAF CAL, JBA LT Headers, OME 884's, Nitrochargers, Dakars with 3rd lead removed, Light Racing UCA's
    i've only put about 6-7k miles on it so do you think it would need a quick cleaning?
     
  5. Jan 4, 2010 at 8:51 PM
    #5
    TacomaGus

    TacomaGus [OP] Well-Known Member

    Joined:
    Jun 30, 2009
    Member:
    #19121
    Messages:
    1,163
    Gender:
    Male
    First Name:
    Gus
    Morgantown, WV
    Vehicle:
    08 White TRD Sport DC
    Tinted Tails, TRD Shift Knob, Kenwood Headunit, Ebay BHLM Lights, Trimmed Mud Flaps, 265/70/17 General Grabber AT2's, WeatherTech Mats, Black Badges, Sylvania ZXE Bulbs, AFE Stage 2 Si Intake, 17x8.5 Level 8 Guardian Wheels, URD SS, Custom 2.5" Catback with Aero 2525 and Vibrant Ultra Quiet Resonator, URD MAF CAL, JBA LT Headers, OME 884's, Nitrochargers, Dakars with 3rd lead removed, Light Racing UCA's
    the sahara is nothing, i go to school in West Virginia...
     
  6. Jan 4, 2010 at 10:05 PM
    #6
    humanoid

    humanoid bite me

    Joined:
    Jun 27, 2007
    Member:
    #1932
    Messages:
    2,744
    Gender:
    Male
    Sunny SoCal
    Vehicle:
    I had a '99 Xtra Cab PreRunner SR5 V6
    It should be cleaned out every 25K miles or so, but like others have said, don't over oil the filter of you'll mess up the MAF sensor.
     
  7. Jan 5, 2010 at 10:43 AM
    #7
    TacomaGus

    TacomaGus [OP] Well-Known Member

    Joined:
    Jun 30, 2009
    Member:
    #19121
    Messages:
    1,163
    Gender:
    Male
    First Name:
    Gus
    Morgantown, WV
    Vehicle:
    08 White TRD Sport DC
    Tinted Tails, TRD Shift Knob, Kenwood Headunit, Ebay BHLM Lights, Trimmed Mud Flaps, 265/70/17 General Grabber AT2's, WeatherTech Mats, Black Badges, Sylvania ZXE Bulbs, AFE Stage 2 Si Intake, 17x8.5 Level 8 Guardian Wheels, URD SS, Custom 2.5" Catback with Aero 2525 and Vibrant Ultra Quiet Resonator, URD MAF CAL, JBA LT Headers, OME 884's, Nitrochargers, Dakars with 3rd lead removed, Light Racing UCA's
    well i tried to take it off today just to shake it out, but i can easily get the clamp ring off but with the heat shield i cant get a screw driver in far enough to loosen the seal, so i tried to get the heat shield off but its connected to a piece with the MAF sensor on it and didn't want to mess with that, so i gave up until i got on good old TW to see if someone had pics or advice on how to do this.

    Def shouldn't be this difficult
     
  8. Jan 6, 2010 at 8:22 AM
    #8
    TacomaGus

    TacomaGus [OP] Well-Known Member

    Joined:
    Jun 30, 2009
    Member:
    #19121
    Messages:
    1,163
    Gender:
    Male
    First Name:
    Gus
    Morgantown, WV
    Vehicle:
    08 White TRD Sport DC
    Tinted Tails, TRD Shift Knob, Kenwood Headunit, Ebay BHLM Lights, Trimmed Mud Flaps, 265/70/17 General Grabber AT2's, WeatherTech Mats, Black Badges, Sylvania ZXE Bulbs, AFE Stage 2 Si Intake, 17x8.5 Level 8 Guardian Wheels, URD SS, Custom 2.5" Catback with Aero 2525 and Vibrant Ultra Quiet Resonator, URD MAF CAL, JBA LT Headers, OME 884's, Nitrochargers, Dakars with 3rd lead removed, Light Racing UCA's
To Top