1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

"How to" clean MAF sensor

Discussion in 'Technical Chat' started by 02ttaco, Apr 3, 2011.

  1. Apr 3, 2011 at 7:46 PM
    #1
    02ttaco

    02ttaco [OP] Member

    Joined:
    Mar 13, 2011
    Member:
    #52923
    Messages:
    14
    Gender:
    Male
    First Name:
    Tyler
    Maryland
    Vehicle:
    02 tacoma trd
    three inch spacer lift with blocks in the rear
    I took my truck through some thick mud last night. The whole night and part of the morning the truck ran great. It was after i washed underneath the hood the truck started bogging down and seemed to be misfiring. I had this problem on my old nissan and it was the MAF sensor which i replaced.
    Could there be another possible issue? Upon start up the truck has a really rough idle:confused:, however The problem seems to correct itself after going 5 miles or so. Check engine light came on but i have yet to read the code. Thanks in advance for any help
     
  2. Jun 2, 2011 at 6:07 PM
    #2
    pyroskier

    pyroskier Well-Known Member

    Joined:
    Mar 24, 2011
    Member:
    #53622
    Messages:
    1,005
    Gender:
    Male
    First Name:
    Jacob
    Laramie, WY
    Vehicle:
    2004 Ext Cab TRD 3.4
    Bump for same situation
     
  3. Jun 2, 2011 at 6:10 PM
    #3
    scocar

    scocar Scouting the perimeter for weakness

    Joined:
    Nov 11, 2009
    Member:
    #25814
    Messages:
    31,305
    Gender:
    Male
    First Name:
    Dick
    In close proximity to an undisclosed location
    Vehicle:
    2015 DCLB 4x4 SR5
    Back to square one after the 2001. So...
    Did you check to see if the air filter is wet?
     
  4. Jun 11, 2011 at 1:18 AM
    #4
    x2468

    x2468 Well-Known Member

    Joined:
    Jul 19, 2009
    Member:
    #19879
    Messages:
    1,646
    Gender:
    Male
    Tallahassee
    Vehicle:
    '02 TRD 4wd V6 Xcab Sr5
    Either way can anyone tell us how to clean a Maf?
     
  5. Jun 11, 2011 at 4:49 AM
    #5
    VirginiaBound

    VirginiaBound Whyareyoureadingthis?

    Joined:
    Jun 22, 2009
    Member:
    #18755
    Messages:
    7,332
    Gender:
    Male
    First Name:
    Sam I am, green eggs and ham
    North of Maine, South of Spain
    X2
     
To Top