1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

How to fix P0441 Code

Discussion in '1st Gen. Tacomas (1995-2004)' started by Michael Nelson, Oct 17, 2011.

  1. Oct 17, 2011 at 2:36 PM
    #1
    Michael Nelson

    Michael Nelson [OP] Active Member

    Joined:
    Apr 5, 2010
    Member:
    #34662
    Messages:
    44
    Gender:
    Male
    First Name:
    Michael
    Warner Robins, GA
    Vehicle:
    98 Tacoma
    Throttle Body Spacer, Deck Plate Mod
    pulled code P0441 which said was a EVAP Control System Improper Purge Flow.

    Is this something that needs immediate attention or can i have it fixed in due time?

    also where exactly is this purge valve located, is it something that can just be cleaned?
     
  2. Oct 31, 2017 at 2:24 PM
    #2
    Luis martinez

    Luis martinez New Member

    Joined:
    Oct 25, 2017
    Member:
    #234103
    Messages:
    3
    Gender:
    Male
    First Name:
    Luis
    Vehicle:
    Tacoma 2004
    Purge valve is located ,on comparment engine on left side..close to fuse box.
    It 2 conector hoses .and conector for power.
     
  3. Oct 31, 2017 at 2:26 PM
    #3
    Luis martinez

    Luis martinez New Member

    Joined:
    Oct 25, 2017
    Member:
    #234103
    Messages:
    3
    Gender:
    Male
    First Name:
    Luis
    Vehicle:
    Tacoma 2004
    I had same problem,don't buy gas cap from autozone or advance....get original one save you headaches. ...
     
  4. Nov 1, 2017 at 10:26 AM
    #4
    twblanset

    twblanset Well-Known Member

    Joined:
    Jul 11, 2015
    Member:
    #159232
    Messages:
    101
    Gender:
    Male
    Check your gas cap gasket for cracks.
     
  5. Nov 1, 2017 at 2:35 PM
    #5
    Luis martinez

    Luis martinez New Member

    Joined:
    Oct 25, 2017
    Member:
    #234103
    Messages:
    3
    Gender:
    Male
    First Name:
    Luis
    Vehicle:
    Tacoma 2004
    Thanks .....a lot
     
  6. Nov 1, 2017 at 3:14 PM
    #6
    Kens04Taco

    Kens04Taco Well-Known Member

    Joined:
    Sep 11, 2016
    Member:
    #196991
    Messages:
    993
    Gender:
    Male
    Sunland, CA
    Vehicle:
    2004 PreRunner 4x4
    kangs and thanngs
    Start at gas cap, remove and check gasket. If cracked,dry, deformed....replace.

    Find the purge valve. Get a 9 volt battery and some leads. Blow into the purge valve. I believe it's normally closed so no air should flow. Hook up the 9 volt battery. You can find positive and negative from the other end of the electrical connector. Blow...air should flow. Also when u should hear a click. When u hook it up to the battery.

    If this works check your vacuum hoses for leaks. I just replaced all of mine because it's cheap and you can buy it by the foot.

    If this all seems to be in order move to the rear of the truck. Near the gas tank is your evap canister. Located on this black box on the top is another valve similar to your purge valve. Remove and test with 9 volt battery and inspect vacuum lines. (This was the culprit for my issue).

    If you have tested these and everything is working and functioning as it should you either have a cracked evap canister or the small diaphragm in the gas tank fill neck is fucked.
     
    NvrSyNvr likes this.

Products Discussed in

To Top