1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Icon (Aftermarket) UCA question

Discussion in '1st Gen. Tacomas (1995-2004)' started by dominator001, Aug 2, 2020.

  1. Aug 2, 2020 at 6:57 AM
    #1
    dominator001

    dominator001 [OP] Member

    Joined:
    Jun 5, 2019
    Member:
    #295411
    Messages:
    24
    Gender:
    Male
    First Name:
    Dominic
    Beaumont, CA
    Vehicle:
    White 2002 Tacoma Prerunner Regular Cab
    Good morning TW, have recently been running a set of Icon upper control arms I picked up used. Assume my question applies to most aftermarket control arms though. Replaced some hardware that was missing, everything else seemed to be in one piece. Upon install though I couldn’t tell if the 12 spline/castle bolt was supposed to be tightened enough to keep the uniball dome top piece in place or if it should spin freely. One side tightens enough to keep the cover from spinning, what I would assume to be closer to torque spec. The other side spins freely though and when it gets anymore than decently tight, it slips out of thread. I’ve taken the truck out a few times and haven’t had a problem with either side, but the fact that they’re different makes me nervous.

    Side note: being a no manual warrior, I didn’t actually notice I was missing the bottom bolt that “connects” the spindle to the uniball through the bottom side. Definitely going to go pick some up today, but have I been riding around in a death trap without those?
     

Products Discussed in

To Top