1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

iDatalink Maestro RR with on-screen TPS,RPM, MPH, etc. 2nd Gen.

Discussion in '2nd Gen. Tacomas (2005-2015)' started by SFXTACO, May 24, 2016.

  1. May 24, 2016 at 9:37 AM
    #1
    SFXTACO

    SFXTACO [OP] New Member

    Joined:
    May 3, 2013
    Member:
    #103447
    Messages:
    2
    Gender:
    Male
    Rhode Island
    Vehicle:
    2010 TRD Sport
    Pioneer AVIC-8200NEX, JL HD900/5, Hertz Hi Energy XLs, 2 JL 8W3s. Compustar T11 RS Combo with Drone and DASH.
  2. May 24, 2016 at 11:02 AM
    #2
    Revelations

    Revelations Well-Known Member

    Joined:
    Apr 17, 2014
    Member:
    #127895
    Messages:
    469
    Gender:
    Male
    Vehicle:
    2014 MGM DCSB
    I was just looking at the avic 8200 today. Only thing stopping me is that I'm waiting on the Android Auto wireless. I don't think the 8200 has any wifi capabilities.
     
    airwhen likes this.
  3. May 24, 2016 at 4:12 PM
    #3
    8m0nkey8

    8m0nkey8 Member

    Joined:
    Aug 16, 2014
    Member:
    #136306
    Messages:
    7
    Gender:
    Male
    Hawai'i / Las Vegas
    Vehicle:
    2014 Taco TRDsport Double Cab, Long Bed
    FJ Trail Team TRD Rims, Tires 265/75-16, TRD Catback Exhaust, Wet Okole Seat Covers , Roll n Lock Tonneau Cover
    Just curious..? Is the Maestro RR compatible pervious NEX decks..?

    Was thinking about switching out my stock deck and was deciding on getting one of the Pioneer NEX series 4100 and up.
     
    Last edited: May 24, 2016
    airwhen likes this.
  4. May 24, 2016 at 4:15 PM
    #4
    nd4spdbh

    nd4spdbh Well-Known Member

    Joined:
    Oct 7, 2013
    Member:
    #114055
    Messages:
    8,600
    Gender:
    Male
    SoCal
    Vehicle:
    13 DCSB TRD OR v6 Auto
    8 dollar OBD bluetooth adaptor and an android powered head unit, side load torque pro... boom


    sweet setup
     
    airwhen likes this.
  5. Apr 11, 2017 at 7:38 AM
    #5
    prux56

    prux56 Well-Known Member

    Joined:
    Jun 29, 2015
    Member:
    #158379
    Messages:
    51
    Gender:
    Male
    Vehicle:
    2012 White Tacoma TRD
    SFXTACO,

    what you have installed is exactly what I am working on with my 2012 TRD Sport with JBL and no amp. I know its been a year but I am hoping you remember a couple things about the install as I have three questions about connecting the unit.

    Assuming you did the install yourself did you ground-out the park brake lead so that you can enter information to the unit while driving? I'm stuck whether to put both green park leads together with the two ground wires (one from Maestro harness and the other from the Pioneer).

    The second question is where you connected your camera, did you use the black connector at the left access panel or go by the Maestro instructions which indicate something else, at least for my 2012.

    And the last question is whether you installed a sub. I don't have one now but was thinking of installing one later and didnt know if it was just a matter of connecting to the 'Remote' wire which was supplied on both the Pioneer and Maestro harnesses or something else.

    Thanks in advance for any help.

    P.
     
  6. Jun 4, 2017 at 7:47 PM
    #6
    jdtemple

    jdtemple Well-Known Member

    Joined:
    Apr 19, 2010
    Member:
    #35623
    Messages:
    518
    Gender:
    Male
    Bay Area CA
    Vehicle:
    08 DBLCAB LB TRD Sport
    Lift & Tires, in cab power outlets, Locking Bed Boxes, K&N
    Does it support the Transmission Temp as well?
     
    airwhen likes this.
  7. Jun 4, 2017 at 9:01 PM
    #7
    airwhen

    airwhen "You done messed up A.A.Ron!!!!

    Joined:
    Nov 24, 2015
    Member:
    #170625
    Messages:
    747
    Gender:
    Male
    Seattle, WA
    Vehicle:
    2015 TRD Sport DCSB 4X4
    Too much to list!
    Yes it does.

    BAA25433-0611-4348-8DD9-9300B0909266-1200-00000206B71ED094.jpg
     
  8. Jun 4, 2017 at 9:03 PM
    #8
    airwhen

    airwhen "You done messed up A.A.Ron!!!!

    Joined:
    Nov 24, 2015
    Member:
    #170625
    Messages:
    747
    Gender:
    Male
    Seattle, WA
    Vehicle:
    2015 TRD Sport DCSB 4X4
    Too much to list!
    Some older ones, but some may have limited functionality. The 8200 fully works where as the 8100 doesn't. IDataLinks website states what works or not.
     
  9. Jun 4, 2017 at 9:04 PM
    #9
    airwhen

    airwhen "You done messed up A.A.Ron!!!!

    Joined:
    Nov 24, 2015
    Member:
    #170625
    Messages:
    747
    Gender:
    Male
    Seattle, WA
    Vehicle:
    2015 TRD Sport DCSB 4X4
    Too much to list!
    Torque Pro is cool, but you cannot use it on the Pioneer deck, only on your phone or Andriod Powered deck.
     
    Last edited: Jun 4, 2017
  10. Jun 4, 2017 at 9:14 PM
    #10
    airwhen

    airwhen "You done messed up A.A.Ron!!!!

    Joined:
    Nov 24, 2015
    Member:
    #170625
    Messages:
    747
    Gender:
    Male
    Seattle, WA
    Vehicle:
    2015 TRD Sport DCSB 4X4
    Too much to list!
    Don't think the wireless option (Bluetooth) is coming to Andriod Auto or Apple CarPlay anytime soon. As of things right now, over Bluetooth Audio, many meta-data points (album art, time scrub, internal application control) are not available. Most likely a limitation to the generation of Bluetooth. But as new generations of Bluetooth arrive, we will see. For now, so much more data can be pumped through the micro USB/Lightning USB cords.

    Wifi capabilities? As being a hotspot? No and likely never. Why would you need it when your phone has those capabilities?

    Also, audio over Bluetooth is degraded. Pluging your phone in will always sound better.
     
  11. Jun 11, 2017 at 8:13 AM
    #11
    prux56

    prux56 Well-Known Member

    Joined:
    Jun 29, 2015
    Member:
    #158379
    Messages:
    51
    Gender:
    Male
    Vehicle:
    2012 White Tacoma TRD
    Hey,

    I'm just in the process of connecting my 8200 AVIC NEC to my 2012 TRD Sport Taco with JBL but no amp. So far it has gone well but I am having trouble tapping into the backup camera feed. The wiring instructions that come with the iDatalink says to use either the 24 pin connector or the 16 pin connector and lists them as 'Rear Camera Harness' but does not show where these are. Can anyone point me in the right direction?

    I have tried to tap into the smaller plug below the fuse panel on the drivers side as a lot of people on her have done but I do not get an image on the unit. It does seem to register that the vehicle is in reverse but it did that before I made any of the connections for the reverse camera.

    Since you folks already have installed them I was hoping you would remember where this connection is.

    As well I wanted to ask where the large brown USB connection is supposed to be made to tie into the factory usb.

    P.
     
  12. Jul 1, 2017 at 6:37 AM
    #12
    Eadestrd

    Eadestrd Member

    Joined:
    Jul 1, 2017
    Member:
    #222820
    Messages:
    7
    Gender:
    Male
    First Name:
    Austin
    Vehicle:
    2009 Red Tacoma TRD
    Going on my 6th hour looking at all these wires trying to figure out what goes where, I would not recommend this unit to anybody just due to the huge headache of install. I have flashed the Rr, I found the wiring diagram and believe it is all correct, hooked everything together and turned the key hoping to not mess with it anymore and it didn't pop up on the screen. Not sure what I'm doing wrong if anyone could help you would be a life safer! I don't get a green light on the Rr or anything If anyone has a picture could you post a picture of your wiring harnesses if it is clear or explain what I'm doing wrong if you know
     
    airwhen likes this.
  13. Jul 1, 2017 at 6:41 AM
    #13
    airwhen

    airwhen "You done messed up A.A.Ron!!!!

    Joined:
    Nov 24, 2015
    Member:
    #170625
    Messages:
    747
    Gender:
    Male
    Seattle, WA
    Vehicle:
    2015 TRD Sport DCSB 4X4
    Too much to list!
    iDataLink has excellent customer support. Have you called them?
     
  14. Jul 1, 2017 at 6:43 AM
    #14
    Eadestrd

    Eadestrd Member

    Joined:
    Jul 1, 2017
    Member:
    #222820
    Messages:
    7
    Gender:
    Male
    First Name:
    Austin
    Vehicle:
    2009 Red Tacoma TRD
    I called the number on there website and it was in a completely different language lol I believe it's only open Monday through Friday as well and I have to have this done or taken out and ready to return by Monday
     
    airwhen likes this.
  15. Jul 1, 2017 at 6:54 AM
    #15
    FadedComa

    FadedComa Failed Porn Star.........

    Joined:
    Apr 27, 2017
    Member:
    #217518
    Messages:
    3,992
    Gender:
    Male
    Vehicle:
    09 BSP TRD SPORT......
    Wiper Blades
    I had an issue and just posted on their forum, had an answer in like 2 hours. I would take a pic for you but it took me 2 hours to get all those wires tucked in behind the dash to even get the radio in. Never pulling that mess out again. If you bought it from Crutchfield their tech is open today. I used a JVC unit and made the cable like in the write up on here and luckily it worked right off the bat.
     
  16. Jul 1, 2017 at 7:09 AM
    #16
    airwhen

    airwhen "You done messed up A.A.Ron!!!!

    Joined:
    Nov 24, 2015
    Member:
    #170625
    Messages:
    747
    Gender:
    Male
    Seattle, WA
    Vehicle:
    2015 TRD Sport DCSB 4X4
    Too much to list!
    Hmm, well I guess that won't work then. You may have to submit pics in order to see what exactly is going on. You ordered the TO-1 harness with the unit?
     
  17. Jul 1, 2017 at 7:15 AM
    #17
    FadedComa

    FadedComa Failed Porn Star.........

    Joined:
    Apr 27, 2017
    Member:
    #217518
    Messages:
    3,992
    Gender:
    Male
    Vehicle:
    09 BSP TRD SPORT......
    Wiper Blades
    Just to clarify, I did not use the Maestro wiring to tap into the reverse camera. Did the tap in method from the thread somewhere on here and it worked perfectly.
     
  18. Jul 1, 2017 at 7:17 AM
    #18
    Kens04Taco

    Kens04Taco Well-Known Member

    Joined:
    Sep 11, 2016
    Member:
    #196991
    Messages:
    1,255
    Gender:
    Male
    Sunland, CA
    Vehicle:
    2004 PreRunner 4x4
    kangs and thanngs
  19. Jul 1, 2017 at 7:20 AM
    #19
    Eadestrd

    Eadestrd Member

    Joined:
    Jul 1, 2017
    Member:
    #222820
    Messages:
    7
    Gender:
    Male
    First Name:
    Austin
    Vehicle:
    2009 Red Tacoma TRD
    Yes I do have the TO1 but I do have some wires left over but I'm following the wiring diagram
     
  20. Jul 1, 2017 at 7:22 AM
    #20
    Eadestrd

    Eadestrd Member

    Joined:
    Jul 1, 2017
    Member:
    #222820
    Messages:
    7
    Gender:
    Male
    First Name:
    Austin
    Vehicle:
    2009 Red Tacoma TRD
    Rats nest of wires lol I can take more detailed ones if you can help!

    IMG_0355.jpg
     

Products Discussed in

To Top