1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Idler pulley maintenance questions

Discussion in '1st Gen. Tacomas (1995-2004)' started by krlang, Oct 9, 2008.

  1. Oct 9, 2008 at 2:48 PM
    #1
    krlang

    krlang [OP] NewEnglander

    Joined:
    Sep 3, 2007
    Member:
    #2592
    Messages:
    133
    Gender:
    Male
    Commonwealth of Massachusetts
    Vehicle:
    03 2WD 2.4L Tacoma Reg Cab
    Chrome Bumpers F&R, Grille & Corner Lights, Wheel Skins, Red/Clear LED taillights, Remote start, PDL, Cruise, K&N, All Kenwood, DNX-5120 6.1" NAV/TRAFFIC/DTV/DVD/XM/BLUETOOTH/USB/IPOD/SUB/rear cam, Tint, Air Band radio, Class 3 Hitch with 4/7 pin harness, Transmission Cooler, Red Top Battery, "Deck Plate" mod.
    Hi all,
    Coming up on 100k on my 03 taco, time to rid it of the morning squeak.
    I bought new belts, confirmed the sizes and I am ready for the swap.

    My questions are....

    Is there anything for maintenance on the idler pulleys?
    I would love to repack them, but I did not see anything in the manual.

    I see the pulleys in the toyota parts list are 2 different numbers with a price difference of $115.00, but dayco lists them as the same replacement part for $25 ea.
    Has anybody tried the Dayco pulleys?
     
  2. Oct 9, 2008 at 2:50 PM
    #2
    tacomaman06

    tacomaman06 Carolina Alliance: Enforcer

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,258
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '16 Tundra TRD Pro
    getting there....
    not on the tacoma yet, but i bought dayco idler pulley(im pretty sure it was them) from autozone for the 02 mustang my wife had...never had a problem with it either.
     
To Top