1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Idq12s froze up! Crap

Discussion in 'Audio & Video' started by mrmumbels, Jan 29, 2011.

  1. Jan 29, 2011 at 9:53 AM
    #1
    mrmumbels

    mrmumbels [OP] Well-Known Member

    Joined:
    Nov 17, 2010
    Member:
    #46331
    Messages:
    256
    Gender:
    Male
    Land O Lakes, fl
    Vehicle:
    09 prerunner
    none
    [​IMG]

    Plate is glued to magnet and basket screws to plate. The plate came unglued! Anyone have any experience with this? What's glue shall I use? I might screw it in like it should be
     
  2. Jan 29, 2011 at 10:24 AM
    #2
    mrmumbels

    mrmumbels [OP] Well-Known Member

    Joined:
    Nov 17, 2010
    Member:
    #46331
    Messages:
    256
    Gender:
    Male
    Land O Lakes, fl
    Vehicle:
    09 prerunner
    none
    The whole magnet assembly unglued.

    [​IMG]
     
  3. Jan 29, 2011 at 10:27 AM
    #3
    brian

    brian Another Traitor

    Joined:
    Apr 15, 2009
    Member:
    #16011
    Messages:
    7,557
    Gender:
    Male
    Elizabeth City, NC
    Vehicle:
    2008 F-350 Powerstroke
    Looks like some kinda RTV from the pics, I would just find something that looks and feels similar but has good bonding strength and go for it. I doubt you're gonna hurt anything.
     
  4. Jan 29, 2011 at 10:34 AM
    #4
    mrmumbels

    mrmumbels [OP] Well-Known Member

    Joined:
    Nov 17, 2010
    Member:
    #46331
    Messages:
    256
    Gender:
    Male
    Land O Lakes, fl
    Vehicle:
    09 prerunner
    none
    Don't think I can fix this. The magnet is so strong I can't line anything up properly.
     
  5. Jan 29, 2011 at 6:50 PM
    #5
    ItalynStylion

    ItalynStylion Sounds Gooooood

    Joined:
    Jun 15, 2009
    Member:
    #18467
    Messages:
    4,866
    Gender:
    Male
    First Name:
    Steven
    DFW, Tx.
    Vehicle:
    09 Double Cab TRD Sport 4x4
    Dude, are you fucking kidding me? Call Image Dynamics and send it back! I've never had a motor assembly just "fall apart". What the hell happened?
     
  6. Jan 29, 2011 at 6:55 PM
    #6
    mrmumbels

    mrmumbels [OP] Well-Known Member

    Joined:
    Nov 17, 2010
    Member:
    #46331
    Messages:
    256
    Gender:
    Male
    Land O Lakes, fl
    Vehicle:
    09 prerunner
    none
    I was just driving down the highway this morning and it made a funny sound. Look at how cheap that glueing is. I'm really surprised they didn't screw it through the magnet.
     
  7. Jan 29, 2011 at 6:56 PM
    #7
    rhodehard09

    rhodehard09 sometimes nonsense is the only sense someone has

    Joined:
    Sep 18, 2009
    Member:
    #22964
    Messages:
    3,485
    Gender:
    Male
    First Name:
    Ryan
    tampa, fl
    Vehicle:
    09 TRD Off Road 4x4 doublecab
    3" lift, allpro u-bolt flip kit,285/75/16 km2s, hella hid lights, hid conversions for headlights and foglights, led everything, debadged, 9145 reverse light bulbs, black tail lights, black headlight mod,trail-gear rock sliders, dynomax ultra flo muffler,satoshi with custom woven stainless grill,hella 100watt floods in grill, pioneer 4100 in dash dvd player, pioneer 800watt 4 channel amp, pioneer 4way 6x9s, pioneer 4 way 6.5s, 2 rockford p3 10's,rockford power 500.1 mono amp w/bass knob, 7 pin relocated, highlift and mount in bed, diff breather mod, led bed lights, secondary air filter removed,t-rex eyelids, mefab bumper bar, muddy under carriage
    hey bring them back to wherever you bought them, and see what they say.....
     
  8. Jan 30, 2011 at 8:44 PM
    #8
    shaneckc

    shaneckc Fyntünd Designs Vendor

    Joined:
    Jun 23, 2010
    Member:
    #39362
    Messages:
    1,295
    Gender:
    Male
    First Name:
    Shane
    Thousand Oaks, CA
    Vehicle:
    2014 SR Package DCLB 4x4
    lol i just lost alot of respect for image dynamics...
     
  9. Jan 31, 2011 at 4:10 AM
    #9
    mrmumbels

    mrmumbels [OP] Well-Known Member

    Joined:
    Nov 17, 2010
    Member:
    #46331
    Messages:
    256
    Gender:
    Male
    Land O Lakes, fl
    Vehicle:
    09 prerunner
    none
    Don't make your decisions on one sub. I do think the glue idea is kinda weird, but I still haven't found another person that this has happened to.
     
  10. Jan 31, 2011 at 6:00 AM
    #10
    ItalynStylion

    ItalynStylion Sounds Gooooood

    Joined:
    Jun 15, 2009
    Member:
    #18467
    Messages:
    4,866
    Gender:
    Male
    First Name:
    Steven
    DFW, Tx.
    Vehicle:
    09 Double Cab TRD Sport 4x4
    Yeah it's not typical for sure. That glue is very very strong. I agree a screw/bolt would have been ideal in addition to the glue but the glue is what holds most motor structures on. Eric at Image Dynamics is a decent guy. My IDMAX was broken when I received it and he replaced it.
     
  11. Jan 31, 2011 at 7:01 AM
    #11
    mrmumbels

    mrmumbels [OP] Well-Known Member

    Joined:
    Nov 17, 2010
    Member:
    #46331
    Messages:
    256
    Gender:
    Male
    Land O Lakes, fl
    Vehicle:
    09 prerunner
    none
    Not only is the glue strong the magnet has just as strong a hold on these plates. I needed 2 screw drivers to pry them off without smashing my fingers.
     
  12. Jan 31, 2011 at 7:17 AM
    #12
    ItalynStylion

    ItalynStylion Sounds Gooooood

    Joined:
    Jun 15, 2009
    Member:
    #18467
    Messages:
    4,866
    Gender:
    Male
    First Name:
    Steven
    DFW, Tx.
    Vehicle:
    09 Double Cab TRD Sport 4x4
    Did you hit an abrupt bump in the truck?
     
  13. Jan 31, 2011 at 11:30 AM
    #13
    supersuk

    supersuk Well-Known Member

    Joined:
    Apr 3, 2009
    Member:
    #15529
    Messages:
    111
    Gender:
    Male
    Honolulu, HI
    Vehicle:
    2010 Dcab TRD Sport Magnetic Gray
    Sounds!
    Hey, That happened to one of my dayton 8" midbass. The plate holding the magnet became "unglued" and cause the speaker to freeze up since the voice coil was binding on the magnet. Shitty deals...
     
  14. Jan 31, 2011 at 4:28 PM
    #14
    mrmumbels

    mrmumbels [OP] Well-Known Member

    Joined:
    Nov 17, 2010
    Member:
    #46331
    Messages:
    256
    Gender:
    Male
    Land O Lakes, fl
    Vehicle:
    09 prerunner
    none
    No, I'd have to drive off a cliff to delaminate a motor assembly.
     
  15. Jan 31, 2011 at 5:15 PM
    #15
    rhodehard09

    rhodehard09 sometimes nonsense is the only sense someone has

    Joined:
    Sep 18, 2009
    Member:
    #22964
    Messages:
    3,485
    Gender:
    Male
    First Name:
    Ryan
    tampa, fl
    Vehicle:
    09 TRD Off Road 4x4 doublecab
    3" lift, allpro u-bolt flip kit,285/75/16 km2s, hella hid lights, hid conversions for headlights and foglights, led everything, debadged, 9145 reverse light bulbs, black tail lights, black headlight mod,trail-gear rock sliders, dynomax ultra flo muffler,satoshi with custom woven stainless grill,hella 100watt floods in grill, pioneer 4100 in dash dvd player, pioneer 800watt 4 channel amp, pioneer 4way 6x9s, pioneer 4 way 6.5s, 2 rockford p3 10's,rockford power 500.1 mono amp w/bass knob, 7 pin relocated, highlift and mount in bed, diff breather mod, led bed lights, secondary air filter removed,t-rex eyelids, mefab bumper bar, muddy under carriage
    hey how do you feel about rockford fosgate? i have the p3s 10's and my buddy has the p3 12's. mine are really nice...bump hard and sound quality is great(and its all hidden)...my buddy's p3 12's are ridiculous. but they are in a box on his back seat.
    we off road alot and haven't had any problems.....
     
  16. Jan 31, 2011 at 7:43 PM
    #16
    mrmumbels

    mrmumbels [OP] Well-Known Member

    Joined:
    Nov 17, 2010
    Member:
    #46331
    Messages:
    256
    Gender:
    Male
    Land O Lakes, fl
    Vehicle:
    09 prerunner
    none
    ID confirmed this was a glue problem and that sometimes the acrylic mixtures may not mix well, although very very rare.

    They are sending me a brand new sub and a UPS label to return the old one. Amazing customer service!!

    I'd be surprised to get this level of support from any other speaker manufacturer.
     
  17. Jan 31, 2011 at 7:45 PM
    #17
    ItalynStylion

    ItalynStylion Sounds Gooooood

    Joined:
    Jun 15, 2009
    Member:
    #18467
    Messages:
    4,866
    Gender:
    Male
    First Name:
    Steven
    DFW, Tx.
    Vehicle:
    09 Double Cab TRD Sport 4x4
    Those seem to have a problem with the cone detaching from the former. My friend has gone through like 3 of them. PE always replaces them no questions asked. They're a great shop; best part of my supply chain hands down.
     
  18. Jan 31, 2011 at 11:35 PM
    #18
    shaneckc

    shaneckc Fyntünd Designs Vendor

    Joined:
    Jun 23, 2010
    Member:
    #39362
    Messages:
    1,295
    Gender:
    Male
    First Name:
    Shane
    Thousand Oaks, CA
    Vehicle:
    2014 SR Package DCLB 4x4
    good to hear about their customer service. Reminds me of Hertz Audio. I have yet to see them deny a return and you cant beat their 3 year warranty.
     
  19. Feb 1, 2011 at 5:44 AM
    #19
    ItalynStylion

    ItalynStylion Sounds Gooooood

    Joined:
    Jun 15, 2009
    Member:
    #18467
    Messages:
    4,866
    Gender:
    Male
    First Name:
    Steven
    DFW, Tx.
    Vehicle:
    09 Double Cab TRD Sport 4x4
    Good to hear man. I knew they'd take care of you. That's one of those problems that's so freak accident they know you didn't screw it up. Nice to see they're still taking care of people.
     
To Top