1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

installed my lift

Discussion in 'Suspension' started by rpking, Apr 8, 2012.

  1. Apr 8, 2012 at 6:51 PM
    #1
    rpking

    rpking [OP] Well-Known Member

    Joined:
    Jun 19, 2011
    Member:
    #58543
    Messages:
    215
    Gender:
    Male
    First Name:
    Roger
    Ohio
    Vehicle:
    Tacoma 4x4 TRD off road
    painted engine cover, bed cover, color match door handles, window tint, seat covers, weather gaurd floor mats, TRD stainless steel cat back exhaust, front skid pan, bug deflector, custom holster mount in center console, OME 884X springs and shocks, 2" AAL, OME shocks
    I installed an OME lift and a AAL, It went very well alot easier than i thought it would. I put the front end together first and drove the truck around a couple times, no vibes, shakes, or wandering. Then i installed the AAL, i have a very small vibe at 20-25 MPH. I put some 1/4 inch spacers to drop the drive shaft carrier bearing but it seemed to make it a little worse, i'm going to keep messing with different size spacers to try to get it to stop. But i can live with it if i fail :D
     
  2. Apr 8, 2012 at 8:35 PM
    #2
    Sublime

    Sublime Well-Known Member

    Joined:
    Nov 14, 2009
    Member:
    #25918
    Messages:
    3,711
    Gender:
    Male
    First Name:
    Mike
    Phoenix, AZ
    Vehicle:
    08 TRD 4x4
    Icon/All Pro.....chopped for 35's
    What method did you use up front.....unbolt the tie rod end, uca from the spindle or lca? Will be swapping out for some ext travel Icons and want to see what's easiest!
     
  3. Apr 8, 2012 at 8:36 PM
    #3
    medic2230

    medic2230 Ditch Doctor

    Joined:
    Oct 13, 2008
    Member:
    #9942
    Messages:
    10,242
    Gender:
    Male
    First Name:
    Murph
    Columbus, Ga
    Vehicle:
    2011 Taco 4x4 DCLB
    20% Tint, OME 3"complete lift with Dakar's, Light Racing UCA's, 285/75/16 Nitto Terra Grapplers, 10 HP TW sticker, Ultraguage, B.A.M.F. Rock Sliders, MedicFab Bed Rack, Relentless front bumper
    Yeah me too. I'm installing my OME lift this week.
     
  4. Apr 9, 2012 at 7:45 PM
    #4
    rpking

    rpking [OP] Well-Known Member

    Joined:
    Jun 19, 2011
    Member:
    #58543
    Messages:
    215
    Gender:
    Male
    First Name:
    Roger
    Ohio
    Vehicle:
    Tacoma 4x4 TRD off road
    painted engine cover, bed cover, color match door handles, window tint, seat covers, weather gaurd floor mats, TRD stainless steel cat back exhaust, front skid pan, bug deflector, custom holster mount in center console, OME 884X springs and shocks, 2" AAL, OME shocks
    I unbolted the tie rod and the upper control arm at the spindle it worked out well
     
To Top