1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Installed the weapon r secret weapon intake and now issues!!!!!!!

Discussion in '2nd Gen. Tacomas (2005-2015)' started by xtrm23x, Mar 18, 2012.

  1. Mar 18, 2012 at 6:24 PM
    #1
    xtrm23x

    xtrm23x [OP] New Member

    Joined:
    Jun 19, 2009
    Member:
    #18663
    Messages:
    3
    Gender:
    Male
    Oshkosh, Wisconsin
    Vehicle:
    06 SR5 TRD Offroad
    stock
    Just wondering if anyone else has used this intake on their tacoma. After installing it the engine idles worth a crap and the transmission shifts hard from first to second. I was getting to lean engine codes but those are no longer there. Looking for some insight thanxs guys.
     
  2. Mar 18, 2012 at 6:29 PM
    #2
    Maticuno

    Maticuno Resident Pine Swine

    Joined:
    May 26, 2011
    Member:
    #57287
    Messages:
    2,903
    Gender:
    Male
    California High Deserts
    Vehicle:
    08 DCLB Sport
    Pioneer AVIC-D3, SWI-PS, Sirius Satellite Radio, 2X In-Cab 110V Outlets, Constant Fog Light Mod, Inverter Always 400W Mod, Anti-Pack-Rat-In-Intake Mod, Eibachs on 5100's, 2" Toytec AAL, B.A.M.F Rear Diff Skid, 265/70R17 Goodyear Wrangler Authority tires
    Never used that particular intake, but I'd start with checking the electrical connections to your MAF and throttle body and make sure to tighten up any intake pipe connections after the MAF.
     
  3. Mar 18, 2012 at 6:30 PM
    #3
    IndianTaco

    IndianTaco Well-Known Member

    Joined:
    Aug 1, 2010
    Member:
    #41057
    Messages:
    1,110
    Gender:
    Male
  4. Mar 18, 2012 at 8:41 PM
    #4
    NEAScott

    NEAScott Well-Known Member

    Joined:
    Feb 20, 2012
    Member:
    #73258
    Messages:
    640
    Gender:
    Male
    First Name:
    Scott
    Toledo, Oh
    Vehicle:
    2014 Chevrolet Impala Limited
    Weapon R is still around?? LOL.
     
  5. Mar 18, 2012 at 8:49 PM
    #5
    KalamaKid

    KalamaKid Well-Known Member

    Joined:
    Aug 3, 2008
    Member:
    #8323
    Messages:
    5,249
    Gender:
    Male
    First Name:
    Jason
    Socialist Republic of Oregon
    same shit as everyone else
    [​IMG]

    What is the blue fire in the intake for?
     
  6. Mar 18, 2012 at 8:53 PM
    #6
    Fightnfire

    Fightnfire Recklessly tired

    Joined:
    Jun 12, 2011
    Member:
    #58178
    Messages:
    5,804
    Gender:
    Male
    Marysville, WA
    Vehicle:
    09 Access Cab V6 4X4
    Softopper, Bilstein 5100's @ 1.75 in the front, TSB Rear, 17x8.5 Lvl 8 Guardians, 265/70-17 Goodyear Wrangler Duratracs, Scooped, Anytime fog mod, Osram Nightbreakers, LED Interior lights, Debadged, Painted valance, Removed rear head rests, De-flapped, Hidden Hitch installed, Weather Techs, Flyzeye'd A/W/A, Cover Kings,... oh and the hot wife mod.
    It's not fire, it's so cold it appears as ice. This CAI pulls air from the freezer you mount underneath the truck. Most people report 40+ HP. The downside is the freezer mounts under the passenger seat ... every time my wife gets out she's even more of a frigid bitch.

    That was wife approved, she read it and laughed.
     
  7. Mar 18, 2012 at 8:59 PM
    #7
    truckboattruck

    truckboattruck is one of the sharper tools in the shed

    Joined:
    Oct 23, 2010
    Member:
    #45123
    Messages:
    2,277
    Gender:
    Male
    First Name:
    evan
    MD
    Vehicle:
    silver sport
    99superjet 11ktm350

    true love.
     
  8. Mar 18, 2012 at 9:21 PM
    #8
    Fightnfire

    Fightnfire Recklessly tired

    Joined:
    Jun 12, 2011
    Member:
    #58178
    Messages:
    5,804
    Gender:
    Male
    Marysville, WA
    Vehicle:
    09 Access Cab V6 4X4
    Softopper, Bilstein 5100's @ 1.75 in the front, TSB Rear, 17x8.5 Lvl 8 Guardians, 265/70-17 Goodyear Wrangler Duratracs, Scooped, Anytime fog mod, Osram Nightbreakers, LED Interior lights, Debadged, Painted valance, Removed rear head rests, De-flapped, Hidden Hitch installed, Weather Techs, Flyzeye'd A/W/A, Cover Kings,... oh and the hot wife mod.
    That, maybe. Or she just puts up with me.
     
  9. Mar 18, 2012 at 9:39 PM
    #9
    Night

    Night Well-Known Member

    Joined:
    Feb 21, 2011
    Member:
    #51613
    Messages:
    981
    Gender:
    Male
    First Name:
    Mike
    Canada
    Vehicle:
    '11 TRD OR AC MagGrey
    Banks Monster Exhaust, aFe ProGuard 7, 3M Film, UnderCoating, alpine 920 headunit, alpine 6.5 components, 20% tint all around, JL Stealthbox, PDX-V9 Amp, Avid Lightbar, Avid Sliders, Full Metal JackRabbit Tonneau, TRD S/C
    supposedly you get 3x air compared to the original intake. might need some injectors for that thing.


    (just kidding)
     
  10. Mar 18, 2012 at 9:43 PM
    #10
    Axletek

    Axletek Member

    Joined:
    Mar 18, 2012
    Member:
    #75163
    Messages:
    5
    Gender:
    Male
    First Name:
    Bob
    Vehicle:
    06 taco
    Exactly how do you take pictures of a truck running like poo
     
  11. Mar 18, 2012 at 9:45 PM
    #11
    KalamaKid

    KalamaKid Well-Known Member

    Joined:
    Aug 3, 2008
    Member:
    #8323
    Messages:
    5,249
    Gender:
    Male
    First Name:
    Jason
    Socialist Republic of Oregon
    same shit as everyone else
    To see if he has his MAF installed correctly
     
  12. Mar 18, 2012 at 10:17 PM
    #12
    Boost JuNkY

    Boost JuNkY Well-Known Member

    Joined:
    Apr 10, 2011
    Member:
    #54706
    Messages:
    350
    Gender:
    Male
    First Name:
    Billy
    Vancouver, BC
    Vehicle:
    2006 DC SPORT 6MT
    885's, OME Nitros, AP 3" leafs, DTLT's, Magnaflow Exhaust, TRD SS, AFE prodry S, URD Maf Cal, Exedy Clutch, URD TOB, Bhlm, AP winch bumper, Daystar 9" lights, OEM roof rack, Yakima fairing, Bed & rock lights, Sony Sub & Amp, 48" Hi Lift, 4X sliders,
    Good old Weapon R! I still have my old sticker from my honda years that I never put on.
    To the op, most likely a leak in ur maf, or somewhere in the hoses. Does it idle high or low ?
     
  13. Mar 18, 2012 at 10:21 PM
    #13
    Axletek

    Axletek Member

    Joined:
    Mar 18, 2012
    Member:
    #75163
    Messages:
    5
    Gender:
    Male
    First Name:
    Bob
    Vehicle:
    06 taco
    You can only install it one way two bolts opposite sides
     
  14. Mar 18, 2012 at 10:29 PM
    #14
    xtrm23x

    xtrm23x [OP] New Member

    Joined:
    Jun 19, 2009
    Member:
    #18663
    Messages:
    3
    Gender:
    Male
    Oshkosh, Wisconsin
    Vehicle:
    06 SR5 TRD Offroad
    stock
    It idles high low and sometimes it bounces all over. with the stock intake it runs just fine.
     
  15. Mar 18, 2012 at 10:31 PM
    #15
    Axletek

    Axletek Member

    Joined:
    Mar 18, 2012
    Member:
    #75163
    Messages:
    5
    Gender:
    Male
    First Name:
    Bob
    Vehicle:
    06 taco
    Hmm maybe pictures will help
     
  16. Mar 18, 2012 at 10:32 PM
    #16
    blackhawke88

    blackhawke88 wo ai ni bao bei ^_^

    Joined:
    Jan 11, 2009
    Member:
    #12478
    Messages:
    16,670
    Gender:
    Male
    SGV, CA
    Vehicle:
    07 TRD Offroad
    make sure all the vacuum tubes are connected properly too
     
  17. Mar 18, 2012 at 10:39 PM
    #17
    Axletek

    Axletek Member

    Joined:
    Mar 18, 2012
    Member:
    #75163
    Messages:
    5
    Gender:
    Male
    First Name:
    Bob
    Vehicle:
    06 taco
    Anyway yeah the fuel pressure reg connects to a fitting on the intake I don't see that working properly due to lack of vacuum
     
  18. Mar 18, 2012 at 10:43 PM
    #18
    Bishop2Queens6

    Bishop2Queens6 Well-Known Member

    Joined:
    Jun 8, 2011
    Member:
    #57944
    Messages:
    1,317
    Gender:
    Male
    First Name:
    Mike
    SoCal
    Vehicle:
    2009 DCSB MGM
    Afe CAI (removed back to stock intake), TSB 4 leaf pack with Firestone Air Bags and Daystar cradels, 3rd OEM HU, Wranger All Terrain Adventure with Kevlar 265/75/16, Cali raised LED pods, Wheeler Off Road Front Bump Stops.
    Did you pull the neg cable on your battery so that the computer resets ?

    Is your MAF clean and properly connected?

    Double check your vacuum tubes. There is that tiny one that's easy to miss.
     
  19. Mar 18, 2012 at 10:54 PM
    #19
    Axletek

    Axletek Member

    Joined:
    Mar 18, 2012
    Member:
    #75163
    Messages:
    5
    Gender:
    Male
    First Name:
    Bob
    Vehicle:
    06 taco
    The tiny one that goes to the fuel pressure regulator I don't see that working properly with the new intake
     
  20. Mar 19, 2012 at 5:34 AM
    #20
    maineah

    maineah Well-Known Member

    Joined:
    Mar 24, 2011
    Member:
    #53641
    Messages:
    4,145
    Gender:
    Male
    First Name:
    Tim
    Maine
    Vehicle:
    4X4 SR5 V6 6spd
    Vacuum line to the fuel rail only has an effect at full throttle but it sure sounds like the MAF is not reading the air flow properly or there is air getting in past it.
     
To Top