1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Instrument panel and clock lights are out.

Discussion in 'Technical Chat' started by Houstonboy713, Jan 11, 2011.

  1. Jan 11, 2011 at 6:24 PM
    #1
    Houstonboy713

    Houstonboy713 [OP] New Member

    Joined:
    Jan 11, 2011
    Member:
    #49118
    Messages:
    2
    Gender:
    Male
    Vehicle:
    96 Tacoma
    I have a 1996 Tacoma, I have just recently put in a aftermarket radio and HID's on it. When I installed the new radio into the vehicle I have noticed that the clock on the truck had been working which it hadn't been working for awhile. Then I had installed the HID's in the truck and when I went to turn on the headlights to see if they worked the instrument panel and clock didn't work. I also noticed that one of the balace for the light was messed. Could it be that the bad balace had blown a fuse or something. Also, when that one headlight wouldn't turn on my nephew would keep twisting the headlight knob maybe causing something blow??

    Also, the only thing that comes on on the instrument panel is the hand brake light. I also, tried the dimmer and that did no help.

    If anyone has experienced the problem or has a slight idea of what the problem is. Please help. I appreciate yall's time.
     
To Top