1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Jl audio 13tw5

Discussion in 'Audio & Video' started by champagne234, Dec 12, 2009.

  1. Dec 12, 2009 at 1:58 PM
    #1
    champagne234

    champagne234 [OP] Member

    Joined:
    Oct 3, 2009
    Member:
    #23723
    Messages:
    21
    Gender:
    Male
    First Name:
    Jordan
    Louisiana
    Vehicle:
    2ND Gen tacoma
    I recently installed this subwoofer in my truck and i pulled my seat down to check on everything and i noticed that the jl logo on the center of subwoofer has fallen off and there is a small hole where the logo once was i couldn't find the jl symbol anywheres but the sub still sound ok and works fine? should keep it the way it is or send it back to the company i purchased it from? has anyone heard of this problem?
     
  2. Dec 12, 2009 at 8:20 PM
    #2
    TorenApart

    TorenApart Well-Known Member

    Joined:
    May 15, 2008
    Member:
    #6665
    Messages:
    521
    Gender:
    Male
    Vehicle:
    06 Double Cab SR5 TRD Sport
    Toytec Ultimate Lift Kit, Total Chaos UCA's, 18'' Black XD Monster, 285/60R18 Cooper Zeon LTZ, OEM Skid Plate, Weather Tech Floor Mats, Lund Tonneau, Custom 2-tone gray leather, Aero Turbine 2525 muffler with AR25 resonator, Aero Turbine Exhaust Tip, Mr. Marv subwoofer enclosure w/ 2 JL 10W3v2's, AFE Pro Dry S, TRAIN HORNS, Eclipse AVN-6620, Pioneer PRS-D2100T, Hybrid Audio Clarus 6.5'' Front Components, Black Headlight Mod, Tinted tail lights, PL5300 with Eclipse BEC-109
    Was the sub hitting the back of your seat?

    I would definitely send it back... a sub that costs that much should not have that problem.
     
  3. Dec 15, 2009 at 11:23 PM
    #3
    Tony D

    Tony D Well-Known Member

    Joined:
    Nov 8, 2009
    Member:
    #25610
    Messages:
    45
    Gender:
    Male
    First Name:
    Tony
    if it's just the logo.. glue it back on.. use a small amount of super glue
     
  4. Dec 16, 2009 at 11:59 AM
    #4
    champagne234

    champagne234 [OP] Member

    Joined:
    Oct 3, 2009
    Member:
    #23723
    Messages:
    21
    Gender:
    Male
    First Name:
    Jordan
    Louisiana
    Vehicle:
    2ND Gen tacoma
    Tony i would if i could find it! Plus I have contacted JL and they have already taken care of me the sub was shipped off today to get replaced! thanks for your post!
     
  5. Dec 17, 2009 at 12:06 AM
    #5
    Kelson

    Kelson My Truck is Cuter than Yours

    Joined:
    May 13, 2008
    Member:
    #6597
    Messages:
    4,505
    Gender:
    Male
    First Name:
    Kelson
    Honolulu, Hawaii
    Vehicle:
    08 5-Lug Reg. Cab SR5
    SR5 Exterior/Interior (Color matched Front Bumper, Chrome Grille Surround and Chrome Rear Bumper/Silver Scoshe Dash Kit, A/C Bezel, A/C Vent Surround) LED license plate and white interior lights, Wet Okole Seat Covers, iPad in-Dash, JL CL-RLC, JL 13TW5 sub, JL 500/1 Slash V1 amp, JL XR 6.5 Components, Rockford Fosgate 6X9s in Boxes Front XRunner Coils, DJM Control Arms and Rear 4X4 Leafs, Custom 2" Angled Streetacos.com Blocks Front XR Bilstien Struts and Rear XR Bilstien Shocks, CravenSpeen Antennae, RX-8 Rims w/ Fronts:235/40-R18 Sumitomo HTR Rears:245/40-R18 Goodyear Eagle GT, 35% Tint front windows, OEM Sliding Privacy Glass w/ 5% Ceramic Tint, Flowmaster Super 44 dumped before the axle, URD Short Throw Shifter, Door Sill Protectors, Door Edge Guards, OEM Sport Pedals,The Retrofit Source Morimoto Mini D2S Stage III 35W 5K HID Headlights, OEM Fog Lights w/ piss yellow bulbs, OEM Cruise Control, Porsche 944 Bucket Seats, BeefedTaco Skid Plate, Whale
    nice...never had a problem with this lol
     
To Top