1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Just had tranny fluid changed, now gear is holding too long.

Discussion in '2nd Gen. Tacomas (2005-2015)' started by bruce1271, Dec 1, 2009.

  1. Dec 1, 2009 at 2:56 PM
    #1
    bruce1271

    bruce1271 [OP] Well-Known Member

    Joined:
    Oct 1, 2009
    Member:
    #23629
    Messages:
    84
    Gender:
    Male
    Well, I took my 2005 pre-runner into toyota to have the transmission fluid power flushed and changed. I was quoted $155 but when I go there they told me that it was actually $295 because of the World Standard cost and time to check the level etc. I complained to the manager and he said they would do it for $155.

    I picked up my truck and noticed that it seemed to take off from a stop a lot more peppy and powerful. However, when I got on the highway and went to pass someone, It upshifted into third and wouldnt go back to 4th for about 2 seconds after letting off the pedal. That doesn't seem right does it? It wasnt doing that before I took it in for the fluid change. Also, same thing about 10 miles later when coming off a stop light and going down a small hill, It wouldnt shift either from 2nd to 3rd, or 3rd to 4th right away. I felt like it was engine braking.

    I have driven that light 500 times the past year and I dont recall that ever happening before. I have 92,000 miles on the truck. So, either it was wrong before, or its wrong now.

    Any comments?
     
  2. Dec 1, 2009 at 2:57 PM
    #2
    Krazie Sj

    Krazie Sj Resident Jackass

    Joined:
    Oct 9, 2008
    Member:
    #9849
    Messages:
    13,686
    Gender:
    Male
    First Name:
    Power Serge
    LV-426 (Acheron)
    Vehicle:
    07 TRD Off Road 4x4
    Borla Catback Exhaust, Airaid Short Ram Intake, 285x75R16 Mickey Thompson MTZs, 16" Konig Countersteer rims, ARB Bumper, All Pro LT w/Walker Evan Shocks front and back, All Pro expedition leaf pack, 10,000lb Superwinch, Intake Manifold Spacer, Bed Rack with ARB RTT, Rotopack and Hi Lift mounted, Husky Liner mats and an air freshener from 1995.
    Filled incorrectly. Had that happen with mine. Take it back in. It needs to be filled at a certain temperature to be done correctly. Mine wouldn't shift into 5th and would stay in 4th the entire time I was up past 80km/h. (and yes it was in D and not 4th) Got it done right the second time and never encountered that since.
     
  3. Dec 1, 2009 at 3:25 PM
    #3
    bruce1271

    bruce1271 [OP] Well-Known Member

    Joined:
    Oct 1, 2009
    Member:
    #23629
    Messages:
    84
    Gender:
    Male
    Well, I just talked to them and they said its possible that the computer is set back to the factory defaults and the transmission has to re-learn my driving style. But they said to bring it back and go for a test drive with the shop foreman and see what he thinks.
     
  4. Dec 1, 2009 at 4:28 PM
    #4
    bajamoon

    bajamoon Well-Known Member

    Joined:
    Feb 3, 2009
    Member:
    #13269
    Messages:
    5,953
    Gender:
    Male
    First Name:
    STEVE
    Whittier

    did you do it yourself. you sure you put tranny
    fluid in.:rofl:
     
  5. Dec 1, 2009 at 7:10 PM
    #5
    bruce1271

    bruce1271 [OP] Well-Known Member

    Joined:
    Oct 1, 2009
    Member:
    #23629
    Messages:
    84
    Gender:
    Male
    Dealership did it. Who knows what they put in. Better have been WS. Thats what my receipt said anyway.
     
  6. Dec 1, 2009 at 7:46 PM
    #6
    GTVAPSAMTIK

    GTVAPSAMTIK Well-Known Member

    Joined:
    Sep 30, 2009
    Member:
    #23563
    Messages:
    220
    Gender:
    Male
    First Name:
    SOHAIL
    Fort Carson, CO
    Vehicle:
    2010 TRD OFF-ROAD 4X4 Automatic
    EXTANG Tuff WeatherTech Liners Toyota Bed Mat Coverkind Seat Covers
    Well let us know what happened next
     
  7. Dec 2, 2009 at 6:35 AM
    #7
    HondaGM

    HondaGM Roll Tide

    Joined:
    Oct 28, 2009
    Member:
    #25056
    Messages:
    5,769
    Gender:
    Male
    First Name:
    James
    South-Pole
    Vehicle:
    09 DC 4x4 Blown Honda VTEC V8
    trd exhaust,step bars,vent visors,bed lights,tailgate mod
    take to the dealer and make a face like this:mad:.
     
To Top