1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

K&N Cold air intake - Has anyone actually experienced prolonged issues?

Discussion in 'Technical Chat' started by Toyota Tacoma, Jan 15, 2013.

  1. Jan 15, 2013 at 6:41 PM
    #1
    Toyota Tacoma

    Toyota Tacoma [OP] Well-Known Member

    Joined:
    Aug 9, 2010
    Member:
    #41439
    Messages:
    727
    Gender:
    Male
    First Name:
    Brady
    Kelowna, bc
    Vehicle:
    dbl cab long box
    Suspension: -Bilistien 5100's all around -Add a leaf -Firestone ride rite air bags Performance: -K&N cold air -Borla cat back Stereo: -Pioneer AVH-X2500BT head unit -Kenwood 1400 shallow mount 12'' sub in custom box -Alpine 1100 amp -Alpine 400 4 channel -4 energy component 6.5's Wheels/tires: -17x9 with 4.5 backspacing XD hoss rims with 33'' bfTreadwright gaurd dogs and spidertrax spacers Looks: -Satoshi grille made by myself -Hood, front bumper, grille, roof, tailgate and rear bumper plasti-dipped. -BHLM -eyelids -matted out tailights -Tacoma bed mat Small mods : -Trailer 7 pin replaced and moved into bumper beside licence plate -Removed mud flaps -Repainted frame/lower a-arms, skid and rear diff/housing with por15 -Led bulbs -Interior lights replaced with blue led's -Beep on lock added
    I have been researching the k&n cold air lately and keep coming upon these threads and statements assuring everyone they are no good and will cause harm.

    I nor agree or disagree with these statements and accusations but.....

    Has anyone had problems proven to be associated with the filter ? Increased oil consumption, low compression, scored cylinder walls etc? :confused:

    Iv seen charts on silicon levels and such but is it enough to actually cause harm during average use?

    I know the oil will gum up the MAF from time to time but its an easy fix with electronic cleaner spray.

    Thanks!
     
  2. Jan 15, 2013 at 6:43 PM
    #2
    Super Black Taco

    Super Black Taco Well-Known Member

    Joined:
    Jan 7, 2012
    Member:
    #70160
    Messages:
    350
    Gender:
    Male
    First Name:
    Grayson
    Redwood valley, CA
    Vehicle:
    09 TRD SPORT 4x4
    OME 885 1/4 spacers,Dakars, 3* shims,Light Racing UCA BHLM,Wicked Flow Muffler, JL sub, Alpine amp, URD Short Throw Kit, U-Bolt Flip kit, 285/70/17 hankook mt
    I had it for 3 years or so. Never had a problem.
     
  3. Jan 15, 2013 at 6:45 PM
    #3
    Johnsredline

    Johnsredline Well-Known Member

    Joined:
    Jun 1, 2012
    Member:
    #79872
    Messages:
    110
    Gender:
    Male
    North Las Vegas
    Barcelona Red- Method Double Standards, Flowmaster Exhaust, K&N intake, black headlights and raptor style grille, ICON stage 4 suspension, allpro sliders
    I've ran a K&N for a year now and havent had any issues. The tube is dust free, MAF is clean, and it runs like a champ.

    I honestly think all the bad talk of the K&N intakes is from people who improperly oil their filters. K&N has been around a long time and doesnt seem like they have issues in other filters (quads, dirtbikes, go-karts, etc).
     
  4. Jan 15, 2013 at 6:53 PM
    #4
    jeffvt0508

    jeffvt0508 Well-Known Member

    Joined:
    Sep 5, 2011
    Member:
    #62959
    Messages:
    3,671
    Gender:
    Male
    First Name:
    Jeff
    Anderson,SC
    Vehicle:
    '10 Super White Toyota Tacoma PreRunner SR5
    K&N Air Filter, mud flap mod, anti-theft tailgate mod, fog light anytime mod, OEM roof rack, tonneau cover,plasti dip lower valence,Avid Light Bar, Billies 5100, Grillcraft grill, TW sticker,Hi-Lift jack mount
    I ran K&N for 4 yrs on my old truck never had a problem.. installed on my 2010.. and less than 10k and my MAF was messed up.. K&N at fault? I can't say for sure.. but I did remove it..and saw that my charcoal filter was soaked in oil.. ( I never recharged it prior to this date was brand new..)
     
  5. Jan 16, 2013 at 5:19 PM
    #5
    Toyota Tacoma

    Toyota Tacoma [OP] Well-Known Member

    Joined:
    Aug 9, 2010
    Member:
    #41439
    Messages:
    727
    Gender:
    Male
    First Name:
    Brady
    Kelowna, bc
    Vehicle:
    dbl cab long box
    Suspension: -Bilistien 5100's all around -Add a leaf -Firestone ride rite air bags Performance: -K&N cold air -Borla cat back Stereo: -Pioneer AVH-X2500BT head unit -Kenwood 1400 shallow mount 12'' sub in custom box -Alpine 1100 amp -Alpine 400 4 channel -4 energy component 6.5's Wheels/tires: -17x9 with 4.5 backspacing XD hoss rims with 33'' bfTreadwright gaurd dogs and spidertrax spacers Looks: -Satoshi grille made by myself -Hood, front bumper, grille, roof, tailgate and rear bumper plasti-dipped. -BHLM -eyelids -matted out tailights -Tacoma bed mat Small mods : -Trailer 7 pin replaced and moved into bumper beside licence plate -Removed mud flaps -Repainted frame/lower a-arms, skid and rear diff/housing with por15 -Led bulbs -Interior lights replaced with blue led's -Beep on lock added
    Yea the MAF is the only issue I have seen directly related to the CAI and it only takes 10 minutes to clean.
     
To Top