1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

k + N cold air intake

Discussion in '2nd Gen. Tacomas (2005-2015)' started by gaert09, Jul 19, 2008.

  1. Jul 19, 2008 at 8:16 PM
    #1
    gaert09

    gaert09 [OP] Member

    Joined:
    Jun 9, 2008
    Member:
    #7198
    Messages:
    23
    Hurlburt Field Air Force Base
    Vehicle:
    07 Tacoma
    Window Tints, Eyebrow Tint, Bug Deflector, Rain Deflector on windows, K+N Air Filter, under cover over bed,
    I just installed the k + n cold air on my 4cyl tacoma....Im noticing while im in D at a red light or a stop sign, my truck seems to rumble from left to right and it sounds like its going to stall out....Does anyone know why that would happen? Please reply it will be great to find out why this would happen

    thanks alot
     
  2. Jul 19, 2008 at 10:18 PM
    #2
    tacomaman06

    tacomaman06 Carolina Alliance: Enforcer

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,258
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '16 Tundra TRD Pro
    getting there....
    did you double check to make sure the maf sensor is plugged all the way in?? if so.........give it a little time to adjust to the new air flow, it will go back to normal, computer just has to relearn the new mix.:)
     
  3. Jul 19, 2008 at 10:33 PM
    #3
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,158
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    It could also be a vaccume line came loose or disconected. If these symptomes persist, check your lines. :)
     
  4. Jul 19, 2008 at 10:55 PM
    #4
    tacoskim

    tacoskim Tuned By Gadget

    Joined:
    Mar 13, 2008
    Member:
    #5252
    Messages:
    2,385
    Gender:
    Male
    Los Angeles, CA
    Vehicle:
    09 TRD 4x4 Pyrite Mica
    Stock
    is it a rattle noise ??? maybe the heat sheild???

    if its a rumble then check ur lines... if its a rattle re-adjust ur filter and play around with it a little and find a area that wont make it rattle
     
To Top