1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

K&N - Never again!

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Rich8419, Jun 5, 2008.

  1. Jun 5, 2008 at 10:04 AM
    #1
    Rich8419

    Rich8419 [OP] Well-Known Member

    Joined:
    Jan 11, 2008
    Member:
    #4193
    Messages:
    81
    Gender:
    Male
    Louisiana
    Vehicle:
    2009 Dbl Cab Short Bed Offroad Pkg
    weathertech floor liners, scan guage, gatekeeper
    My dad visited me a few weeks ago and bought me a K&N air filter for my new truck. I was going to get an afe but since its from my pops I thought I'd give it a try. I mean its a free air filter and I've never tried a K&N before so whats the harm? Well, the first tank sounded a little heartier but after the subsequent few tanks I've been averaging 1-2 mpg less than before I had the air filter. I opened up the box last night and low and behold there is a sheen of oil residue. Am I loosing my mind or can the oil from the K&N really be this bad?
     
  2. Jun 5, 2008 at 10:17 AM
    #2
    RoadKill

    RoadKill Northern Alliance: padawan

    Joined:
    Apr 1, 2008
    Member:
    #5679
    Messages:
    126
    North of the border
    Vehicle:
    First gen 4x4
    285x70x17 offset rims+ 1.5 spacers, rear Timbrens + 3 inch lift add a leaf, Sway-a-way coilovers + camburg control arms, Fender flares (2.5 inch), clear lights, headers, sliders, roll bar
    Installing CAI could save you on gas millage, that is if you drive like uncle goerge... assuming there is more air availiable, there is more drinking capability if you have heavy foot.
    Was removing pcv necessary to install your kit? could your oil residue be caused by internal engine oil fumes? I'm not sure what you mean with your last comment.:confused:
     
  3. Jun 5, 2008 at 10:21 AM
    #3
    Ridgerunner

    Ridgerunner Well-Known Member

    Joined:
    Mar 14, 2008
    Member:
    #5269
    Messages:
    3,621
    Gender:
    Male
    First Name:
    Frank
    San Francisco
    Vehicle:
    2001 prerunner doublecab limited
    2001 with; cat-back twin exhaust,elbow mod, Westin bullbar with Hella550's, Snugtop XTR camper shell, TRD off-road 2x4-black beauty.
    Did you apply the oil to your filter or was it preoiled-if preoiled it shouldve been lightly and evenly coated. People tend to overoil the filter which causes your problem.
     
  4. Jun 5, 2008 at 10:28 AM
    #4
    luk8272

    luk8272 Poodoo

    Joined:
    Feb 24, 2008
    Member:
    #4929
    Messages:
    5,879
    Gender:
    Male
    First Name:
    Lucas
    Kaplan, Louisiana
    Vehicle:
    07 Silver4dr. 4x4, V6 Shortbed
    5% Tint, Bug flector, vent Visors, Removed secondary air filter, Rear Spring TSB w/ Wheeler's Add A Leaf HD Pack, Icon 2.0 rear shocks, Toytec 3" lift up front with Total Chaos UCA's, Debadged, Billet Grille,TRD Offroad rims/17x9 Pro comp 6001 rims, Duratracs 265/75/16 or 285/70/17, Fog light anytime mod, Tailgate hose clamp mod, Pro-dry AFE filter. Extended Differential Breather, ABS on/off, 6000k LEDs from CSJumper, heads/fogs, ScanguageII, Devil horns, Devil horns on third brake light, Mounted 60" Highlift, Mounted Tool Box, Wet Okole Front/Rear Seat Covers, TW sticker, Midland Handheld CB,Painted engine cover, Revenge Fab Sliders, ARE Topper, Weather tech Floorliners.
    I have used k&N before on my 02 tacoma and never had a loss of mileage or problems with the MAF sensor. The residue you are talking about, could you elaborate. Is it the filter leaking or something other?
     
  5. Jun 5, 2008 at 10:34 AM
    #5
    Rich8419

    Rich8419 [OP] Well-Known Member

    Joined:
    Jan 11, 2008
    Member:
    #4193
    Messages:
    81
    Gender:
    Male
    Louisiana
    Vehicle:
    2009 Dbl Cab Short Bed Offroad Pkg
    weathertech floor liners, scan guage, gatekeeper
    the filter was pre oiled and looks like a bit of oil dripped out of the filter and kinda just swirled around. Maybe I got one that was oiled a little too much from the factory.
     
  6. Jun 5, 2008 at 10:35 AM
    #6
    flavalk

    flavalk 2-Broke 2-Care

    Joined:
    Jan 15, 2007
    Member:
    #729
    Messages:
    148
    Orlando, Florida via Huntsville, Alabama
    Vehicle:
    '07 PreRunner SR5 Double Cab 2WD - Short Bed - Automatic- Silver Mica
    Not much. Toyota bed mat, Toyota step bars, tinted windows, Toyota seat covers, Toyota all-weather mats, quart of Wild Turkey in the glove box, KelTec PT3AT in the center console, backseat full of old speeding tickets

    Every K&N that I have ever seen...for any vehicle, has come pre-oiled. If additional oil was applied, it's gonna make a mess. :(
     
  7. Jun 5, 2008 at 10:45 AM
    #7
    luk8272

    luk8272 Poodoo

    Joined:
    Feb 24, 2008
    Member:
    #4929
    Messages:
    5,879
    Gender:
    Male
    First Name:
    Lucas
    Kaplan, Louisiana
    Vehicle:
    07 Silver4dr. 4x4, V6 Shortbed
    5% Tint, Bug flector, vent Visors, Removed secondary air filter, Rear Spring TSB w/ Wheeler's Add A Leaf HD Pack, Icon 2.0 rear shocks, Toytec 3" lift up front with Total Chaos UCA's, Debadged, Billet Grille,TRD Offroad rims/17x9 Pro comp 6001 rims, Duratracs 265/75/16 or 285/70/17, Fog light anytime mod, Tailgate hose clamp mod, Pro-dry AFE filter. Extended Differential Breather, ABS on/off, 6000k LEDs from CSJumper, heads/fogs, ScanguageII, Devil horns, Devil horns on third brake light, Mounted 60" Highlift, Mounted Tool Box, Wet Okole Front/Rear Seat Covers, TW sticker, Midland Handheld CB,Painted engine cover, Revenge Fab Sliders, ARE Topper, Weather tech Floorliners.
    Have you removed that filter yet? If so does the truck run correctly, I have heard that the abundance of oil on the filter can dirty up the MAF sensor. Here on the site they tell you how to clean it up and make it like new. Hope all goes well.
     
  8. Jun 5, 2008 at 2:36 PM
    #8
    1bad03snake

    1bad03snake Well-Known Member

    Joined:
    May 26, 2008
    Member:
    #6889
    Messages:
    49
    Baytown,TX
    Vehicle:
    4x4 TRD
    none but please give me your info.
    Is the oil brown, black or pink?
     
  9. Jun 5, 2008 at 4:03 PM
    #9
    RedruM29

    RedruM29 Blinking Car Mod...

    Joined:
    Feb 5, 2008
    Member:
    #4594
    Messages:
    607
    Gender:
    Male
    First Name:
    Kyle
    Nor☆Cal
    Vehicle:
    08 trd sport 4x4
    Just enough, and never enough
    i'm sorry but...:worthless:
     
  10. Jun 5, 2008 at 4:12 PM
    #10
    Janster

    Janster Old & Forgetful

    Joined:
    Mar 25, 2007
    Member:
    #1138
    Messages:
    14,253
    Gender:
    Female
    First Name:
    Jandy
    Lancaster, PA
    Vehicle:
    2016 GMC Canyon SLT w/ LineX and....
    I've run K&N's on various vehicles for many years. And like people have already said.... if they're over-oiled, that's when you can have problems. Also - if you don't clean them often enough, you can also have dust getting past it.

    Like 1bad03snake asked...what color is the oil residue?

    K&N's shouldn't be over-oiled from factory, but I guess you never know. Where did your pops buy the filter from?
     
  11. Jun 5, 2008 at 4:14 PM
    #11
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,132
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    I ran a K&N for a long time on my 2000 Tacoma. When I pulled the intake manifold, it had oil all the way to the head. It was the last time I used one.
     
  12. Jun 5, 2008 at 4:48 PM
    #12
    bowzerdoo77

    bowzerdoo77 U.S.M.C.

    Joined:
    Jan 5, 2007
    Member:
    #658
    Messages:
    925
    Gender:
    Male
    Carlsbad CA
    Vehicle:
    2016 DBL CAB 4x4TRD OFF ROAD
    6 inch Pro comp Stage 1 lift 305/70/18 MasterCraft MXT 18x9 Monster wheels,
    :DI have noticed the same thing I thought I got worst mileage with it that with a paper filter I went back too and I only used it for about 5000 miles anybody want to buy one!!! fits the 3.4 ill even clean it and send you the recharge kit
     
  13. Jun 5, 2008 at 4:48 PM
    #13
    bowzerdoo77

    bowzerdoo77 U.S.M.C.

    Joined:
    Jan 5, 2007
    Member:
    #658
    Messages:
    925
    Gender:
    Male
    Carlsbad CA
    Vehicle:
    2016 DBL CAB 4x4TRD OFF ROAD
    6 inch Pro comp Stage 1 lift 305/70/18 MasterCraft MXT 18x9 Monster wheels,
    I meant I got worse mileage not worst mileage!!!!
     
  14. Jun 5, 2008 at 7:54 PM
    #14
    WilsonTheDog

    WilsonTheDog Kylie's dad

    Joined:
    Nov 17, 2007
    Member:
    #3496
    Messages:
    4,837
    Gender:
    Male
    First Name:
    Eric
    Myrtle Beach SC
    Vehicle:
    07 Prerunner SR5 DC/SB V6
    Magnaflow 12576 muffler & chrome tip, Westin step bars, 27% tint, Pop N Lock, AFE ProdryS, bed mat, Husky liners, D-rings added, Access Literider tonneau, Pioneer 4-ways all around, GY Wrangler Duratracs 265/75/16, 5100's @ 1.75", 1.5" AAL
    A very common experience for many (most?) people. I can't prove it but I believe the K&N I had on the CAI in my '05 Altima caused a MAF failure. That was the last straw for K&N for me.

    Get an AEM Dryflow.
     
  15. Jun 5, 2008 at 7:57 PM
    #15
    Ridgerunner

    Ridgerunner Well-Known Member

    Joined:
    Mar 14, 2008
    Member:
    #5269
    Messages:
    3,621
    Gender:
    Male
    First Name:
    Frank
    San Francisco
    Vehicle:
    2001 prerunner doublecab limited
    2001 with; cat-back twin exhaust,elbow mod, Westin bullbar with Hella550's, Snugtop XTR camper shell, TRD off-road 2x4-black beauty.
    I have the dropin too and have repeatedly switched out and in with confusion as to what exactly was I gaining using it. I run paper now and the K&n sits in a box in the garage. With my twin exhaust it just seems more comfortable with the paper.
     
  16. Jun 5, 2008 at 8:04 PM
    #16
    Rosco75

    Rosco75 Well-Known Member

    Joined:
    Apr 3, 2008
    Member:
    #5719
    Messages:
    51
    Clavet Sk
    Vehicle:
    2001 Tacoma SR5 TRD
    3 inch skyjacker lift, k&n FIPK, 33inch procomp mud terrain tires
    Anyone ever run an old truck with the oil bath filter system, Now I know there was no MAF to worry about in those things, but how bad could it be. I put in my FIPK and it sounds so good I can`t keep my foot off it! I know why mileage went down haha
     
  17. Jun 5, 2008 at 8:05 PM
    #17
    WilsonTheDog

    WilsonTheDog Kylie's dad

    Joined:
    Nov 17, 2007
    Member:
    #3496
    Messages:
    4,837
    Gender:
    Male
    First Name:
    Eric
    Myrtle Beach SC
    Vehicle:
    07 Prerunner SR5 DC/SB V6
    Magnaflow 12576 muffler & chrome tip, Westin step bars, 27% tint, Pop N Lock, AFE ProdryS, bed mat, Husky liners, D-rings added, Access Literider tonneau, Pioneer 4-ways all around, GY Wrangler Duratracs 265/75/16, 5100's @ 1.75", 1.5" AAL
    ^Well that's usually the case, Rightfootism. If you're OK with it, stick with it.
     
  18. Jun 5, 2008 at 8:06 PM
    #18
    Ridgerunner

    Ridgerunner Well-Known Member

    Joined:
    Mar 14, 2008
    Member:
    #5269
    Messages:
    3,621
    Gender:
    Male
    First Name:
    Frank
    San Francisco
    Vehicle:
    2001 prerunner doublecab limited
    2001 with; cat-back twin exhaust,elbow mod, Westin bullbar with Hella550's, Snugtop XTR camper shell, TRD off-road 2x4-black beauty.
    There ya go Rosco:D
     
  19. Jun 6, 2008 at 5:22 AM
    #19
    Burns

    Burns Well-Known Member

    Joined:
    Jun 19, 2007
    Member:
    #1871
    Messages:
    3,665
    Gender:
    Male
    NJ
    Vehicle:
    Truck is Sold
    I had a K&N drop in on my 98 taco and it messed up my MAF sensor as well and I will never buy another one of their POS filters again.
     
  20. Jun 6, 2008 at 6:42 AM
    #20
    Cusker

    Cusker Member

    Joined:
    Feb 23, 2008
    Member:
    #4896
    Messages:
    11
    You're going to get oil residue inside the intake tract any place downstream from where the PCV system ties in.

    Anything before that will be caused by something else, such as a K&N filter.
     
To Top