1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Kenwood 5120 Help Please!!

Discussion in '2nd Gen. Tacomas (2005-2015)' started by RDAY, Oct 20, 2009.

  1. Oct 20, 2009 at 10:48 PM
    #1
    RDAY

    RDAY [OP] Well-Known Member

    Joined:
    Dec 18, 2008
    Member:
    #11700
    Messages:
    712
    Gender:
    Male
    NY
    Vehicle:
    07 Tacoma SR5 4x4
    Sorry for the beginner questions but money is tight right now and i dont wanna pay someone to do this. 1st off i bought this used so its confusing me.

    so here is the wiring harness i have for it its the right one right?

    [​IMG]

    and here is the harness that came with it do i need to do anything with the steering wheel controls or is it all set already?

    [​IMG]

    The 1st 1 is the only plug im gonna use right these other ones were prolly from the harness from the previous owners?

    [​IMG]



    [​IMG]

    [​IMG]
     
  2. Oct 20, 2009 at 10:56 PM
    #2
    RDAY

    RDAY [OP] Well-Known Member

    Joined:
    Dec 18, 2008
    Member:
    #11700
    Messages:
    712
    Gender:
    Male
    NY
    Vehicle:
    07 Tacoma SR5 4x4
    and theres more ok it came with these two these the 1st one has the gps plug that plugs into the head unit the 2nd one i dunno where that plug goes or what it is and it says trimble what is it?

    [​IMG]


    [​IMG]
    this is the back of the bluetooth that i have and i also have a hd radio how to i wire it up i have a connector so that the bluetooth or the hd radio can be a circular plug or kindof a square plug.


    [​IMG]




    [​IMG]


    thanks so so so much
     
  3. Oct 21, 2009 at 7:06 AM
    #3
    RDAY

    RDAY [OP] Well-Known Member

    Joined:
    Dec 18, 2008
    Member:
    #11700
    Messages:
    712
    Gender:
    Male
    NY
    Vehicle:
    07 Tacoma SR5 4x4
    anyone? can someone atleast help me out on the gps what is the trimble thing?
     
  4. Oct 21, 2009 at 8:58 AM
    #4
    Evil Monkey

    Evil Monkey There's an evil monkey in my truck

    Joined:
    Aug 8, 2007
    Member:
    #2352
    Messages:
    8,337
    Gender:
    Male
    First Name:
    Robert
    Escondido, CA
    Vehicle:
    07 4x4 DC SR5 TRD Off-road
    Weathertech front & rear mats, rear suspension TSB, Toytec AAL for TSB, Hi-Lift Jack, Bilstein 5100 & Toytec Adjustable coilovers, Built Right UCAs, KMC XD 795 Hoss Wheels, Definity Dakota MTs 285/75R16, Leer XR, Thule Tracker II & Thule MOAB basket
    I'd try posting in the Audio section. It'll get more views by people who know audio components.
     
  5. Oct 21, 2009 at 9:30 AM
    #5
    Viet2100

    Viet2100 Well-Known Member

    Joined:
    Jun 27, 2007
    Member:
    #1930
    Messages:
    2,512
    Gender:
    Male
    First Name:
    Viet
    Delray Beach, FL
    Vehicle:
    2007 Infiniti G35S
    The smaller black plug with all of the wires going into it is your main harness that plugs into your HU. Clip off the other gray colored looking plug, that harness went into the previous owner's vehicle. You will need to match up the color wires to your harness (the pic you posted above of two plugs). I am not sure if his steering wheel control harness is the same as ours though. As for the GPS, they are both GPS antennas. I am not sure why he sent you two different ones, but use the blank one. The satellite radio and bluetooth module boxes are completely different. Each needs their own box.
     
  6. Oct 21, 2009 at 9:35 AM
    #6
    Dark Knight

    Dark Knight Well-Known Member

    Joined:
    Jul 18, 2008
    Member:
    #8006
    Messages:
    9,594
    Gender:
    Male
    First Name:
    Jeff
    NC/SC
    Vehicle:
    4Runner Trail
    You can go to pac-audio to get directions.
     
  7. Oct 21, 2009 at 10:06 AM
    #7
    stormyday

    stormyday Well-Known Member

    Joined:
    Mar 13, 2009
    Member:
    #14641
    Messages:
    146
    Gender:
    Male
    Morganton, NC
    Vehicle:
    14 Taco Double Cab Pre-Runner
    I did my install with a Kenwood unit. Look at the link on my signature. I still have all the documentation.
     
  8. Oct 21, 2009 at 11:11 AM
    #8
    RDAY

    RDAY [OP] Well-Known Member

    Joined:
    Dec 18, 2008
    Member:
    #11700
    Messages:
    712
    Gender:
    Male
    NY
    Vehicle:
    07 Tacoma SR5 4x4
    ok that clears it up quit a bit thanks guys but its not satalite radio its an hd tuner and i was told that you could plug it into the in port on the bluetooth and then plug another wire on the output and run to the head unit is this true?
     
  9. Oct 21, 2009 at 11:12 AM
    #9
    RDAY

    RDAY [OP] Well-Known Member

    Joined:
    Dec 18, 2008
    Member:
    #11700
    Messages:
    712
    Gender:
    Male
    NY
    Vehicle:
    07 Tacoma SR5 4x4
    and i do have the head unit working just havent installed the hd radio and bluetooth also just need to figure out how to progrma the pac swi-jack now
     
  10. Oct 21, 2009 at 3:02 PM
    #10
    stormyday

    stormyday Well-Known Member

    Joined:
    Mar 13, 2009
    Member:
    #14641
    Messages:
    146
    Gender:
    Male
    Morganton, NC
    Vehicle:
    14 Taco Double Cab Pre-Runner
    The first Antenna is a XM or Sirius Antenna (Plastic square plus). The second one is a GPS antenna (trimble).

    Here is the install manual for the radio: http://manual.kenwood.com/files/B54-4670-00.pdf

    Here it is for the HD: http://manual.kenwood.com/files/489165385b2aa.pdf

    My unit (and this one I believe) requires a seperate box to add the HD and SAT. The seperate box connects to the head unit and the HD and SAT connect to it. HD Radio uses the existing antenna.

    The PSI instructions are confusing. Here are the Taco instructions.
    http://76.12.243.71/swixprogramming...mSearch=Toyota&Submit2=Search+Vehicles&ID=354
     
To Top