1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Kenwood DDIN Head Unit Angles Not Working!

Discussion in 'Audio & Video' started by blacksandtaco, May 1, 2009.

  1. May 1, 2009 at 8:54 PM

    blacksandtaco [OP] Well-Known Member

    Feb 21, 2009
    First Name:
    07 Access TRD Sport 4X4
    Viper remote start/alarm, Kenwood Excelon DNX 9140 in -dash Nav and DVD, Anzo black headlight, FoldaCover tonneau cover, BedRug carpeted truck bed, Pop-A-Lock electric tailgate lock, Level 8 MK6 (16x8), Toyo Open Country AT2 (LT265/75R16), Fold-A-Cover Tonneau, Bilstein 5100s front, Rear Leaf Suspension TSB, AVS in-channel front window vents, AVS Aeroskin hood protector,
    Alright so I've searched and searched and I think I know what the problem is. I have both the Scosche and Metra DDIN kits and have tried them both. My Kenwood DNX7140 has 5 tilt angles and a reverse tilt angle. I can't get the screen to tilt to all angles (including reverse) without it scraping the trim piece and getting stuck. I know a lot of people have had this problem and they've sanded down the trim piece to get it to angle freely. Has anyone been able to pull off all angles without adjusting/altering the trim piece?
To Top