1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

keyless remote problem on 2009 tacoma

Discussion in '2nd Gen. Tacomas (2005-2015)' started by surferguy, May 2, 2009.

  1. May 2, 2009 at 5:26 PM
    #1
    surferguy

    surferguy [OP] New Member

    Joined:
    May 2, 2009
    Member:
    #16706
    Messages:
    4
    Gender:
    Male
    Vehicle:
    prerunner
    Bought a 2009 tacoma access cab prerunner recently.The keyless remote worked fine.It automatically locked the doors and the horn would activate as an alarm when the door was opened.The problem was it took 2 chirps to open both doors instead of one.So I saw your site saying how you could get it to open both doors with 1 push of the remote,by opening the doors and putting key into ignition different times within 40 seconds.Well I tried it and now the doors don't lock automatically and the horn doesn't activate as an alarm anymore.The dealer wants $40 to reset everything.Is there a way i can do it?
     
  2. May 2, 2009 at 7:23 PM
    #2
    Taco-NB

    Taco-NB MMMMM Taco's

    Joined:
    May 1, 2009
    Member:
    #16662
    Messages:
    1,744
    Gender:
    Male
    New Brunswick
    Vehicle:
    '09 4X4 SR5 Access Cab V6 - Black Sand Pearl
    Is this what your looking for??

    I found it at this website.

    You can program the remote your self, here are the directions:
    1- key out of the ignition and driver door open
    2- within 40 seconds close and reopen driver door twice and then insert the key into ignition (DONT TURN! just insert) and then remove the key
    3- within 40 seconds close and reopen the driver door twice, insert key in ignition and CLOSE the door
    4-within 40 seconds turn the key from lock to "on" and then back to lock 1 time
    5-remove key
    6-you should see the power dor locks cycle 1 time
    7-you are now in registration mode....on the new remote press and hold BOTH lock and unlock buttons on the remote for about 2 seconds, release both buttons and then press just the lock button on the remote, remote is now registered
    8-to exit registration mode OR if you mess up you can just let the truck sit for 45 seconds or open the driver door to restart.
    Thank you and good luck!
     
  3. May 3, 2009 at 10:53 AM
    #3
    surferguy

    surferguy [OP] New Member

    Joined:
    May 2, 2009
    Member:
    #16706
    Messages:
    4
    Gender:
    Male
    Vehicle:
    prerunner
    thanks,yey I tried that one and the locks did cycle,but my alarm still doesn't work.I even checked to see if the single pin connector under dash next to steering collumn was disconnected that actually turns the keyless remote into an alarm,and it was.So it did work when I bought it.But my mistake was going to custom tacos to change stuff on the remote.I was thinkin of gettin a real alarm already.But thanks for your help.
     
  4. May 3, 2009 at 10:54 AM
    #4
    FlawedXJ

    FlawedXJ mall crawlin', web wheelin', concrete cowboy

    Joined:
    Oct 28, 2008
    Member:
    #10334
    Messages:
    5,961
    Gender:
    Male
    First Name:
    Paul
    NorAla
    Vehicle:
    13 F150 FX4, 99 jeep xj, 04 msm miata
    I actually have a jeep now. Imagine that.
    just unplug the battery. Takes everything like that back to stock.
     
  5. May 4, 2009 at 4:16 PM
    #5
    surferguy

    surferguy [OP] New Member

    Joined:
    May 2, 2009
    Member:
    #16706
    Messages:
    4
    Gender:
    Male
    Vehicle:
    prerunner
    thanks,tried it,but didn't work.
     
  6. May 4, 2009 at 4:43 PM
    #6
    2009tacomav6

    2009tacomav6 Well-Known Member

    Joined:
    Dec 6, 2008
    Member:
    #11323
    Messages:
    385
    Gender:
    Male
    phx AZ
    Vehicle:
    2012 4x4
    TRD SC TRD Cat Back KMC 17x9 Addicts
    damn setup's always gotta get you for something...
     
  7. May 4, 2009 at 4:51 PM
    #7
    Edrin55

    Edrin55 Well-Known Member

    Joined:
    Apr 11, 2009
    Member:
    #15858
    Messages:
    944
    Gender:
    Male
    First Name:
    Ron
    San Diego, CA (Scripps Ranch)
    Vehicle:
    2010 Magnetic Gray TRD Sport Access Cab
    Avid Off Road Light Bar Line-X'd, Black Sand Pearl Hood Scoope, Truck Covers USA metal roll up bed cover, Thule Custom lockable light bar, TRD Sport Exhaust, Line-X'd TRD skid plate, Slee Off Road Sliders, Upgraded 3.5" Rearview Mirror/Monitor, Anytime Foglight Mod. (TY Jeff), Smoked Foglights, SilverStar Headlight & Foglight Bulbs, Tinted windows all around, Vent visors, Bed mat with security mod, Wet Okoles front & back, Race/Sport Pedals, Tailgate Clamps, PopNLcok 5300 Tailgate Lock, All weather mats, Helo 17x8 Hubcentric Rims & BFG All Terrain 265/70/17, Blisteins 5100's all around with mini leaf add to the rears, AFE Pro Dry drop in filter, Go Rhino Hitch Step, TRD License Plate Frames and Tire Valve Covers. GrillCraft MX Mesh upper and lower grills with "old school TOYOTA" FJ emblem, Cobra CB Radio, Firestick CB Antenna with custom mount.
    Its an 09. Its under warranty. Take it back to the dealer and tell them it stopped working on its own. DO NOT ADMIT ANYTHING. If your dealer already knows you did something, take it into another dealer. Warranty work is covered at all dealerships....
     
To Top