1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Leak Question.

Discussion in '1st Gen. Tacomas (1995-2004)' started by LarrysWorld, Jan 2, 2012.

  1. Jan 2, 2012 at 10:58 PM
    #1
    LarrysWorld

    LarrysWorld [OP] 05 Taquito

    Joined:
    Dec 6, 2011
    Member:
    #68276
    Messages:
    213
    Gender:
    Male
    First Name:
    Larry
    Rialto, CA
    Vehicle:
    05 Tacoma Reg Cab
    2in front lift HIDs 15" Steelies
    I have some time of leak from under my engine more towards the back. Don't know what it could be thought someone might have an idea.
    Thanks!
     
  2. Jan 2, 2012 at 11:07 PM
    #2
    LarrysWorld

    LarrysWorld [OP] 05 Taquito

    Joined:
    Dec 6, 2011
    Member:
    #68276
    Messages:
    213
    Gender:
    Male
    First Name:
    Larry
    Rialto, CA
    Vehicle:
    05 Tacoma Reg Cab
    2in front lift HIDs 15" Steelies
    Like a darkish brownish reddish I believe
     
  3. Jan 2, 2012 at 11:13 PM
    #3
    LarrysWorld

    LarrysWorld [OP] 05 Taquito

    Joined:
    Dec 6, 2011
    Member:
    #68276
    Messages:
    213
    Gender:
    Male
    First Name:
    Larry
    Rialto, CA
    Vehicle:
    05 Tacoma Reg Cab
    2in front lift HIDs 15" Steelies
    Too be honest i wouldn't know what it is from smelling it.
    Damn..
     
  4. Jan 3, 2012 at 5:05 AM
    #4
    fsusteve

    fsusteve Well-Known Member

    Joined:
    Sep 8, 2011
    Member:
    #63111
    Messages:
    54
    Gender:
    Male
    First Name:
    Steve
    Naples, Fla
    auto tranny? sounds like burnt tranny fluid but you really need to define your question more or show some pics.
     
  5. Jan 3, 2012 at 7:54 AM
    #5
    fsusteve

    fsusteve Well-Known Member

    Joined:
    Sep 8, 2011
    Member:
    #63111
    Messages:
    54
    Gender:
    Male
    First Name:
    Steve
    Naples, Fla
    could also be a p/s hose/rack leak, check your fluids to see if any are low.
     
  6. Jan 3, 2012 at 8:57 AM
    #6
    TacoMX

    TacoMX TW's Official anti body-lift pundit

    Joined:
    Aug 24, 2011
    Member:
    #62240
    Messages:
    4,834
    Gender:
    Male
    First Name:
    Jonathan
    Deltona, Florida
    Take some brake cleaner and hose off all the oil, then with the area clean try to track down where the leak is coming from.

    Pictures of the leak will also help if you can get some.
     
  7. Jan 3, 2012 at 9:58 AM
    #7
    MacGyvR

    MacGyvR Well-Known Member

    Joined:
    Jul 21, 2010
    Member:
    #40533
    Messages:
    241
    Gender:
    Male
    First Name:
    Tom
    Arizona
    Vehicle:
    03 Prerunner SR5 2wd
    x2

    Have you had any of the fluids changed recently?
     
  8. Jan 3, 2012 at 11:03 AM
    #8
    jbrandt

    jbrandt Well-Known Member

    Joined:
    Feb 12, 2011
    Member:
    #51038
    Messages:
    461
    Gender:
    Male
    Sacramento, CA
    Vehicle:
    '04 TRD Tacoma 4x4
    K&N intake
    Take it to a shop, IMO. If you're not confident enough to know how to tell tranny fluid from oil from coolant, etc... you best just take it to a professional and have them check it out.

    Not trying to bag on the OP, just trying to be realistic. I have no problems taking my truck to a professional when a problem gets beyond my level of comfort.
     
To Top