1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

LIFT QUESTION NEED HELP

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Jays2010Taco, Dec 22, 2011.

  1. Dec 22, 2011 at 7:31 PM
    #1
    Jays2010Taco

    Jays2010Taco [OP] Well-Known Member

    Joined:
    Aug 1, 2010
    Member:
    #41099
    Messages:
    87
    Gender:
    Male
    First Name:
    Jay
    Oahu, Hawaii
    Vehicle:
    10Toyota Tacoma
    6inch Fab-Tech suspension lift
    All,
    I need some help. I am new to the whole Taco nation. I bought a 2010 Taco a little over a year ago. I had it lifted "professionally" with a Fabtech lift. The first time I took it off road I snapped my driver side Tie Rod just by comming of the ground a little bit at the top of a hill I had the Tie Rod replaced. I then stored my Taco for 7 months while deployed. When I was deployed I was told by storage that my truck was leaking fluid, I had a friend take it in to the same place that did my lift and they replaced the seals around the driver side axle. After driving my truck for a week being home I noticed that there was a grinding and rubbing side on the driver side. thought it might be the ball joints took it in to a highly recommended shop, that was when I was told that when my truck was lifted it put stress on my axle and everything on the left side. When I got it lifted I didnt know that you should put adjustable A arms on as well. Were they supposed to put spacers on the axle or anything to compensate for the lift? I need recommendations. Are Taco's known for this or was the job done wrong? I have ordered some adjustable arms and will put them in when they get here so I can get my allignment done, but am I missing anything else?
     
  2. Dec 22, 2011 at 7:35 PM
    #2
    Sunner

    Sunner Well-Known Member

    Joined:
    Nov 7, 2011
    Member:
    #66659
    Messages:
    1,689
    Gender:
    Male
    I have surfed around alot of lift thread and not heard this yet, subbed for solution
     
  3. Dec 22, 2011 at 7:39 PM
    #3
    pataco

    pataco Well-Known Member

    Joined:
    Jan 1, 2009
    Member:
    #12092
    Messages:
    2,070
    Gender:
    Male
    Down by the lake
    Vehicle:
    05 4x4 trd dc white
    FOX 2.0 RESIS,LRUCAS,BILLY 5100S ON THE REAR.MAGNAFLOW 11264,COLOR MATCHED GRILL,YELLOW FOG MOD.OVER HEAD DVD,FEDERAL COURAGIA M/T
    sounds like you snapped more than a tie rod.have to see where the oil is coming from to be sure of whats going on here.
     
To Top