1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Light switch wiring help...

Discussion in 'Technical Chat' started by LonghornTaco, Feb 7, 2009.

  1. Feb 7, 2009 at 9:26 AM
    #1
    LonghornTaco

    LonghornTaco [OP] Can you pass the bailout please?

    Joined:
    Oct 6, 2008
    Member:
    #9763
    Messages:
    3,355
    Gender:
    Male
    First Name:
    Jason
    Minnesota
    Vehicle:
    Black 09 4x4 TRD Off Road Doublecab
    3" ToyTec coilover lift on Bilstein 5100s, Total Chaos UCAs, ToyTec diff drop, Scangauge II, 4D MagLite mounted on the drivers seat, Painted engine cover, Painted calipers (red), Painted skid plate (red) Valentine 1 radar detector hard wired, Damplifier Pro on the floor, back wall and doors, Luxury Liner Pro on the floor and doors, Kenwood DNX8120, 2 Pioneer TS-SW1041D 10" shallow mount subs, 2 Pioneer PRS-D4200F 1200W amps, Mr Marv sub enclosure, Hybrid Audio Clarus 6.5" components in the front doors, Alpine 5.25" coaxials in the rear doors, A.R.E. LSII fiberglass tonneau cover, All Pro bumper, All Pro sliders, Wet Okole seat covers, Sockmonkey Mountain badges, PIAA 510 SMR Driving Lights, Warn M8000 Winch, Bud Built skids
    I have a question about wiring up these switches I got. They function just fine, but the indicator light doesn't light up. I just talked to Tony at Iron Goat 4x4 and found out why it isn't but I'm not 100% sure where to run the wire.

    This is the wiring diagram:
    [​IMG]
    Currently, I'm just using one pole so I have the ground, power in and power out on the 1st pole connected. I don' thave the running lights wired and that's the problem. Since I have my lights running on the battery and independent of the truck running, can I just run this to the same "power in" wire I have from the battery or do I really need to run it to the runing lights (or just some other switched power source)?
     
  2. Feb 7, 2009 at 10:34 AM
    #2
    LonghornTaco

    LonghornTaco [OP] Can you pass the bailout please?

    Joined:
    Oct 6, 2008
    Member:
    #9763
    Messages:
    3,355
    Gender:
    Male
    First Name:
    Jason
    Minnesota
    Vehicle:
    Black 09 4x4 TRD Off Road Doublecab
    3" ToyTec coilover lift on Bilstein 5100s, Total Chaos UCAs, ToyTec diff drop, Scangauge II, 4D MagLite mounted on the drivers seat, Painted engine cover, Painted calipers (red), Painted skid plate (red) Valentine 1 radar detector hard wired, Damplifier Pro on the floor, back wall and doors, Luxury Liner Pro on the floor and doors, Kenwood DNX8120, 2 Pioneer TS-SW1041D 10" shallow mount subs, 2 Pioneer PRS-D4200F 1200W amps, Mr Marv sub enclosure, Hybrid Audio Clarus 6.5" components in the front doors, Alpine 5.25" coaxials in the rear doors, A.R.E. LSII fiberglass tonneau cover, All Pro bumper, All Pro sliders, Wet Okole seat covers, Sockmonkey Mountain badges, PIAA 510 SMR Driving Lights, Warn M8000 Winch, Bud Built skids
    Thanks Phantom! Yes, it's a double pole/single throw. Just a two position on/off and each switch is controlling a single light circuit.

    The diagram above is just what I was thinking... Just jumper over power to the "running lights" connector.

    When I get out there to try it, I'll let you know how it goes.
     
To Top