1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Lights coming on?

Discussion in '2nd Gen. Tacomas (2005-2015)' started by ALBtacoma, Jan 16, 2013.

  1. Jan 16, 2013 at 6:39 AM
    #1
    ALBtacoma

    ALBtacoma [OP] Well-Known Member

    Joined:
    Sep 28, 2012
    Member:
    #87905
    Messages:
    582
    Gender:
    Male
    First Name:
    Pete
    Red deer AB, Canada
    Vehicle:
    07 trail limo trd sport
    So the past few days my marker lights have been coming on while the truck is off and has been parked for awhile. This morning after working out I was going to my truck to leave and the marker and head lights were on and I couldn't start my truck and needed a boost. I have got in my truck while they were on and hit the brake, turned on/off all lights to see if it would reset them and nothing the only way to get them to turn off is to start the truck and then turn it off. Any ideas of what it could be. I'm thinking short but I have no idea of have to chase a short.
     
  2. Jan 16, 2013 at 6:42 AM
    #2
    Jeffvt0508

    Jeffvt0508 Well-Known Member

    Joined:
    Sep 5, 2011
    Member:
    #62959
    Messages:
    13,285
    Gender:
    Male
    First Name:
    Jeff
    Anderson, SC
    Vehicle:
    2015 DCSB 4x4 trd offroad
    Ome 887s, dakars, lr uca,sliders, konig countersteer,
    ... speechless.. don't even have a place for you to start looking for easy fix.. I would take to dealership
     
  3. Jan 16, 2013 at 6:49 AM
    #3
    wolftree

    wolftree Well-Known Member

    Joined:
    Oct 9, 2011
    Member:
    #64877
    Messages:
    684
    Gender:
    Male
    First Name:
    Rick
    Ohio
    Vehicle:
    2011 Tacoma 4x4 Regular cab automatic trans,
    Rear Leaf TSB, Bilstein 5100s, extra leaf added
    Does anyone know if there is a relay for the headlights/ marker lights? That is what it sounds like to me.
     
  4. Jan 16, 2013 at 6:57 AM
    #4
    NicksRig

    NicksRig Well-Known Member

    Joined:
    Oct 14, 2008
    Member:
    #9966
    Messages:
    710
    Gender:
    Male
    Kenora, Ontario
    Vehicle:
    07 Tacoma DC TRD Sport
    Blacked out Skid plate, block heater, bug deflector, blacked out headlights, tinted fronts, OME 3" lift, Toytec AAL, Revenge-Fab Sliders, K&N Air Filter
    I have the same issue. I figured it had something to do with the wiring when the dealership put in the day time running lights. Your the first person I have heard of having the same problem. However it has never killed my battery, and they do go off after varying lengths of time.
     
  5. Jan 16, 2013 at 4:37 PM
    #5
    ALBtacoma

    ALBtacoma [OP] Well-Known Member

    Joined:
    Sep 28, 2012
    Member:
    #87905
    Messages:
    582
    Gender:
    Male
    First Name:
    Pete
    Red deer AB, Canada
    Vehicle:
    07 trail limo trd sport
    This is the first time that my head lights have come on, I've also had my park brake light come while driving. Not sure if its all connected. I don't have day time running lights on my truck so don't think it's that but good to know someone else has this problem
     
  6. Jan 16, 2013 at 4:40 PM
    #6
    BradleyScottETC

    BradleyScottETC Class IV Category 8 Elite VIP Member (Only)

    Joined:
    Aug 2, 2009
    Member:
    #20521
    Messages:
    1,751
    Gender:
    Male
    First Name:
    Bradley
    Lake County, FL
    Vehicle:
    10 4.0 AC 4x4
    There is most certainly a relay for the lights. I'm digging out schematics, please hold.
     
  7. Jan 16, 2013 at 4:41 PM
    #7
    janelle2388

    janelle2388 Well-Known Member

    Joined:
    Dec 30, 2011
    Member:
    #69627
    Messages:
    74
    Gender:
    Male
    First Name:
    Corey
    Montana
    Vehicle:
    09 tacoma access cab SR5
    3 inch icon lift, dual exhaust, 17 inch pro comp rims, tinted tail lights, black badges, BHLM, T-Rex eye lids, 10" alpine type R sub, alpine deck, alpine amp, K&N CAI, icon UCA's, 2" AAL, 32" led light bar
    i had this happen to another vehicle, it was a relay that went so they were always on cause they had always had power going to them. i didnt understand what was going on, had a buddy that worked at a dealer get me a new relay and it never happened again. i dont no if the relay was stuck "open" so it just kept power going to it or what but that did fix it for me. it was a jetta, i no its a different vehicle but maybe its the same thing.
     
  8. Jan 18, 2013 at 6:00 AM
    #8
    ALBtacoma

    ALBtacoma [OP] Well-Known Member

    Joined:
    Sep 28, 2012
    Member:
    #87905
    Messages:
    582
    Gender:
    Male
    First Name:
    Pete
    Red deer AB, Canada
    Vehicle:
    07 trail limo trd sport
    They don't always come just randomly when th truck is off. Does this still point to the relay? Have you found the schematics yet?
     
  9. Jan 20, 2013 at 10:22 AM
    #9
    BradleyScottETC

    BradleyScottETC Class IV Category 8 Elite VIP Member (Only)

    Joined:
    Aug 2, 2009
    Member:
    #20521
    Messages:
    1,751
    Gender:
    Male
    First Name:
    Bradley
    Lake County, FL
    Vehicle:
    10 4.0 AC 4x4
    I would change out the relay first and then hunt for a short... Incase you haven't found the problem yet, here is the schematics for the headlamps.

    em01d7_zps5d21cad8_eb52c97366c8a83467d250b08a68471c961e01d5.jpg

    em01d9_zpse65a47a4_d780faa02b14ec6d90c9de7809f6933063cab6c2.jpg

    em01d2_zpscfe475a3_cad5c0a405d589d9acecc6c063e81791a80a0a33.jpg
     

Products Discussed in

To Top