1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Looking for answers

Discussion in '2nd Gen. Tacomas (2005-2015)' started by toyjack, Jul 12, 2008.

  1. Jul 12, 2008 at 1:54 PM

    toyjack [OP] New Member

    Aug 9, 2007
    Blountville, TN
    Tacoma 4X4 Access cab V-6
    My wife wrecked my 2007 Tacom 4WD access cab, major right front damage.When I picked up my truck I noticed that the 4wd low light was flashing and the airbag light was steady red showing a red ball(Like deployed). Plan to take it in to shop on monday as body work done by another shop. They did use all Toyota parts and they did not know how to reset the computer. I think just computer problem. As damage was right front wheel/fender hub, grille, transmission cooler, radiator headlight. One good thing is what ever the problem is insurance will fix. I just would like to have an idea. Truck is in 2wd, and won't chnge to 4wd when you try to go into 4wd. Any ideas?
  2. Jul 12, 2008 at 2:06 PM

    Janster Old & Forgetful

    Mar 25, 2007
    First Name:
    Lancaster, PA
    2016 GMC Canyon SLT w/ LineX and....
    If the shop can't fix it - CALL YOUR INSURANCE company and tell them the shop can't fix it. You are entitled to getting it fixed completely - but you may need *permission* to take it to a Toyota dealer whom should know what to do. Notice I said.... SHOULD know what to do.
    Sorry to hear about the wreck..... but for the most part, I hope your wife wasn't hurt.
  3. Jul 12, 2008 at 6:55 PM

    ricepow Well-Known Member

    Jun 15, 2008
    08 4x4 TRD Sport
    Look on the top of your front diff. There is a grey plug that gets plugged in. I just had my Tacoma lifted, then took it to Discount Tire to get wheels and tires. When I left Discount Tire the 4LO/4WD was flashing as you described but the truck was in 2WD. I went back to the shop and was looking at it in the parking lot prior to going inside. I noticed this grey plug somehow became unplugged (likely due to the installer when installing the diff drop bracket combined with some vibration, or something that the guys at Discount caused somehow). At any rate, this plug was unplugged. After having it plugged back in the lights went away. All is good. Check that out.
To Top