1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Looking for input on head unit with Idatalink Maestro

Discussion in 'Audio & Video' started by TacoDawgfan, Jan 3, 2020.

  1. Jan 3, 2020 at 6:17 AM
    #1
    TacoDawgfan

    TacoDawgfan [OP] Hunker Down You Hairy Dawg!

    Joined:
    Jan 30, 2011
    Member:
    #50214
    Messages:
    16,843
    Gender:
    Male
    First Name:
    Mike
    Georgia
    Vehicle:
    2011 Silver 4x4 TRD Sport w/JBL
    5100's at 1.75, Rear leaf TSB, Moto Metal 951 16x8, BFG TKO2 265/75/16, AFe Stage 2 CAI w/pro dry filter, Kenwood DDX374BT installed with Idatalink Maestro kit, Access Loredo tonneau cover, N-Fab steps, Tinted windows, EGR in channel vent visors, UGA drink coasters in the front cup holders, and a Graco car seat in the back seat
    I’m in the market for a carplay unit that supports Idatalink Maestro. Looking at a pioneer avh-2500nex and a kenwood ddx6905s. I can get either for about the same price.

    What I am looking for is what vehicle diagnostics I will get through each unit vs the other? Anyone have either unit that can share would be greatly appreciated.

    I have a 2011 DC with JBL with an non carplay Kenwood right now with the Idatalink Maestro and trying to find out if I will gain any more diagnostics from either of the units to help with my decision. Thanks.
     
  2. Jan 3, 2020 at 6:57 AM
    #2
    destin_meeks

    destin_meeks I used to fix people's crappy stereos

    Joined:
    Jul 14, 2017
    Member:
    #223997
    Messages:
    2,645
    Gender:
    Male
    First Name:
    Destin
    Tuscaloosa, AL
    Vehicle:
    2017 SSM DoubleCab TRD Off-Road 4x4
    You will get the same options from all maestro-compatible head units. The maestro RR is doing all the work so any unit that is compatible will show the same info :thumbsup:

    I do a lot of the 2550 and like it for the money. I personally like pioneers menu’s better, but the kenwood is a great unit as wel
     
  3. Jan 3, 2020 at 8:22 AM
    #3
    TacoDawgfan

    TacoDawgfan [OP] Hunker Down You Hairy Dawg!

    Joined:
    Jan 30, 2011
    Member:
    #50214
    Messages:
    16,843
    Gender:
    Male
    First Name:
    Mike
    Georgia
    Vehicle:
    2011 Silver 4x4 TRD Sport w/JBL
    5100's at 1.75, Rear leaf TSB, Moto Metal 951 16x8, BFG TKO2 265/75/16, AFe Stage 2 CAI w/pro dry filter, Kenwood DDX374BT installed with Idatalink Maestro kit, Access Loredo tonneau cover, N-Fab steps, Tinted windows, EGR in channel vent visors, UGA drink coasters in the front cup holders, and a Graco car seat in the back seat
    Yeah I’m torn between the 2. The Kenwood is an Excelon unit, don’t know if that really means anything. But I currently have a Kenwood Ddx374bt if I remember the model number correctly and it just show Tpms, battery voltage, intake temp and I don’t remember what else. Seen on some threads in here where people with high end pioneers had mpgs and such that I don’t get on mine. Thought maybe it was the hu that restricted that?
     
  4. Jan 3, 2020 at 8:41 AM
    #4
    TacoDawgfan

    TacoDawgfan [OP] Hunker Down You Hairy Dawg!

    Joined:
    Jan 30, 2011
    Member:
    #50214
    Messages:
    16,843
    Gender:
    Male
    First Name:
    Mike
    Georgia
    Vehicle:
    2011 Silver 4x4 TRD Sport w/JBL
    5100's at 1.75, Rear leaf TSB, Moto Metal 951 16x8, BFG TKO2 265/75/16, AFe Stage 2 CAI w/pro dry filter, Kenwood DDX374BT installed with Idatalink Maestro kit, Access Loredo tonneau cover, N-Fab steps, Tinted windows, EGR in channel vent visors, UGA drink coasters in the front cup holders, and a Graco car seat in the back seat
    so you have the 2550, let me ask this. One thing I hate about the Kenwood I currently have and scares me about the new one is that the Bluetooth does weird stuff. Like when I get a call the volume will be to low to hear and doesn’t hold the level where I left it. It asks me to pick where I want the call, via the hu, my iPhone, etc. so by the time I choose and turn the volume up a lot of the times the caller hangs up. It pisses my wife off. Sometimes it doesn’t even come through the Bluetooth. Just don’t know if that is a Kenwood issue or that hu but do understand that when plugged in for carplay I shouldn’t have that issue. But I also know I may not feel like taking the time to plug up so don’t want to have that issue. So my question is on the 2550 does the bt work ok without being plugged in for the carplay?
     
  5. Jan 3, 2020 at 9:03 AM
    #5
    destin_meeks

    destin_meeks I used to fix people's crappy stereos

    Joined:
    Jul 14, 2017
    Member:
    #223997
    Messages:
    2,645
    Gender:
    Male
    First Name:
    Destin
    Tuscaloosa, AL
    Vehicle:
    2017 SSM DoubleCab TRD Off-Road 4x4
    i think (and I may be wrong) that has more to do with the year of the truck and less to do with the radio. Your signature says you have a 2011 and I'm not sure what all info is carried on that data system for the maestro to read
     
  6. Jan 3, 2020 at 9:06 AM
    #6
    destin_meeks

    destin_meeks I used to fix people's crappy stereos

    Joined:
    Jul 14, 2017
    Member:
    #223997
    Messages:
    2,645
    Gender:
    Male
    First Name:
    Destin
    Tuscaloosa, AL
    Vehicle:
    2017 SSM DoubleCab TRD Off-Road 4x4
    i havent experienced bluetooth issues yet for the 50+ units I've installed of the 2550. no client has come back with anything yet and its been out for quite a while.

    bluetooth does work without the USB cable, but carplay does not. you'd need to step up to the 4500 to get wireless carplay
     
  7. Jan 3, 2020 at 10:12 AM
    #7
    TacoDawgfan

    TacoDawgfan [OP] Hunker Down You Hairy Dawg!

    Joined:
    Jan 30, 2011
    Member:
    #50214
    Messages:
    16,843
    Gender:
    Male
    First Name:
    Mike
    Georgia
    Vehicle:
    2011 Silver 4x4 TRD Sport w/JBL
    5100's at 1.75, Rear leaf TSB, Moto Metal 951 16x8, BFG TKO2 265/75/16, AFe Stage 2 CAI w/pro dry filter, Kenwood DDX374BT installed with Idatalink Maestro kit, Access Loredo tonneau cover, N-Fab steps, Tinted windows, EGR in channel vent visors, UGA drink coasters in the front cup holders, and a Graco car seat in the back seat
    That’s what I figured. May be that the ones I saw with more info were 3rd gens?

    The one thing that scares me about Pioneer is I keep reading about people’s back up camera stop working when shifted into reverse after a few months of installation. It works with the button but not with shifting. And I’ve read this on every single pioneer model I’ve researched. I wouldn’t think that would be a problem with the unit but haven’t seen that on any other brands reviews, but on many different pioneer model reviews.
     
  8. Jan 4, 2020 at 2:36 PM
    #8
    TacoDawgfan

    TacoDawgfan [OP] Hunker Down You Hairy Dawg!

    Joined:
    Jan 30, 2011
    Member:
    #50214
    Messages:
    16,843
    Gender:
    Male
    First Name:
    Mike
    Georgia
    Vehicle:
    2011 Silver 4x4 TRD Sport w/JBL
    5100's at 1.75, Rear leaf TSB, Moto Metal 951 16x8, BFG TKO2 265/75/16, AFe Stage 2 CAI w/pro dry filter, Kenwood DDX374BT installed with Idatalink Maestro kit, Access Loredo tonneau cover, N-Fab steps, Tinted windows, EGR in channel vent visors, UGA drink coasters in the front cup holders, and a Graco car seat in the back seat
    I just ordered the avh-1440nex. Wanted the larger screen on the 2550 but found a deal and couldn’t justify $75 more for a half inch more of screen. Found it on Fry’s for $224. Best I could find on the 2550 was about $300.
     
  9. Jan 4, 2020 at 2:44 PM
    #9
    Sammie

    Sammie :D :P ;)

    Joined:
    Nov 14, 2016
    Member:
    #202417
    Messages:
    8,794
    Gender:
    Female
    Charlotte, NC
    Vehicle:
    ‘17 Tacoma BBP
    I wish I’d known that before getting the one I have.
     
  10. Jan 4, 2020 at 2:52 PM
    #10
    Sammie

    Sammie :D :P ;)

    Joined:
    Nov 14, 2016
    Member:
    #202417
    Messages:
    8,794
    Gender:
    Female
    Charlotte, NC
    Vehicle:
    ‘17 Tacoma BBP
    I can’t remember the model I have off the top of my head. I’ll look when I get home tomorrow. This is what mine shows. Just recently learned it shows when the doors open.

    A63F8D5E-90FC-41D7-972F-5B8E20315BF9.jpg
    D4FCCD22-518D-4BAF-8E6A-BF61C11E7A34.jpg
     
  11. Jan 4, 2020 at 3:53 PM
    #11
    TacoDawgfan

    TacoDawgfan [OP] Hunker Down You Hairy Dawg!

    Joined:
    Jan 30, 2011
    Member:
    #50214
    Messages:
    16,843
    Gender:
    Male
    First Name:
    Mike
    Georgia
    Vehicle:
    2011 Silver 4x4 TRD Sport w/JBL
    5100's at 1.75, Rear leaf TSB, Moto Metal 951 16x8, BFG TKO2 265/75/16, AFe Stage 2 CAI w/pro dry filter, Kenwood DDX374BT installed with Idatalink Maestro kit, Access Loredo tonneau cover, N-Fab steps, Tinted windows, EGR in channel vent visors, UGA drink coasters in the front cup holders, and a Graco car seat in the back seat
    Fucking Frys just called me and cancelled my order, said they don’t have It in stock. Why the fuck is it listed on the site then? Plus they already sent tracking info. Wtf!
     
  12. Jan 4, 2020 at 4:51 PM
    #12
    destin_meeks

    destin_meeks I used to fix people's crappy stereos

    Joined:
    Jul 14, 2017
    Member:
    #223997
    Messages:
    2,645
    Gender:
    Male
    First Name:
    Destin
    Tuscaloosa, AL
    Vehicle:
    2017 SSM DoubleCab TRD Off-Road 4x4
    They do that a lot. Have for years. They mark stuff down a huge amount, over sell their inventory, then cancel orders.
     

Products Discussed in

To Top