1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Loose Radiator

Discussion in '2nd Gen. Tacomas (2005-2015)' started by PSJ, Dec 22, 2011.

  1. Dec 22, 2011 at 6:01 PM

    PSJ [OP] Prerunners Work

    Nov 9, 2008
    Sebastian Inlet
    09 Access Cab Prerunner
    Rear Leaf spring TSB, Bilstein 5100's all around w/ front set at 1.75", 265/75R/16 Mickey Thompson Baja STZ's, Trailer hitch w/custom wiring, AFE drop in dry filter, Rear Diff breather mod, Debadged truck, customized stock TRD wheel center caps, added factory fog lights, bed mat, door sills, tinted windows
    I just did my 30,000 mile maintenance schedule, and as a note on the prior oil change I noticed a little "dripage" from the line running from the radiator cap to the overflow tank- where it connects to the overflow tank- and I noticed it again at the 30K maintenance schedule. As I was cleaning the radiator fluid that had dripped from the line and had dried on the outside of the tank, I realized the radiator itself was loose from the frame of the truck, at the bottom attachment points. Lucky for me, I ordered a part for the truck and while I was at the dealer they tightened the bolts up. Just thought I would pass this along as it seems this is a "assembly issue" with my truck, as I have not done anything with this truck that would cause the radiator to be loose from the truck frame.
To Top