1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Lots of Squeaking in my front end

Discussion in '2nd Gen. Tacomas' started by Eyesofdeath13F, Sep 1, 2011.

  1. Sep 1, 2011 at 6:49 PM
    #1
    Eyesofdeath13F

    Eyesofdeath13F [OP] New Member

    Joined:
    Sep 1, 2011
    Member:
    #62745
    Messages:
    2
    Gender:
    Male
    First Name:
    Jeremy
    Olympia, WA
    Vehicle:
    06 Tacoma TRD offroad
    6 inch fab-tec lift 36" BF Goodrich MT KN Cold Air Intake ARB Bump with Warren Winch
    Looking for advice on what could be causing all the squeaking in my front suspension. I have a 06 Tacoma double-cab with a 6 inch fabtec lift. It sounds as if the bushing need to be replaced as well as the haft shafts and shocks. Does anyone know where I can buy a replacement bushing kit? Do I need one from Fab-tec or will something else work? Any help would be greatly appreciated.
     
  2. Sep 1, 2011 at 6:52 PM
    #2
    jhodge83

    jhodge83 Any dog under 50# is a cat and cats are useless... Thor

    Joined:
    Apr 27, 2007
    Member:
    #1432
    Messages:
    26,978
    Gender:
    Male
    First Name:
    Jamie
    Moncks Corner, SC
    Vehicle:
    09 Timberland Mica DC 4WD Sport
    wat?
    are you using stock or aftermarket UCAs?
     
  3. Sep 1, 2011 at 6:53 PM
    #3
    Blackshirts

    Blackshirts Well-Known Member

    Joined:
    Feb 24, 2010
    Member:
    #32057
    Messages:
    3,906
    Gender:
    Male
    First Name:
    Mike
    TX
    Vehicle:
    09 PreRunner
    Headlight mod, sound system. MB Motor Sport Rims. Black Tails. 5100's, 885, grill craft, Fogs, N-Fab Step Sides. BFG TKO Tires, Wet Oks, LED map lights and dome, LED gauge mod
    Welcome to TW
     
  4. Sep 1, 2011 at 7:06 PM
    #4
    Eyesofdeath13F

    Eyesofdeath13F [OP] New Member

    Joined:
    Sep 1, 2011
    Member:
    #62745
    Messages:
    2
    Gender:
    Male
    First Name:
    Jeremy
    Olympia, WA
    Vehicle:
    06 Tacoma TRD offroad
    6 inch fab-tec lift 36" BF Goodrich MT KN Cold Air Intake ARB Bump with Warren Winch
  5. Sep 1, 2011 at 7:08 PM
    #5
    dYL0n

    dYL0n ระดับอาวุโส สมาชิกอาวุโส

    Joined:
    Jan 14, 2011
    Member:
    #49250
    Messages:
    1,356
    Gender:
    Male
    First Name:
    Dyl0n
    New Orleans, LA
    Vehicle:
    2wd. Auto. Cool Suspension.
    Maxtrac Spindles Fox 2.0 Coilovers TC UCA's All Pro Expo Fox 2.0 rear
    upper control arms
     
  6. Sep 1, 2011 at 7:09 PM
    #6
    jhodge83

    jhodge83 Any dog under 50# is a cat and cats are useless... Thor

    Joined:
    Apr 27, 2007
    Member:
    #1432
    Messages:
    26,978
    Gender:
    Male
    First Name:
    Jamie
    Moncks Corner, SC
    Vehicle:
    09 Timberland Mica DC 4WD Sport
    wat?

    ^^this. if you dont know if they're stock or not, pics would help.
     
  7. Nov 18, 2013 at 9:25 AM
    #7
    BrandonDean

    BrandonDean Member

    Joined:
    Nov 5, 2013
    Member:
    #115964
    Messages:
    8
    Gender:
    Male
    I may have found the issue to the front end squeaking. (time will tell) When the hood is open and you bounce the truck you cant hear a thing the second i closed the hood the noise came right back. Couldn't find where anything was scratching until we looked at the hood latch. Paint was being scrapped off the bottom of the hook so my guess is that is was metal to metal noise from the front. After adding some lube i have not heard it in now 24hrs. Im sure when it dries again it will come right back so ill need to figure out a way to adjust it or see if toyota knows how to adjust the latch. Ill be back if it ends up not being the solution.
     
To Top