1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Maint. Reqd light won't reset.

Discussion in 'Technical Chat' started by luk8272, Oct 24, 2008.

  1. Oct 24, 2008 at 11:30 PM
    #1
    luk8272

    luk8272 [OP] Poodoo

    Joined:
    Feb 24, 2008
    Member:
    #4929
    Messages:
    5,832
    Gender:
    Male
    First Name:
    Lucas
    Kaplan, Louisiana
    Vehicle:
    07 Silver4dr. 4x4, V6 Shortbed
    5% Tint, Bug flector, vent Visors, Removed secondary air filter, Rear Spring TSB w/ Wheeler's Add A Leaf HD Pack, Icon 2.0 rear shocks, Toytec 3" lift up front with Total Chaos UCA's, Debadged, Billet Grille,TRD Offroad rims/17x9 Pro comp 6001 rims, Duratracs 265/75/16 or 285/70/17, Fog light anytime mod, Tailgate hose clamp mod, Pro-dry AFE filter. Extended Differential Breather, ABS on/off, 6000k LEDs from CSJumper, heads/fogs, ScanguageII, Devil horns, Devil horns on third brake light, Mounted 60" Highlift, Mounted Tool Box, Wet Okole Front/Rear Seat Covers, TW sticker, Midland Handheld CB,Painted engine cover, Revenge Fab Sliders, ARE Topper, Weather tech Floorliners.
    Would anyone have any idea what else I could try? Light came on at midnight so I went ahead and tried to reset it no luck so I went and put some gas then tried again to reset it with no luck. What else would cause this light to come on and stay lit? It is late so I am going to bed I'll look into it more after I wake up, been at the casino in kinder since 1pm and just got home gonna take a nap now. Thanks for the help.
     
  2. Oct 24, 2008 at 11:30 PM
    #2
    MsTRD

    MsTRD hell yes i love my truck

    Joined:
    Sep 15, 2008
    Member:
    #9244
    Messages:
    3,367
    Gender:
    Female
    First Name:
    Samantha
    Rohnert Park, CA
    Vehicle:
    06 White Prerunner TRD Sport
    you might need to change your oil
     
  3. Oct 25, 2008 at 2:22 AM
    #3
    Janster

    Janster Old & Forgetful

    Joined:
    Mar 25, 2007
    Member:
    #1138
    Messages:
    13,796
    Gender:
    Female
    First Name:
    Jandy
    Lancaster, PA
    Vehicle:
    2007 4.0L 4x4 TRD Sport Access Cab A
    Advantage Torza top (tri-fold), Husky floor mats, RuffTuff seat covers, C2C hood struts, Homelink mirror, USA Spec PA15-Toy (120gig Classic & 8gig nano), Garmin Nuvi 660, Protecta Bed mat, Pop-n-lock, TSB Springs, Scangauge II, Heated drivers seat, Fumoto drain valve, Aries pushbar, PIAA 540 fog lights, Hood scoop grahics, Flowmaster 50 series dual catback exhaust, RainX Latitude windshield wipers, Husky rear floor liner (ontop of folded down seats). Console Vault.
    Not trying to disprove your intelligence, but how are you attempting to reset it?

    You're supposed to press on the trip meter button and hold it. Turn the key to ON position (while continuing to hold the trip button in) and keep holding it. Don't let that button up until after you see a progression of 3 dashes, 2 dashes, then one dash and no dashes. Then - finally let the button up.

    If that doesn't reset it - then perhaps there's another forum of maitenance that needs done and/or the button doesn't work and should be taken to the dealer for a check-up. Still under warrantee? Get the computer codes checked.
     
  4. Oct 25, 2008 at 6:57 AM
    #4
    luk8272

    luk8272 [OP] Poodoo

    Joined:
    Feb 24, 2008
    Member:
    #4929
    Messages:
    5,832
    Gender:
    Male
    First Name:
    Lucas
    Kaplan, Louisiana
    Vehicle:
    07 Silver4dr. 4x4, V6 Shortbed
    5% Tint, Bug flector, vent Visors, Removed secondary air filter, Rear Spring TSB w/ Wheeler's Add A Leaf HD Pack, Icon 2.0 rear shocks, Toytec 3" lift up front with Total Chaos UCA's, Debadged, Billet Grille,TRD Offroad rims/17x9 Pro comp 6001 rims, Duratracs 265/75/16 or 285/70/17, Fog light anytime mod, Tailgate hose clamp mod, Pro-dry AFE filter. Extended Differential Breather, ABS on/off, 6000k LEDs from CSJumper, heads/fogs, ScanguageII, Devil horns, Devil horns on third brake light, Mounted 60" Highlift, Mounted Tool Box, Wet Okole Front/Rear Seat Covers, TW sticker, Midland Handheld CB,Painted engine cover, Revenge Fab Sliders, ARE Topper, Weather tech Floorliners.
    MsTrd I don't go by the dealer specs, my oil is changed, I just had to wait for the light to come on to turn it off.

    Janster No problem I thought the same thing so after it failed the first time I pulled out the book. I had done it correctly but still have the light.
     
  5. Oct 25, 2008 at 7:27 AM
    #5
    tdm156

    tdm156 Well-Known Member

    Joined:
    Apr 24, 2008
    Member:
    #6166
    Messages:
    590
    Gender:
    Male
    San Antonio, TX
    Vehicle:
    2009 DC 4x4 SR5**Sold
    You dont have to wait for the light to come on to reset it either. When you change your oil....reset it...no worries
     
  6. Oct 25, 2008 at 7:35 AM
    #6
    luk8272

    luk8272 [OP] Poodoo

    Joined:
    Feb 24, 2008
    Member:
    #4929
    Messages:
    5,832
    Gender:
    Male
    First Name:
    Lucas
    Kaplan, Louisiana
    Vehicle:
    07 Silver4dr. 4x4, V6 Shortbed
    5% Tint, Bug flector, vent Visors, Removed secondary air filter, Rear Spring TSB w/ Wheeler's Add A Leaf HD Pack, Icon 2.0 rear shocks, Toytec 3" lift up front with Total Chaos UCA's, Debadged, Billet Grille,TRD Offroad rims/17x9 Pro comp 6001 rims, Duratracs 265/75/16 or 285/70/17, Fog light anytime mod, Tailgate hose clamp mod, Pro-dry AFE filter. Extended Differential Breather, ABS on/off, 6000k LEDs from CSJumper, heads/fogs, ScanguageII, Devil horns, Devil horns on third brake light, Mounted 60" Highlift, Mounted Tool Box, Wet Okole Front/Rear Seat Covers, TW sticker, Midland Handheld CB,Painted engine cover, Revenge Fab Sliders, ARE Topper, Weather tech Floorliners.
    silverback07 Double checked that the second time I tried.

    tdm156 Thats good to know.

    I am thinking maybe there is some other reason it is on. However I have checked all fluid levels and the gas cap to make sure it is on correctly. Thought I had read that somewhere. All my lights work. Nothing seems out of place. If I brought it to autozone and got them to read the codes would that maybe point me in the direction are or these 2 things not related.
     
  7. Oct 25, 2008 at 7:37 AM
    #7
    tdm156

    tdm156 Well-Known Member

    Joined:
    Apr 24, 2008
    Member:
    #6166
    Messages:
    590
    Gender:
    Male
    San Antonio, TX
    Vehicle:
    2009 DC 4x4 SR5**Sold
    I had the dealer show me how to reset it sitting on the lot brand new and I reset it again when I had the oil changed for the first time and about to do it again in about 2 weeks. Good luck with your issues with the reset.
     
  8. Oct 25, 2008 at 8:38 AM
    #8
    luk8272

    luk8272 [OP] Poodoo

    Joined:
    Feb 24, 2008
    Member:
    #4929
    Messages:
    5,832
    Gender:
    Male
    First Name:
    Lucas
    Kaplan, Louisiana
    Vehicle:
    07 Silver4dr. 4x4, V6 Shortbed
    5% Tint, Bug flector, vent Visors, Removed secondary air filter, Rear Spring TSB w/ Wheeler's Add A Leaf HD Pack, Icon 2.0 rear shocks, Toytec 3" lift up front with Total Chaos UCA's, Debadged, Billet Grille,TRD Offroad rims/17x9 Pro comp 6001 rims, Duratracs 265/75/16 or 285/70/17, Fog light anytime mod, Tailgate hose clamp mod, Pro-dry AFE filter. Extended Differential Breather, ABS on/off, 6000k LEDs from CSJumper, heads/fogs, ScanguageII, Devil horns, Devil horns on third brake light, Mounted 60" Highlift, Mounted Tool Box, Wet Okole Front/Rear Seat Covers, TW sticker, Midland Handheld CB,Painted engine cover, Revenge Fab Sliders, ARE Topper, Weather tech Floorliners.
    Any more ideas out there?
     
  9. Oct 25, 2008 at 11:43 AM
    #9
    Janster

    Janster Old & Forgetful

    Joined:
    Mar 25, 2007
    Member:
    #1138
    Messages:
    13,796
    Gender:
    Female
    First Name:
    Jandy
    Lancaster, PA
    Vehicle:
    2007 4.0L 4x4 TRD Sport Access Cab A
    Advantage Torza top (tri-fold), Husky floor mats, RuffTuff seat covers, C2C hood struts, Homelink mirror, USA Spec PA15-Toy (120gig Classic & 8gig nano), Garmin Nuvi 660, Protecta Bed mat, Pop-n-lock, TSB Springs, Scangauge II, Heated drivers seat, Fumoto drain valve, Aries pushbar, PIAA 540 fog lights, Hood scoop grahics, Flowmaster 50 series dual catback exhaust, RainX Latitude windshield wipers, Husky rear floor liner (ontop of folded down seats). Console Vault.
    Sounds like it's a trip to the dealer (under warrantee)....
     
  10. Oct 25, 2008 at 3:04 PM
    #10
    luk8272

    luk8272 [OP] Poodoo

    Joined:
    Feb 24, 2008
    Member:
    #4929
    Messages:
    5,832
    Gender:
    Male
    First Name:
    Lucas
    Kaplan, Louisiana
    Vehicle:
    07 Silver4dr. 4x4, V6 Shortbed
    5% Tint, Bug flector, vent Visors, Removed secondary air filter, Rear Spring TSB w/ Wheeler's Add A Leaf HD Pack, Icon 2.0 rear shocks, Toytec 3" lift up front with Total Chaos UCA's, Debadged, Billet Grille,TRD Offroad rims/17x9 Pro comp 6001 rims, Duratracs 265/75/16 or 285/70/17, Fog light anytime mod, Tailgate hose clamp mod, Pro-dry AFE filter. Extended Differential Breather, ABS on/off, 6000k LEDs from CSJumper, heads/fogs, ScanguageII, Devil horns, Devil horns on third brake light, Mounted 60" Highlift, Mounted Tool Box, Wet Okole Front/Rear Seat Covers, TW sticker, Midland Handheld CB,Painted engine cover, Revenge Fab Sliders, ARE Topper, Weather tech Floorliners.
    Thats it I went to autozone knowing that the OBDII port would have nothing to do with this but hey why not. Well I was right. So off to the dealer they told me that I didn't know how to reset it so I said would you show me. Ha ha, it didn't work for them either. They pulled it to the back and it returned seconds later and the tech said he just tried it again and it worked not sure what was going on. I guess i'll see if it is ok in about 5k more miles. Thanks for the input everyone.
     
  11. Oct 26, 2008 at 4:10 AM
    #11
    Janster

    Janster Old & Forgetful

    Joined:
    Mar 25, 2007
    Member:
    #1138
    Messages:
    13,796
    Gender:
    Female
    First Name:
    Jandy
    Lancaster, PA
    Vehicle:
    2007 4.0L 4x4 TRD Sport Access Cab A
    Advantage Torza top (tri-fold), Husky floor mats, RuffTuff seat covers, C2C hood struts, Homelink mirror, USA Spec PA15-Toy (120gig Classic & 8gig nano), Garmin Nuvi 660, Protecta Bed mat, Pop-n-lock, TSB Springs, Scangauge II, Heated drivers seat, Fumoto drain valve, Aries pushbar, PIAA 540 fog lights, Hood scoop grahics, Flowmaster 50 series dual catback exhaust, RainX Latitude windshield wipers, Husky rear floor liner (ontop of folded down seats). Console Vault.
    Gotta love it when you proove them wrong.....:D
     
To Top