1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

maintenance required

Discussion in 'Performance and Tuning' started by mel, Aug 25, 2011.

  1. Aug 25, 2011 at 6:44 PM
    #1
    mel

    mel [OP] Member

    Joined:
    Aug 4, 2011
    Member:
    #61167
    Messages:
    17
    Gender:
    Male
    suffolk, va
    Vehicle:
    07xrunner
    So I recently got my xrunner and my maintenance required light came on yesterday then it went away and now today its staying on... I don't know why it would come on so early any suggestions on what it could be
     
  2. Aug 25, 2011 at 6:46 PM
    #2
    Us3r

    Us3r Reading...

    Joined:
    Aug 16, 2011
    Member:
    #61833
    Messages:
    139
    Gender:
    Male
    First Name:
    Mike
    Socali
    Vehicle:
    98 Tacoma Std. 2RZ-FE 2WD
    Axle wrap mod (Shackled), 140 Amp Alternator & Wires, HID Headlights, Brush Guard Grille, Hella 550 Driving Lights. |Saving:Total Chaos.|
    lol serious?


    cause it hates you

















    give us more details man.

    thats like shooting flys in the damn dark. trying to tell you what it is.

    want to make it easier on yourself? shoot over to autozone oreily or whatever auto store you got for a free obd scan.
     
  3. Aug 25, 2011 at 6:48 PM
    #3
    Konaborne

    Konaborne Pineapples on pizza Hawaiian does not it make.

    Joined:
    Nov 21, 2010
    Member:
    #46536
    Messages:
    31,864
    Gender:
    Male
    First Name:
    Cody
    Kealakekua, Hawaii
    Vehicle:
    Lifted 00 TRD Off-Road
    fox extended travel remote resivoir coilovers, 14" eibach 600lb coils, All Pro tubular chromoly 1" uniball upper control arms, All Pro expedition leaf packs, 10" bilstein 5150 piggyback reservoir shocks 265/75r16 Goodyear wrangler MT/R kevlars wrapped around 16" Helo 791 gloss black, Mini H1 retrofits with 6000k bulbs, 18" magnaflow w/custom exhaust reroute various decals, Sockmonkey retro hood stripes
    try get a scan, it could be hundreds of different things.
    thousands

    centillions.
     
  4. Aug 25, 2011 at 6:48 PM
    #4
    KPT

    KPT sees what you did there.

    Joined:
    Sep 3, 2009
    Member:
    #22227
    Messages:
    32,383
    Gender:
    Male
    Vehicle:
    09 Prerunner
    Katskin leather interior, Satoshi grille, Bilstein 5100's @ 1.75, rear leaf TSB, magnaflow exhaust, 18x9 BBS RW's, 275/65/18 Nitto TG's, black headlights, black taillights, Hella Supertones, weathertechs, EFX tri-fold tonneau, n-Fab steps
    I believe your owners manual will tell you what's going on and how to reset it.

    Im going to take a shot in the dark and say this is a used truck and they didnt reset it at the last oil change.
     
  5. Aug 25, 2011 at 6:49 PM
    #5
    KPT

    KPT sees what you did there.

    Joined:
    Sep 3, 2009
    Member:
    #22227
    Messages:
    32,383
    Gender:
    Male
    Vehicle:
    09 Prerunner
    Katskin leather interior, Satoshi grille, Bilstein 5100's @ 1.75, rear leaf TSB, magnaflow exhaust, 18x9 BBS RW's, 275/65/18 Nitto TG's, black headlights, black taillights, Hella Supertones, weathertechs, EFX tri-fold tonneau, n-Fab steps
    Maintenance light, not check engine light fellas.
     
  6. Aug 25, 2011 at 6:53 PM
    #6
    Konaborne

    Konaborne Pineapples on pizza Hawaiian does not it make.

    Joined:
    Nov 21, 2010
    Member:
    #46536
    Messages:
    31,864
    Gender:
    Male
    First Name:
    Cody
    Kealakekua, Hawaii
    Vehicle:
    Lifted 00 TRD Off-Road
    fox extended travel remote resivoir coilovers, 14" eibach 600lb coils, All Pro tubular chromoly 1" uniball upper control arms, All Pro expedition leaf packs, 10" bilstein 5150 piggyback reservoir shocks 265/75r16 Goodyear wrangler MT/R kevlars wrapped around 16" Helo 791 gloss black, Mini H1 retrofits with 6000k bulbs, 18" magnaflow w/custom exhaust reroute various decals, Sockmonkey retro hood stripes
    damn. I have a case of teh dumbs today.
     
  7. Aug 25, 2011 at 7:05 PM
    #7
    Us3r

    Us3r Reading...

    Joined:
    Aug 16, 2011
    Member:
    #61833
    Messages:
    139
    Gender:
    Male
    First Name:
    Mike
    Socali
    Vehicle:
    98 Tacoma Std. 2RZ-FE 2WD
    Axle wrap mod (Shackled), 140 Amp Alternator & Wires, HID Headlights, Brush Guard Grille, Hella 550 Driving Lights. |Saving:Total Chaos.|
    dittoness
     
  8. Jan 5, 2012 at 2:01 PM
    #8
    XD40SC

    XD40SC Well-Known Member

    Joined:
    Dec 28, 2011
    Member:
    #69537
    Messages:
    93
    Gender:
    Male
    First Name:
    Davis
    South Carolina
    Vehicle:
    10' PreRunner SR5 Black Sand Pearl
    Hoping this is the same thing for mine. I only have put 1800 miles on my Tacoma since buying it. Its an 2010 and I have a feeling they didn't reset at last oil change. Called up to get service records(mofo's didnt put in an oil sticker) to find out last oil change and I am not due for another 1000 or so miles. Probably just going to do a reset and keep fingers crossed.
     
  9. Jan 5, 2012 at 2:03 PM
    #9
    sean266

    sean266 Moderator Staff Member

    Joined:
    Mar 21, 2011
    Member:
    #53447
    Messages:
    16,492
    Gender:
    Male
    First Name:
    Sean
    Denver area
    Vehicle:
    14' Tundra TRD Crewmax
    Toytec BOSS Tundra Kit Black Tundra badges Window tint Stubby antenna Interior LED's Reverse LED's Center console mag light mod Center console gun holster mod LP leds Switched out chrome mirror caps/exterior door handles to black OEM. Nitto Terra Grappler G2's MotoMetal 971 18x9 wheels Ammo can mod TRDPro headlights ADD "Venom" side steps
    Just reset the light AFTER you've confirmed the oil is g2g
     
  10. Jan 5, 2012 at 2:24 PM
    #10
    XD40SC

    XD40SC Well-Known Member

    Joined:
    Dec 28, 2011
    Member:
    #69537
    Messages:
    93
    Gender:
    Male
    First Name:
    Davis
    South Carolina
    Vehicle:
    10' PreRunner SR5 Black Sand Pearl
    Just talked to them. I have over 1000 miles before I am due for an oil change. They must have just forgotten to reset it. Thanks
     
To Top