1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

meguiars hot tire shine

Discussion in 'Detailing' started by coffeesnob, Aug 17, 2010.

  1. Aug 17, 2010 at 4:08 PM
    #1
    coffeesnob

    coffeesnob [OP] Well-Known Member

    Joined:
    Feb 7, 2010
    Member:
    #30892
    Messages:
    8,068
    Gender:
    Male
    VA
    Vehicle:
    2010 access 4 cyl 2 wd
    Anyone have trouble with the sprayers on the hot tire shine bottle from Meguiars? I bought a bottle and three squirts and it quit working, sent Meguiars a note and they sent me a new bottle, two squirts and that one quit working too. Called the company today but I think the guy who answered didn't really care.
     
  2. Aug 17, 2010 at 4:10 PM
    #2
    blackhawke88

    blackhawke88 wo ai ni bao bei ^_^

    Joined:
    Jan 11, 2009
    Member:
    #12478
    Messages:
    16,670
    Gender:
    Male
    SGV, CA
    Vehicle:
    07 TRD Offroad
    just take the two bottles you have and pour them into a spray bottle u have laying around your house
     
  3. Aug 17, 2010 at 4:11 PM
    #3
    tacomaman06

    tacomaman06 Carolina Alliance: Enforcer

    Joined:
    May 1, 2007
    Member:
    #1475
    Messages:
    26,258
    Gender:
    Male
    First Name:
    Will
    York,South Carolina
    Vehicle:
    '16 Tundra TRD Pro
    getting there....
    i dont use the spray tire stuff, but i know what you are talking about. they use some cheap bottles.

    maybe try meguiars endurance tire shine....its awesome....and its good to use a sponge with it. also....may wanna try some aerospace 303....awesome stuff, a lil expensive...but gives a lil shine and protects very well.
     
  4. Aug 17, 2010 at 4:33 PM
    #4
    mattleegee

    mattleegee Well-Known Member

    Joined:
    Mar 21, 2010
    Member:
    #33672
    Messages:
    513
    Gender:
    Male
    Tacoma, WA
    Vehicle:
    04 350z
    no problems with mine... only used it like 3 times
     
  5. Aug 17, 2010 at 4:35 PM
    #5
    Incognito

    Incognito μολὼν λαβέ

    Joined:
    May 25, 2009
    Member:
    #17626
    Messages:
    13,625
    Gender:
    Male
    First Name:
    Colton
    VA
    Vehicle:
    2012 Pyrite AC TRD OR
    See Build thread
    X2
     
  6. Aug 18, 2010 at 2:34 AM
    #6
    coffeesnob

    coffeesnob [OP] Well-Known Member

    Joined:
    Feb 7, 2010
    Member:
    #30892
    Messages:
    8,068
    Gender:
    Male
    VA
    Vehicle:
    2010 access 4 cyl 2 wd

    Yes, thats is what I am doing. I'm just getting tired of everything being so cheaply made.
     
  7. Aug 18, 2010 at 4:54 AM
    #7
    MattN03

    MattN03 Well-Known Member

    Joined:
    Jan 14, 2009
    Member:
    #12571
    Messages:
    716
    Gender:
    Male
    First Name:
    Matt
    Bluegrass State
    Vehicle:
    07 DC 4x4 TRD Off-Road
    20% window tint, beep mod, hardwired V1, TSB springs, AVS Bugshield-21803, USA Spec PA15, OEM Tacoma scuff plates, Weathertech mats, Truxedo LoPro, TRD skid, GY Duratrac's 265/75/16 C Range, locker mod (switch method)
    I'm using their Hot Shine in an aerosol can and never had an issue. Try calling Meguiar's again and asking them to switch your bad bottle for an aerosol version. Their Customer Service is top notch!
     
To Top