1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Mini D2s Retrofit high beam sticking!!

Discussion in 'Lighting' started by DubVtundy, Jan 22, 2013.

  1. Jan 22, 2013 at 2:52 PM
    #1
    DubVtundy

    DubVtundy [OP] ERMAHGERD

    Joined:
    May 30, 2010
    Member:
    #38082
    Messages:
    1,440
    Gender:
    Male
    First Name:
    Thayer
    Keyser West Virginia
    Vehicle:
    2010 white double cab
    8 inch alcan custom leaf packs, ome 885's powdercoated white, bilstein 5100's all the way around with 12 inch travel on the rear, Light Racing Upper Control Arms, Sway bar removed, 17x9 kmc strike. 35x12.50 nitto Trail Grapplers. Satoshi Grill made by (homertaco), Black Headlight housings,retrofits, Tinted Tailights, color matched grill, Bought a TRD sport hood,elite off road front plate bumper,elite off road sliders, 13% tint on the front windows, 5% on top of the facotry rear windows and back glass, 5% tint stip across the windshield, Lo Pro Truxedo tonneu cover, Herculiner bed liner, Weather Tech Window Visors, Exhaust- Flowmaster Super 44 dumped above rear axle, Maglight Mount on side of drivers seat, Scangauge II, Mossy Oak Camo Seat Covers, Weather Tech Floor mats, Spatter painted A-Pillars, Spatter painted headunit trim and shifter trim, Headunit= Pioneer 4300 double din touch screen, Speakers- Precision Power 3 way component stage, Precision Power 8 i
    alright i have the mini d2s projectors from the retrofitsource and my passenger side high beam is sticking when i go to turn my low beams back on. can figure out why its doing this. if i get out an tap my headlight housing it will drop down. the only thing i can think of is it would be the sheild inside the projector itself not coming down. anyone else ever had this happen. dont know what to do. i dont want to pull my housings apart again but im thinking thats the only way im going to fix this.
     
  2. Jan 22, 2013 at 3:14 PM
    #2
    XXFattyHunterXX

    XXFattyHunterXX Well-Known Member

    Joined:
    Sep 18, 2012
    Member:
    #87200
    Messages:
    119
    Gender:
    Male
    Westminster, Colorado
    Vehicle:
    TRD OffRoad
    I think its a solenoid problem, I'd say call TRS. Just installed mine.
     
  3. Jan 22, 2013 at 8:05 PM
    #3
    Ronn

    Ronn Well-Known Member

    Joined:
    Oct 5, 2010
    Member:
    #44253
    Messages:
    201
    Gender:
    Male
    First Name:
    Ron
    Northern Ontario
    Vehicle:
    2007 DCLB 4x4 SR5
    Westin bullbar, KC slimlites, Mini D2S headlight retrofit, 5100 front @ 1.75 and 5100 rear, Wheelers HD leaf pack
    I had the same issue with my retrofit that I'm doing now, while testing the projectors I noticed one shield was getting stuck on the high position. It would only happen every so often and if I cycled it a few more times it would eventually go up.

    The problem was a small burr on the arm that actuates the shield which slides on the plunger. The burr was sometimes getting caught on the plunger and sticking would result.

    I called TRS today and talked to Andrew, he told me to take the projector apart, file down the burr or apply graphite lubricant. I filed it down and now it works great. I will have pictures of what I did in my retrofit thread. Good luck.
     
  4. Jan 23, 2013 at 7:40 AM
    #4
    DubVtundy

    DubVtundy [OP] ERMAHGERD

    Joined:
    May 30, 2010
    Member:
    #38082
    Messages:
    1,440
    Gender:
    Male
    First Name:
    Thayer
    Keyser West Virginia
    Vehicle:
    2010 white double cab
    8 inch alcan custom leaf packs, ome 885's powdercoated white, bilstein 5100's all the way around with 12 inch travel on the rear, Light Racing Upper Control Arms, Sway bar removed, 17x9 kmc strike. 35x12.50 nitto Trail Grapplers. Satoshi Grill made by (homertaco), Black Headlight housings,retrofits, Tinted Tailights, color matched grill, Bought a TRD sport hood,elite off road front plate bumper,elite off road sliders, 13% tint on the front windows, 5% on top of the facotry rear windows and back glass, 5% tint stip across the windshield, Lo Pro Truxedo tonneu cover, Herculiner bed liner, Weather Tech Window Visors, Exhaust- Flowmaster Super 44 dumped above rear axle, Maglight Mount on side of drivers seat, Scangauge II, Mossy Oak Camo Seat Covers, Weather Tech Floor mats, Spatter painted A-Pillars, Spatter painted headunit trim and shifter trim, Headunit= Pioneer 4300 double din touch screen, Speakers- Precision Power 3 way component stage, Precision Power 8 i

    well lemme know when you do your write up so i can see whats causing the problem cuz its pretty frustrating when you go and spend all that money on a good set of headlights and then 3 months later they start doing this shit. makes me think as bad as my hids were i wish i still had them. atleast they worked the way they were supposed to
     
  5. Jan 23, 2013 at 10:41 AM
    #5
    Ronn

    Ronn Well-Known Member

    Joined:
    Oct 5, 2010
    Member:
    #44253
    Messages:
    201
    Gender:
    Male
    First Name:
    Ron
    Northern Ontario
    Vehicle:
    2007 DCLB 4x4 SR5
    Westin bullbar, KC slimlites, Mini D2S headlight retrofit, 5100 front @ 1.75 and 5100 rear, Wheelers HD leaf pack
    I'm still not done my retrofit but I do have some pictures for you so I'll post them in your thread.

    1. Start by removing your projector from the headlight housing. You will have to take off your shroud.

    2. Next loosen the 4 bolts on the outer edges that hold on the housing for the lens. You'll end up with this:
    [​IMG]
    3. This is the part we're interested in, cycle the shield with your finger gently and see if it's getting caught somewhere. It could be directly on the plunger, or binding on the outer edges where the shield goes into those little holes or it could be hitting the back. Look for any uneven wear or shiny metal, that will tell you if it's rubbing somewhere.
    [​IMG]
    4. If it is in fact binding on the plunger take that part off the housing by loosening these two screws on the side:
    [​IMG]
    5. Once that is off, take off the small wire by gently bending it out of the hole on the side.
    6. Feel the top/bottom of the part that slides on the plunger and if it has a small lip/burr on it, file it down.
    [​IMG]
    7. You could add graphite lubricant to it if you want, it's up to you. I didn't and it works great.
    8. Re-assemble in reverse order. Just to note there are no little washers or spring loaded clips that will fly off while doing this. The only thing that is spring loaded is the plunger so take care when removing.
     
To Top