1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

More rusty frames

Discussion in '1st Gen. Tacomas (1995-2004)' started by Ryanp, May 7, 2012.

  1. May 7, 2012 at 10:28 PM
    #1
    Ryanp

    Ryanp [OP] Member

    Joined:
    Feb 12, 2012
    Member:
    #72715
    Messages:
    16
    Gender:
    Male
    So when I was changing my shocks yesterday I noticed a nice rust hole in the frame of my truck it's 2001 excab and I live in Canada is there any recall on these every where I look it keeps just misdirecting me. I'm sure someone else out there has had this same issue and knows of some steps I should take into getting this taken care of
     
  2. Jun 24, 2012 at 11:50 PM
    #2
    Ryanp

    Ryanp [OP] Member

    Joined:
    Feb 12, 2012
    Member:
    #72715
    Messages:
    16
    Gender:
    Male
    Anybody???
     
  3. Jun 25, 2012 at 6:36 AM
    #3
    FishinTaco

    FishinTaco Well-Known Member

    Joined:
    Mar 24, 2011
    Member:
    #53612
    Messages:
    246
    Gender:
    Male
    First Name:
    D'Arcy
    Sudbury, ON
    Vehicle:
    TRD 4x4 5spd
    5100's all the way around, OME 880's and AAL, BF's 265/75R16. Switched beds from Stepside to Fleetside
    Hey Ryan, just search around on this forum. There is a lot of info on it as many of us have been through the frame issues.

    Cheers, dc
     
  4. Jun 25, 2012 at 6:53 AM
    #4
    98tacoma27

    98tacoma27 :POOPCORN: Staff Member

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    48,163
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5, 88 SR5 PU, 98 TRD OR (CRUSHED)
    5100's all on fours
To Top