1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

My LED Build - What am I missing?

Discussion in '1st Gen. Tacomas' started by scotrinaf, Feb 10, 2012.

  1. Feb 10, 2012 at 6:12 PM
    #1
    scotrinaf

    scotrinaf [OP] Well-Known Member

    Joined:
    Jan 24, 2012
    Member:
    #71311
    Messages:
    1,475
    Gender:
    Male
    First Name:
    Scott
    Blountville, TN
    Vehicle:
    04 PreRunner TRD SR5 4x2 2.7L
    Leer 100XQ, Yakima Roof Racks
    I'm expanding my LED build by adding 10 LED's in cup holders, glove box and above the 12 volt power ports. The links below were provided by another member RAPR (his build is here), but I modified them for the Blue LED's that I'm doing, you can also do amber, green, white, red, etc...

    I'll have some extra wire and splicers on hand when doing this install.

    My plan is to tap into the dashboard dimmer switch, then go to the toggle switch so that I can turn them off when going down the road, but still be able to dim them if they are too bright...

    Here's what I've purchased:

    The WAGO clamps
    http://www.ebay.com/itm/5-Wago-222-4...item20aefae732
    [​IMG]

    LED holders (a must buy): (I used a 1/4" drill bit which worked perfectly)
    http://www.ebay.com/itm/390380286829...84.m1423.l2649
    [​IMG]

    LED'S:
    http://www.ebay.com/itm/10-pcs-LED-...037?pt=LH_DefaultDomain_0&hash=item4ab2a4f155
    [​IMG]


    Toggle Switch:
    http://www.oznium.com/scion-switch-led

    [​IMG]
     
  2. Feb 16, 2012 at 4:57 PM
    #2
    scotrinaf

    scotrinaf [OP] Well-Known Member

    Joined:
    Jan 24, 2012
    Member:
    #71311
    Messages:
    1,475
    Gender:
    Male
    First Name:
    Scott
    Blountville, TN
    Vehicle:
    04 PreRunner TRD SR5 4x2 2.7L
    Leer 100XQ, Yakima Roof Racks
    So, here's a picture after the first phase of my install... Now I can easily add LED's anywhere I want in the truck using the Quick Connects I bought.

    I put 1 LED in the front cupholder that will light that set of 2 holders, then 1 LED in each of the others underneath the rubber flaps on Northwest "corner" of the cupholder. Though that might help prevent glare in my eyes while driving at night... I have enough problems with halos from my LASIK surgery.

    I also put 1 LED in the lower center console! :)

    Future LED locations include the glove box and replacing the A/C controls with blue LED's.

    [​IMG]
     
  3. Feb 16, 2012 at 5:02 PM
    #3
    STLharry

    STLharry Lube: It's the key to penetration.

    Joined:
    Oct 11, 2008
    Member:
    #9899
    Messages:
    1,832
    Gender:
    Male
    First Name:
    Harry
    VT
    Vehicle:
    01 5VZ-FE TRD 5spd
    '95-'97 style Grille/Hood/Taillights/Tailgate decals, ARB bull bar, Rock sliders, Custom rear tube bumper, King Coilovers with Icon neoprene spring condoms, OME Rear Suspension: CS046R leafs with N85 shocks, NWOR greasable shackles/spring pins and OME hardware; IPF H4 lenses and bulbs, IPF 968 DCG 100W fog lights, CB radio, Aussie-spec FJ60 inclinometer, ARB CKMA12 compressor; ARB-mounted 4' Hi-Lift, Deckplate mod, Grey Wire mod, Dif Breather Extension, Dif Drop Kit, Sway bar removed, Duratrac tires, Sockmonkey bedside decals, Boat cupholder
    Do like.
     
  4. Feb 16, 2012 at 5:02 PM
    #4
    scotrinaf

    scotrinaf [OP] Well-Known Member

    Joined:
    Jan 24, 2012
    Member:
    #71311
    Messages:
    1,475
    Gender:
    Male
    First Name:
    Scott
    Blountville, TN
    Vehicle:
    04 PreRunner TRD SR5 4x2 2.7L
    Leer 100XQ, Yakima Roof Racks
    1 odd phenomenon that I can't quite figure out... When I connected the LED's to the dimmer, when I turned the dimmer to the lowest/off setting, the LED's lit up, when I turned the dimmer to the highest/on setting, the LED's went off... I'm a former electrician on high voltage, but this low voltage stuff messes with my head... any guesses?

    For now I just tapped into the hot with a piggyback connection. 1 cool thing is that by doing that, when I lock/unlock my truck, all the LED's flash which looks pretty awesome!
     
  5. Feb 16, 2012 at 5:13 PM
    #5
    Brad H

    Brad H Well-Known Member

    Joined:
    Jul 14, 2009
    Member:
    #19684
    Messages:
    45
    Gender:
    Male
    Portland, ME
    Vehicle:
    01 4x4 SR5
    Deck Plate, Marlin Crawler Rear Bumper, All-Pro APEX Front Bumper and Skids, Bilstein 5100s All Around, Eibach Springs, Wheelers 5Pak w/ AAL, '01 Tundra Front Brakes, CBI Bolt-on Sliders, More to come
    My guess is if you have it tapped before the switch then that resistance goes up and sends the juice to the LED side of the circuit. However, I'm not an electrician by any means, just a couple basic electronic classes under my belt.
     
  6. Feb 16, 2012 at 5:18 PM
    #6
    BEEFY_CHEESY_TACO

    BEEFY_CHEESY_TACO DUDE MAN BRO

    Joined:
    Mar 28, 2010
    Member:
    #34112
    Messages:
    818
    Gender:
    Male
    First Name:
    Hot Carl!!!
    Roy UT
    Vehicle:
    2010 TRD-Off Road TACO Extra value package
    Icon Ext Travel w/ Resi Front and rear, Dakar leaf springs, total chaos UCA's, color matched rear bumper, color matched satoshi grille with black chrome TRD emblem, konig countersteer offroads (black) w/ 285/75 Duratracs, sockmonkey Trailiens 3rd tail light cover, Tacomaworld.com sticker (made by me), debadged all around, Relentless Front Bumper, Sliders, Rear bumper, and bed bars with Yakima rack w/ full size spare, shovel, hi-lift
    This...all the dimmer switch is, is a variable resistor. Sounds like you may have just tapped into the wrong side of the switch. Kind of hard to tell without a visual schematic of the system...
     
  7. Feb 16, 2012 at 5:24 PM
    #7
    scotrinaf

    scotrinaf [OP] Well-Known Member

    Joined:
    Jan 24, 2012
    Member:
    #71311
    Messages:
    1,475
    Gender:
    Male
    First Name:
    Scott
    Blountville, TN
    Vehicle:
    04 PreRunner TRD SR5 4x2 2.7L
    Leer 100XQ, Yakima Roof Racks
    There were three wires coming out, one that was always hot, one that went on off with the switch, then one I'm assuming that was the ground...???

    Also, I did put a switch on them so I can turn them on/off at my leisure...
    In my high voltage electrical experience, you have a hot feeding the switch, and a "switched" leg leaving the switch... For a resistance based switch, there had to be a neutral (ground) coming from it which explains the 3rd wire... Why it's going in the opposite direction of dim/full as the dashboards LED's I installed, I have no idea... LOL
     
  8. Feb 16, 2012 at 5:34 PM
    #8
    BEEFY_CHEESY_TACO

    BEEFY_CHEESY_TACO DUDE MAN BRO

    Joined:
    Mar 28, 2010
    Member:
    #34112
    Messages:
    818
    Gender:
    Male
    First Name:
    Hot Carl!!!
    Roy UT
    Vehicle:
    2010 TRD-Off Road TACO Extra value package
    Icon Ext Travel w/ Resi Front and rear, Dakar leaf springs, total chaos UCA's, color matched rear bumper, color matched satoshi grille with black chrome TRD emblem, konig countersteer offroads (black) w/ 285/75 Duratracs, sockmonkey Trailiens 3rd tail light cover, Tacomaworld.com sticker (made by me), debadged all around, Relentless Front Bumper, Sliders, Rear bumper, and bed bars with Yakima rack w/ full size spare, shovel, hi-lift
    If you havent already check the wire you believe to be the ground, any variable resistor switches I've seen dont have a ground. Power just runs through it and grounds out later in the circuit. Its kind of driving me nuts cause I cant actually SEE this thing lol...
     
  9. Feb 16, 2012 at 6:08 PM
    #9
    scotrinaf

    scotrinaf [OP] Well-Known Member

    Joined:
    Jan 24, 2012
    Member:
    #71311
    Messages:
    1,475
    Gender:
    Male
    First Name:
    Scott
    Blountville, TN
    Vehicle:
    04 PreRunner TRD SR5 4x2 2.7L
    Leer 100XQ, Yakima Roof Racks
    Okay, this isn't the exact switch, but it's comparable... And the guy in the forum where I found this did say that there is a ground in it...???

    [​IMG]
     
  10. Feb 16, 2012 at 6:22 PM
    #10
    BEEFY_CHEESY_TACO

    BEEFY_CHEESY_TACO DUDE MAN BRO

    Joined:
    Mar 28, 2010
    Member:
    #34112
    Messages:
    818
    Gender:
    Male
    First Name:
    Hot Carl!!!
    Roy UT
    Vehicle:
    2010 TRD-Off Road TACO Extra value package
    Icon Ext Travel w/ Resi Front and rear, Dakar leaf springs, total chaos UCA's, color matched rear bumper, color matched satoshi grille with black chrome TRD emblem, konig countersteer offroads (black) w/ 285/75 Duratracs, sockmonkey Trailiens 3rd tail light cover, Tacomaworld.com sticker (made by me), debadged all around, Relentless Front Bumper, Sliders, Rear bumper, and bed bars with Yakima rack w/ full size spare, shovel, hi-lift
    hmmm.... I'm not sure then, this one has me stumped.
     
  11. Feb 16, 2012 at 6:22 PM
    #11
    IGO4LOW

    IGO4LOW Well-Known Member

    Joined:
    Dec 13, 2011
    Member:
    #68720
    Messages:
    712
    Gender:
    Male
    First Name:
    Zach
    Fullerton, CA
    Vehicle:
    2011 DCLB TRD SPORT 4x4 w/ JBL Audio
    3" Procomp lift, 285/70 R17 Nitto Terra Grapplers on Procomp series 6005 wheels, Fog lights on Anytime mod, illuminated oem fog switch, bed mat, all weather floormats, CB Radio in dash, alternating turn signal mod, automatic center console light. Blacked out badges, D2s in the grille.
    I had this problem when I put different color leds in my oem fog switch to differentiate on and off. Here's a link to the thread I posted about my prob. http://www.tacomaworld.com/forum/2n...og-light-indicator-questions-help-please.html
    What I found after alittle more research I found that the leds all need to be the same voltage and have the correct size resistor wired to them. Those two things gave me the exact same problem. This website fixed myproblem maybe it will help you too. Just put in the info and if will design your wiring guide. http://led.linear1.org/led.wiz
     
  12. Feb 16, 2012 at 6:25 PM
    #12
    BEEFY_CHEESY_TACO

    BEEFY_CHEESY_TACO DUDE MAN BRO

    Joined:
    Mar 28, 2010
    Member:
    #34112
    Messages:
    818
    Gender:
    Male
    First Name:
    Hot Carl!!!
    Roy UT
    Vehicle:
    2010 TRD-Off Road TACO Extra value package
    Icon Ext Travel w/ Resi Front and rear, Dakar leaf springs, total chaos UCA's, color matched rear bumper, color matched satoshi grille with black chrome TRD emblem, konig countersteer offroads (black) w/ 285/75 Duratracs, sockmonkey Trailiens 3rd tail light cover, Tacomaworld.com sticker (made by me), debadged all around, Relentless Front Bumper, Sliders, Rear bumper, and bed bars with Yakima rack w/ full size spare, shovel, hi-lift
    Interesting...So each LED needs its own resistor in line with it to make the dimmer switch work with them?
     
  13. Feb 16, 2012 at 6:32 PM
    #13
    IGO4LOW

    IGO4LOW Well-Known Member

    Joined:
    Dec 13, 2011
    Member:
    #68720
    Messages:
    712
    Gender:
    Male
    First Name:
    Zach
    Fullerton, CA
    Vehicle:
    2011 DCLB TRD SPORT 4x4 w/ JBL Audio
    3" Procomp lift, 285/70 R17 Nitto Terra Grapplers on Procomp series 6005 wheels, Fog lights on Anytime mod, illuminated oem fog switch, bed mat, all weather floormats, CB Radio in dash, alternating turn signal mod, automatic center console light. Blacked out badges, D2s in the grille.
    If they aren't 12volt leds then yes. Your truck is all 12v and those leds are prob around 2.6vf. Which is why when the dimmer switch is all the way down the leds are super bright. Turn up the dimmer you get way to much voltage to the leds so they turn off.
     
  14. Feb 16, 2012 at 7:13 PM
    #14
    BEEFY_CHEESY_TACO

    BEEFY_CHEESY_TACO DUDE MAN BRO

    Joined:
    Mar 28, 2010
    Member:
    #34112
    Messages:
    818
    Gender:
    Male
    First Name:
    Hot Carl!!!
    Roy UT
    Vehicle:
    2010 TRD-Off Road TACO Extra value package
    Icon Ext Travel w/ Resi Front and rear, Dakar leaf springs, total chaos UCA's, color matched rear bumper, color matched satoshi grille with black chrome TRD emblem, konig countersteer offroads (black) w/ 285/75 Duratracs, sockmonkey Trailiens 3rd tail light cover, Tacomaworld.com sticker (made by me), debadged all around, Relentless Front Bumper, Sliders, Rear bumper, and bed bars with Yakima rack w/ full size spare, shovel, hi-lift
    Makes sense!
     
  15. Feb 16, 2012 at 7:20 PM
    #15
    IGO4LOW

    IGO4LOW Well-Known Member

    Joined:
    Dec 13, 2011
    Member:
    #68720
    Messages:
    712
    Gender:
    Male
    First Name:
    Zach
    Fullerton, CA
    Vehicle:
    2011 DCLB TRD SPORT 4x4 w/ JBL Audio
    3" Procomp lift, 285/70 R17 Nitto Terra Grapplers on Procomp series 6005 wheels, Fog lights on Anytime mod, illuminated oem fog switch, bed mat, all weather floormats, CB Radio in dash, alternating turn signal mod, automatic center console light. Blacked out badges, D2s in the grille.
    Yeah it took me like 3 days to figure out why this happened. I ended up going into orvac electronics and they were able to shed some light on the problem and give me that website. Lol.
    I hope this helps out the op.
     
  16. Feb 16, 2012 at 7:36 PM
    #16
    BEEFY_CHEESY_TACO

    BEEFY_CHEESY_TACO DUDE MAN BRO

    Joined:
    Mar 28, 2010
    Member:
    #34112
    Messages:
    818
    Gender:
    Male
    First Name:
    Hot Carl!!!
    Roy UT
    Vehicle:
    2010 TRD-Off Road TACO Extra value package
    Icon Ext Travel w/ Resi Front and rear, Dakar leaf springs, total chaos UCA's, color matched rear bumper, color matched satoshi grille with black chrome TRD emblem, konig countersteer offroads (black) w/ 285/75 Duratracs, sockmonkey Trailiens 3rd tail light cover, Tacomaworld.com sticker (made by me), debadged all around, Relentless Front Bumper, Sliders, Rear bumper, and bed bars with Yakima rack w/ full size spare, shovel, hi-lift
    Well it helped me for future reference! I would have never thought about that.
     
  17. Feb 16, 2012 at 8:11 PM
    #17
    IGO4LOW

    IGO4LOW Well-Known Member

    Joined:
    Dec 13, 2011
    Member:
    #68720
    Messages:
    712
    Gender:
    Male
    First Name:
    Zach
    Fullerton, CA
    Vehicle:
    2011 DCLB TRD SPORT 4x4 w/ JBL Audio
    3" Procomp lift, 285/70 R17 Nitto Terra Grapplers on Procomp series 6005 wheels, Fog lights on Anytime mod, illuminated oem fog switch, bed mat, all weather floormats, CB Radio in dash, alternating turn signal mod, automatic center console light. Blacked out badges, D2s in the grille.
    Cool. Glad to hear it!
     
  18. Feb 17, 2012 at 4:16 AM
    #18
    scotrinaf

    scotrinaf [OP] Well-Known Member

    Joined:
    Jan 24, 2012
    Member:
    #71311
    Messages:
    1,475
    Gender:
    Male
    First Name:
    Scott
    Blountville, TN
    Vehicle:
    04 PreRunner TRD SR5 4x2 2.7L
    Leer 100XQ, Yakima Roof Racks
    Thanks for the info, I'll check it out!
     
  19. Feb 17, 2012 at 4:17 AM
    #19
    scotrinaf

    scotrinaf [OP] Well-Known Member

    Joined:
    Jan 24, 2012
    Member:
    #71311
    Messages:
    1,475
    Gender:
    Male
    First Name:
    Scott
    Blountville, TN
    Vehicle:
    04 PreRunner TRD SR5 4x2 2.7L
    Leer 100XQ, Yakima Roof Racks
    I was getting a 14.2v read off of the switch... But when I hook them up to constant power, they run just fine... Beats me, but I'll get it figured out... :)
     
  20. Feb 17, 2012 at 11:32 AM
    #20
    IGO4LOW

    IGO4LOW Well-Known Member

    Joined:
    Dec 13, 2011
    Member:
    #68720
    Messages:
    712
    Gender:
    Male
    First Name:
    Zach
    Fullerton, CA
    Vehicle:
    2011 DCLB TRD SPORT 4x4 w/ JBL Audio
    3" Procomp lift, 285/70 R17 Nitto Terra Grapplers on Procomp series 6005 wheels, Fog lights on Anytime mod, illuminated oem fog switch, bed mat, all weather floormats, CB Radio in dash, alternating turn signal mod, automatic center console light. Blacked out badges, D2s in the grille.
    That's weird. But give that website a try. Maybe just start with a resistor on one led and see if that led works as it should on the dimmer. If it does great. And you know what to do but if it doesn't then your back right where you started. no harm done. Haha
     
To Top