1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Need help dealing with warning lights '10 Tacoma

Discussion in '2nd Gen. Tacomas (2005-2015)' started by 10taco, Sep 28, 2011.

  1. Sep 28, 2011 at 12:57 PM
    #1
    10taco

    10taco [OP] Well-Known Member

    Joined:
    Sep 4, 2009
    Member:
    #22251
    Messages:
    65
    Gender:
    Male
    Massachusetts
    Vehicle:
    '10 4WD reg cab
    fog lights (with OEM switch), skid plate, stainless exhaust tip, Curt receiver hitch, Exact-Fit seat covers, AFE air filter, intermittant wipers, EGR in-channel vent visors, door sill protectors, Autocraft Platinum AGM battery.
    Started the engine on my '10 Tacoma the other day (4WD reg cab 4cyl man trans) and the engine stumbled briefly then ran normally. Unfortunately two warning lights came on in the dash; the engine symbol and the VSC warning light. Both glow steady and refuse to reset despite about 10 cold starts since. I read the manual but couldn't find anything on how the lights can be reset. I cleaned the airfilter (AFE High-Flow) but can't figure out why these two lights won't go away. If anyone has suggestions or ideas I's like to hear from them. Thanks in advance! :cookiemonster:
     
  2. Sep 28, 2011 at 1:51 PM
    #2
    10taco

    10taco [OP] Well-Known Member

    Joined:
    Sep 4, 2009
    Member:
    #22251
    Messages:
    65
    Gender:
    Male
    Massachusetts
    Vehicle:
    '10 4WD reg cab
    fog lights (with OEM switch), skid plate, stainless exhaust tip, Curt receiver hitch, Exact-Fit seat covers, AFE air filter, intermittant wipers, EGR in-channel vent visors, door sill protectors, Autocraft Platinum AGM battery.
    Thanks WS! I'll get down to a parts store later this week and get a code.
     
  3. Sep 28, 2011 at 1:55 PM
    #3
    Pugga

    Pugga Pasti-Dip Free 1983 - 2015... It was a good run

    Joined:
    Jun 18, 2010
    Member:
    #39131
    Messages:
    30,822
    Gender:
    Male
    First Name:
    Mike
    Massachusetts
    Vehicle:
    '13 Ford F-150 SCREW
    F-150 Mod
    2010, still got a warranty? If so, take it to the dealership and let them fix it for free. :cool:
     
  4. Sep 28, 2011 at 2:03 PM
    #4
    scottri

    scottri Well-Known Member

    Joined:
    Apr 13, 2010
    Member:
    #35187
    Messages:
    2,095
    Gender:
    Male
    First Name:
    Scott
    Tigard Oregon
    Vehicle:
    '10 Sport DC TRD Sport PreRunner
    Cover King Seat Covers, WeatherTech Liners, PopNLock, storage bin locks, N-Fab Step bars, and G4 Elite Tonneau cover.
    I'd take it to the dealer under the warranty as well.
     
  5. Sep 28, 2011 at 2:04 PM
    #5
    Fink

    Fink Motorboatin' SOB

    Joined:
    Mar 12, 2009
    Member:
    #14624
    Messages:
    6,500
    Gender:
    Male
    First Name:
    Chris
    Orlando, FL
    Vehicle:
    2013 Regular Cab 4x4
    WeatherTechs, 265/75-16 DuraTracs, ATX Mojave Teflon Wheels, ARE V-Series Shell
    x3 on the dealership as long as you are still under warranty.

    Fink[​IMG]
     
To Top