1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

need help on getting the codes gone

Discussion in '1st Gen. Tacomas (1995-2004)' started by alexlies, Feb 18, 2011.

  1. Feb 18, 2011 at 9:11 AM
    #1
    alexlies

    alexlies [OP] Well-Known Member

    Joined:
    May 3, 2010
    Member:
    #36488
    Messages:
    168
    Gender:
    Male
    First Name:
    Alex
    Battleground
    Vehicle:
    2002 4 door 4x4
    my 2002 4wd dc trd is throwing these codes

    -p0440- bad gas cap or loose or evap stuff loose or not conected
    -p0441- leak in evap system or faulty purge vsv or blocked vsv
    -p0446- faulty ccv vent control solenoid

    replaced gas cap from stealership gave it 2 days for the light to go off, still hasnt?


    checked the general area of the evap system and checked connections and found no problems.

    any ideas on what i can test or check? where is the ccv vent control

    oh and the truck doesnt run any different from normal.

    any imput is appriciated thank you
     
  2. Feb 18, 2011 at 9:16 AM
    #2
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,838
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
  3. Feb 18, 2011 at 9:18 AM
    #3
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,838
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
  4. Feb 18, 2011 at 9:29 AM
    #4
    alexlies

    alexlies [OP] Well-Known Member

    Joined:
    May 3, 2010
    Member:
    #36488
    Messages:
    168
    Gender:
    Male
    First Name:
    Alex
    Battleground
    Vehicle:
    2002 4 door 4x4
    oh so even if i did fix it with the gas cap the light wont go off till i reset it?
     
  5. Feb 18, 2011 at 9:31 AM
    #5
    steve o 77

    steve o 77 braaap

    Joined:
    Nov 29, 2009
    Member:
    #26726
    Messages:
    19,968
    Gender:
    Male
    First Name:
    Steven
    In a corn field, OH
    Vehicle:
    1990 Chevy Siveraydo
    245k+ miles, rust, working AC, bald eagles
    correct, disconnect the neg battery cable for about 5 minutes and you should be good to go.
     
  6. Feb 18, 2011 at 9:38 AM
    #6
    alexlies

    alexlies [OP] Well-Known Member

    Joined:
    May 3, 2010
    Member:
    #36488
    Messages:
    168
    Gender:
    Male
    First Name:
    Alex
    Battleground
    Vehicle:
    2002 4 door 4x4
    thanks
     
  7. Mar 15, 2011 at 4:54 PM
    #7
    mdenesha34

    mdenesha34 Active Member

    Joined:
    Mar 14, 2011
    Member:
    #53048
    Messages:
    44
    Gender:
    Male
    Rochester NY
    Vehicle:
    2002 SR5 TRD
    Not trying to hijack your thread, but I was wondering how everything turned out for you?

    My truck is throwing the same 3 codes, I just ordered a Stant gas cap, which is supposed to be an OE replacement. I am hoping this will solve the problem, otherwise I'll be troubleshooting as you did.
     
  8. Mar 15, 2011 at 5:11 PM
    #8
    alexlies

    alexlies [OP] Well-Known Member

    Joined:
    May 3, 2010
    Member:
    #36488
    Messages:
    168
    Gender:
    Male
    First Name:
    Alex
    Battleground
    Vehicle:
    2002 4 door 4x4
    i bought a new cap and took off my neg battery terminal for 10 sec and prob fixed. do you have a body lift?
     
  9. Mar 15, 2011 at 5:25 PM
    #9
    mdenesha34

    mdenesha34 Active Member

    Joined:
    Mar 14, 2011
    Member:
    #53048
    Messages:
    44
    Gender:
    Male
    Rochester NY
    Vehicle:
    2002 SR5 TRD
    No, no body lift. I'm getting the new cap in the mail tomorrow so hopefully that will solve my problems as well!

    Your truck looks good by the way. What kind and how much of a lift do you have and how much did it cost you, if you don't mind me asking.
     
  10. Mar 15, 2011 at 5:51 PM
    #10
    alexlies

    alexlies [OP] Well-Known Member

    Joined:
    May 3, 2010
    Member:
    #36488
    Messages:
    168
    Gender:
    Male
    First Name:
    Alex
    Battleground
    Vehicle:
    2002 4 door 4x4
    yea after you get the cap do the battery thing to reset the light, it should stay gone.

    i have fabtechs kinda basic adjustable coil overs with light racing ucas and rear fabtech leafs with a inch and a half block. suspention is about 3 1/2 inches of lift and i have a one inch body lift. reason i ask about body lift is cause when i did mine it pulled on my gas spout, and pulled it in a bit and my cap couldnt get a good seal soi think thats why the light came on,so i fixed that but still bought a cap.

    got my suspention setup for 500 bucks used and body lift for 140 and uca for 400

    just waiting on rims and tires now!!
     
  11. Mar 15, 2011 at 7:20 PM
    #11
    mdenesha34

    mdenesha34 Active Member

    Joined:
    Mar 14, 2011
    Member:
    #53048
    Messages:
    44
    Gender:
    Male
    Rochester NY
    Vehicle:
    2002 SR5 TRD
    Who makes a decent BL kit? I'd like to put a 3" lift on my truck, don't think a suspension lift is in the budget right now.. plus I don't do a whole lot of off roading.
     
  12. Mar 15, 2011 at 7:27 PM
    #12
    Quast

    Quast Well-Known Member

    Joined:
    Apr 8, 2010
    Member:
    #34887
    Messages:
    129
    Gender:
    Male
    First Name:
    Dustin
    Mission, BC
    Vehicle:
    03 toyota tacoma 3.4L
    3'' OME lift, Deck plate mod, spidertrax wheel spacers, 12'' alpine type S sub.
    cant go wrong with toytec but i would stay away from the body lift if you can. try saving up and getting like a OME lift from them. for a little bit more money you can have almost a new suspension.
     
  13. Mar 15, 2011 at 7:39 PM
    #13
    alexlies

    alexlies [OP] Well-Known Member

    Joined:
    May 3, 2010
    Member:
    #36488
    Messages:
    168
    Gender:
    Male
    First Name:
    Alex
    Battleground
    Vehicle:
    2002 4 door 4x4
To Top