1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Need help Please

Discussion in 'New Members' started by WorkTruck, Jan 15, 2008.

  1. Jan 15, 2008 at 6:25 AM
    #1
    WorkTruck

    WorkTruck [OP] Member

    Joined:
    Jan 15, 2008
    Member:
    #4253
    Messages:
    7
    Gender:
    Male
    Vehicle:
    SR5 TRD 4x4
    KN filter
    99 Tacoma with 3.4L. I replaced the both o2 sensors and cat. Installed a magnaflow. This was just the 100,000 mile recomended work. Tacoma ran well for 2 months then the CEL came on code read 0420 bad cat. Took Tacoma to dealer They also said bad cat. Replaced the Magnaflow with a DMI cat. Tacoma ran well for 2 months then the CEL came back on. Went to dealer again same code and they say bad cat again. Anybody had this problem?? Dealer says I need to use a Toyota Cat to fix the problem is this true? Also does anyone know what else could cause the 0420? Could the o2 sensors be bad? Althought they are new!
     
  2. Jan 15, 2008 at 6:59 AM
    #2
    Janster

    Janster Old & Forgetful

    Joined:
    Mar 25, 2007
    Member:
    #1138
    Messages:
    14,256
    Gender:
    Female
    First Name:
    Jandy
    Lancaster, PA
    Vehicle:
    2016 GMC Canyon SLT w/ LineX and....
    Did you keep the original CAT ??

    and do you still have the original 02 sensors?

    Were all of these 'bad' that you had to change them? Were both 02 sensors bad?

    Install the original CAT back in and see what happens.

    Aftermarket CAT's aren't nearly *as good* as the OEM ones. I heard that from a CAT recycler - who removes the precious metals for recycling.

    It all depends...take one of the old 02 sensors and put it back in (after the CAT) and see what happens.

    One reason why I always keep my original parts for a long while, until I know I absolutely won't need 'em.
     
  3. Jan 15, 2008 at 7:41 AM
    #3
    WorkTruck

    WorkTruck [OP] Member

    Joined:
    Jan 15, 2008
    Member:
    #4253
    Messages:
    7
    Gender:
    Male
    Vehicle:
    SR5 TRD 4x4
    KN filter
    I was dumb and trashed the old parts. Nothing was wrong with the old parts just wanted to follow the Hayes schudule maintain for 100,000 miles! ( never again!) I may have a o2 where a AF sensor goes in front of the cat. Would tis be a problem??
     
To Top