1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Need HELP! With foggy windshield

Discussion in 'Detailing' started by Isaiasgon, Jul 18, 2012.

  1. Jul 18, 2012 at 6:32 PM
    #1
    Isaiasgon

    Isaiasgon [OP] Well-Known Member

    Joined:
    Oct 17, 2011
    Member:
    #65382
    Messages:
    324
    Gender:
    Male
    GA
    Vehicle:
    2013 4x4 TRD Sport V6 DCLB
    So Everytime I drive I get a Hugh amount of fogginess outside in the bottom center of the windshield. I tried the defrosters but nothing, It seems that the only way to get rid of it is to use my wipers but it comes back even worst sometimes. also tried rainx and anti fog rainx ( but I used it on the outside even though it's only for inside use). I have tried googling it but nothing. Does anyone know what I could possibly put on the outside windshield to stop this? I'm at the point to call safeguard and get a new one but it's expensive. HELP PLZ!!
     
  2. Jul 18, 2012 at 6:34 PM
    #2
    BuzzardsGottaEat

    BuzzardsGottaEat "Pick up some speed.. You'll make it."

    Joined:
    Apr 27, 2011
    Member:
    #55669
    Messages:
    5,651
    Gender:
    Male
    First Name:
    Chaz
    Nebraska/South Dakota
    Vehicle:
    93 Pickup 4x4 [22R-E] 5MT
    OME suspension, LCE Performance parts, Konigs, etc. [see build]
    Year around, hot or cold weather only?
     
  3. Jul 18, 2012 at 6:36 PM
    #3
    Isaiasgon

    Isaiasgon [OP] Well-Known Member

    Joined:
    Oct 17, 2011
    Member:
    #65382
    Messages:
    324
    Gender:
    Male
    GA
    Vehicle:
    2013 4x4 TRD Sport V6 DCLB
    Well right now it's really hot and humid and it's when I use my a/c but It seems to be the only one with this problem around here.
     
  4. Jul 18, 2012 at 6:37 PM
    #4
    Maverick904

    Maverick904 Resident Fishing Expert

    Joined:
    Sep 21, 2009
    Member:
    #23084
    Messages:
    4,919
    Gender:
    Male
    First Name:
    Kameron
    Northeast Florida
    Vehicle:
    08 TRD Rugged Trail 4x4
    3" Procomp Lift, BDF Light Bar, Borla Stainless Cat-Back System, 2 10" Polk MM Subs, LED Interior Lighting, Pioneer Touch Screen, Kicker Speakers up front, Sonys in the back, Grillcraft grill, 20% tint, Weathertechs, Projector Retrofit Headlights. BHLM
    it happens. nothing you can really do
     
  5. Jul 18, 2012 at 6:39 PM
    #5
    BuzzardsGottaEat

    BuzzardsGottaEat "Pick up some speed.. You'll make it."

    Joined:
    Apr 27, 2011
    Member:
    #55669
    Messages:
    5,651
    Gender:
    Male
    First Name:
    Chaz
    Nebraska/South Dakota
    Vehicle:
    93 Pickup 4x4 [22R-E] 5MT
    OME suspension, LCE Performance parts, Konigs, etc. [see build]
    Mine goes away after a bit. How long did you wait? Try not blasting AC on high right away?
     
  6. Jul 18, 2012 at 6:41 PM
    #6
    Isaiasgon

    Isaiasgon [OP] Well-Known Member

    Joined:
    Oct 17, 2011
    Member:
    #65382
    Messages:
    324
    Gender:
    Male
    GA
    Vehicle:
    2013 4x4 TRD Sport V6 DCLB
    I usually just start the a/c on the first speed, but even when I'm driving it won't go away. Unless I blast the heater to high and wait like 10 minutes
     
  7. Jul 18, 2012 at 6:42 PM
    #7
    Isaiasgon

    Isaiasgon [OP] Well-Known Member

    Joined:
    Oct 17, 2011
    Member:
    #65382
    Messages:
    324
    Gender:
    Male
    GA
    Vehicle:
    2013 4x4 TRD Sport V6 DCLB
    There must be a way cuz this never happens on my buddies taco
     
  8. Jul 18, 2012 at 6:43 PM
    #8
    TacoDawgfan

    TacoDawgfan Hunker Down You Hairy Dawg!

    Joined:
    Jan 30, 2011
    Member:
    #50214
    Messages:
    12,670
    Gender:
    Male
    First Name:
    Mike
    Georgia
    Vehicle:
    2011 Silver 4x4 TRD Sport w/JBL
    5100's at 1.75, Rear leaf TSB, Moto Metal 951 16x8, BFG TKO2 265/75/16, AFe Stage 2 CAI w/pro dry filter, Access Loredo tonneau cover, Tinted windows, EGR in channel vent visors, Ultragauge, UGA drink coasters in the front cup holders, and an Evenflow car seat in the back seat
    I don't think this is what you're talking about, (this was on the inside) but do you use one of those sunshades? I used to until I learned how it was the reason my windshield was always hazy looking. Quit using it and no more problems.

    Those things cause some sort of oil build up from the heat. Not sure of the science of it but someone told me this so I quit using it and sure enough, so now I don't use them. I got sick of cleaning my windshield all the time.
     
  9. Jul 18, 2012 at 6:43 PM
    #9
    Maverick904

    Maverick904 Resident Fishing Expert

    Joined:
    Sep 21, 2009
    Member:
    #23084
    Messages:
    4,919
    Gender:
    Male
    First Name:
    Kameron
    Northeast Florida
    Vehicle:
    08 TRD Rugged Trail 4x4
    3" Procomp Lift, BDF Light Bar, Borla Stainless Cat-Back System, 2 10" Polk MM Subs, LED Interior Lighting, Pioneer Touch Screen, Kicker Speakers up front, Sonys in the back, Grillcraft grill, 20% tint, Weathertechs, Projector Retrofit Headlights. BHLM
    happens to mine all the time haha
     
  10. Jul 18, 2012 at 6:49 PM
    #10
    Rackster

    Rackster Well-Known Member

    Joined:
    May 11, 2012
    Member:
    #78628
    Messages:
    381
    Gender:
    Male
    First Name:
    Kevin
    Connecticut
    Vehicle:
    '04 E/cab 4x4 2.7 Auto SR5
    What setting are you using? Does this happen regardless if you have it on Defog/Defrost or blown on your feet/cabin?
     
  11. Jul 18, 2012 at 6:49 PM
    #11
    Isaiasgon

    Isaiasgon [OP] Well-Known Member

    Joined:
    Oct 17, 2011
    Member:
    #65382
    Messages:
    324
    Gender:
    Male
    GA
    Vehicle:
    2013 4x4 TRD Sport V6 DCLB
    I never have used that but I do appreciate u telling me this cuz I was actually planning to get one but not anymore, my fogginess is on the outside closer to the bottom center.
     
  12. Jul 18, 2012 at 6:51 PM
    #12
    Isaiasgon

    Isaiasgon [OP] Well-Known Member

    Joined:
    Oct 17, 2011
    Member:
    #65382
    Messages:
    324
    Gender:
    Male
    GA
    Vehicle:
    2013 4x4 TRD Sport V6 DCLB
    It happens on all if I have my a/c on, unless I have the heater going
     
  13. Jul 18, 2012 at 6:51 PM
    #13
    Isaiasgon

    Isaiasgon [OP] Well-Known Member

    Joined:
    Oct 17, 2011
    Member:
    #65382
    Messages:
    324
    Gender:
    Male
    GA
    Vehicle:
    2013 4x4 TRD Sport V6 DCLB
    Lol so u know the pain and frustration I am going through, unless u don't care for it to much.:D
     
  14. Jul 18, 2012 at 6:52 PM
    #14
    Maverick904

    Maverick904 Resident Fishing Expert

    Joined:
    Sep 21, 2009
    Member:
    #23084
    Messages:
    4,919
    Gender:
    Male
    First Name:
    Kameron
    Northeast Florida
    Vehicle:
    08 TRD Rugged Trail 4x4
    3" Procomp Lift, BDF Light Bar, Borla Stainless Cat-Back System, 2 10" Polk MM Subs, LED Interior Lighting, Pioneer Touch Screen, Kicker Speakers up front, Sonys in the back, Grillcraft grill, 20% tint, Weathertechs, Projector Retrofit Headlights. BHLM
    as long as it doesnt creep up too much it doesnt bother me...tho sometimes it happens sometimes it doesnt.
     
  15. Jul 18, 2012 at 6:53 PM
    #15
    Isaiasgon

    Isaiasgon [OP] Well-Known Member

    Joined:
    Oct 17, 2011
    Member:
    #65382
    Messages:
    324
    Gender:
    Male
    GA
    Vehicle:
    2013 4x4 TRD Sport V6 DCLB
    I'm at the point to where I want to pull out my windshield and not use it lol ( not really a smart thing though :D)
     
  16. Jul 18, 2012 at 6:54 PM
    #16
    Rich91710

    Rich91710 Well-Known Member

    Joined:
    Feb 23, 2012
    Member:
    #73470
    Messages:
    16,477
    Gender:
    Male
    First Name:
    Rich
    Los Angeles
    Vehicle:
    08 Base
    Satoshi with FJ badge, factory cruise, factory intermittent wipers, Redline Tuning hood-lift struts, Hellwig Swaybar, Rosen DVD-Nav
    Cold air blowing on the inside causes the humid air on the outside to condense on the outside.

    It's exactly the same thing that happens when it's cold outside and you and the GF are getting hot and heavy inside.


    Make sure the AC is blowing on the dash vents and not in the "defrost" position.... all the way to the left, or the position at 9:00 if you want some cool air on your feet.
    If you have the control at 8:00 or 9:00 and you're still feeling air blowing from the defroster vents in the middle of the windshield, you may have a blower door malfunction.
     
  17. Jul 18, 2012 at 6:54 PM
    #17
    greenrustic

    greenrustic Well-Known Member

    Joined:
    Jan 16, 2012
    Member:
    #70776
    Messages:
    664
    Gender:
    Male
    NY
    Vehicle:
    2012 DCLB 4x4 TRD SPORT
    Access LTD Tonneau Cover, Weather Tech Digital Fit Mats, Weather Tech Rain Guards, 35% Tint up Front, AFE Dry Power Intake Filter, Debadged, GrilleCraft, OME 884x, OME 9000 NitroChargers, Icon 3 Leaf Progressive AAL
    Happens to me too. Its annoying so I only use the defrost when I absolutely have to.
     
  18. Jul 18, 2012 at 6:55 PM
    #18
    Rackster

    Rackster Well-Known Member

    Joined:
    May 11, 2012
    Member:
    #78628
    Messages:
    381
    Gender:
    Male
    First Name:
    Kevin
    Connecticut
    Vehicle:
    '04 E/cab 4x4 2.7 Auto SR5
    I haven't run into this yet with my Tacoma, but it did happen with my Ranger. I changed the setting to blow into the cabin and it cured the windshield build-up of condensation....but it would sometimes collect on the rear window especially on very hot and humid days. It could be that your AC is blowing colder than it should. Most wouldn't consider that a problem I suppose, but the higher contrast would result in increased condensation buildup.
     
  19. Jul 18, 2012 at 6:58 PM
    #19
    Isaiasgon

    Isaiasgon [OP] Well-Known Member

    Joined:
    Oct 17, 2011
    Member:
    #65382
    Messages:
    324
    Gender:
    Male
    GA
    Vehicle:
    2013 4x4 TRD Sport V6 DCLB
    Interesting but this only happens when I use the ac though
     
  20. Jul 18, 2012 at 6:59 PM
    #20
    Isaiasgon

    Isaiasgon [OP] Well-Known Member

    Joined:
    Oct 17, 2011
    Member:
    #65382
    Messages:
    324
    Gender:
    Male
    GA
    Vehicle:
    2013 4x4 TRD Sport V6 DCLB
    It really is and isn't dangerous too?
     
To Top