1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Need jetski help! 2008 rxpx 255.

Discussion in 'Off-Topic Discussion' started by sir1123, Aug 6, 2013.

  1. Aug 6, 2013 at 8:09 AM
    #1
    sir1123

    sir1123 [OP] Tacomas FTMFW!!!!

    Joined:
    Nov 15, 2010
    Member:
    #46216
    Messages:
    1,378
    Gender:
    Male
    First Name:
    John
    Charleston
    Vehicle:
    99 SR5 Prerunner, Black,3.4L
    3"Ebaich with 5100 Bilstiens, K&N cai, 5% 3M Tint, Magnaflow 18", Hella 500s with 35w 3000k hid retro, 33x9.5x15 BFG A/T
    So I lent my uncle and his friends the jetski last weekend to take to the lake. It ended up at velocity powersports because he put gas in the oil tank. He says he did not run it because he realized what he did and took it straight to the shop. The shop has charged him $500 + for 2 oil changes and some other thing and they say its running crappy still. My belief is that the shop may have ran the ski before pumping the oil gas mix out causing damage. We have taken it out of the shop and have bought enough oil to do two drains and refills. I am checking the compression tonight and have new spark plugs. Is there anything else I should know or check. Will running it with gas in the oil fry the engine? Any help is appreciated. Really don't want to have to get a new engine put in. Thanks
     
  2. Aug 6, 2013 at 9:12 AM
    #2
    speedjunkie13

    speedjunkie13 Well-Known Member

    Joined:
    Jan 11, 2012
    Member:
    #70448
    Messages:
    147
    Gender:
    Male
    Vehicle:
    a work in progress
    I don't know much about jetskis, so unfortunately I won't be much help. However, I think it's much more likely that your uncle is lying to cover his ass. They probably figured it out after they tried taking it back out into the water and it ran like garbage. I doubt the shop would decide to try and run it after the situation was described to them when dropping it off.

    IMO all you can do is maybe try to flush it some more and try it out. It all depends on if it was ran long enough to wipe the bearings out.
     
  3. Aug 6, 2013 at 9:30 AM
    #3
    Jon850FL

    Jon850FL is Lurkin'

    Joined:
    Aug 1, 2011
    Member:
    #60972
    Messages:
    2,036
    Gender:
    Male
    First Name:
    Jon
    DFS, FL
    how do you confuse the 2?
     
  4. Aug 6, 2013 at 10:46 AM
    #4
    sir1123

    sir1123 [OP] Tacomas FTMFW!!!!

    Joined:
    Nov 15, 2010
    Member:
    #46216
    Messages:
    1,378
    Gender:
    Male
    First Name:
    John
    Charleston
    Vehicle:
    99 SR5 Prerunner, Black,3.4L
    3"Ebaich with 5100 Bilstiens, K&N cai, 5% 3M Tint, Magnaflow 18", Hella 500s with 35w 3000k hid retro, 33x9.5x15 BFG A/T
    He never made it to the lake to run it. He went to gas station then went to shop.
     
  5. Aug 6, 2013 at 10:47 AM
    #5
    sir1123

    sir1123 [OP] Tacomas FTMFW!!!!

    Joined:
    Nov 15, 2010
    Member:
    #46216
    Messages:
    1,378
    Gender:
    Male
    First Name:
    John
    Charleston
    Vehicle:
    99 SR5 Prerunner, Black,3.4L
    3"Ebaich with 5100 Bilstiens, K&N cai, 5% 3M Tint, Magnaflow 18", Hella 500s with 35w 3000k hid retro, 33x9.5x15 BFG A/T
    Gas on left side under the hood and oil on the right. Both identical caps that are black and have raised black writing on them. He doesn't use the jet ski much so I don't really know just not paying attention I guess
     
  6. Aug 6, 2013 at 10:49 AM
    #6
    Large

    Large Red

    Joined:
    Sep 10, 2011
    Member:
    #63268
    Messages:
    15,759
    Gender:
    Male
    I believe the 08 rxp's are fuel injected, so yeah they had to try to run the ski to pump the oil in the engine so they should not have charged $500 at all for a screw up. Also you could drain the tank and put 93 octane in it, at WOT it will smoke a little more but shouldn't damage the ski permanently. I would consider changing the injectors and putting a bottle of injector cleaner in the next tank.
     
  7. Aug 6, 2013 at 11:06 AM
    #7
    sir1123

    sir1123 [OP] Tacomas FTMFW!!!!

    Joined:
    Nov 15, 2010
    Member:
    #46216
    Messages:
    1,378
    Gender:
    Male
    First Name:
    John
    Charleston
    Vehicle:
    99 SR5 Prerunner, Black,3.4L
    3"Ebaich with 5100 Bilstiens, K&N cai, 5% 3M Tint, Magnaflow 18", Hella 500s with 35w 3000k hid retro, 33x9.5x15 BFG A/T
    No gas was put into the oil tank not oil in the gas tank
     
  8. Aug 6, 2013 at 11:21 AM
    #8
    Large

    Large Red

    Joined:
    Sep 10, 2011
    Member:
    #63268
    Messages:
    15,759
    Gender:
    Male
    Okay you shut me down. I got nothing :notsure:
     
  9. Aug 6, 2013 at 11:28 AM
    #9
    bldegle2

    bldegle2 OldPhart

    Joined:
    Apr 16, 2013
    Member:
    #102169
    Messages:
    1,095
    Gender:
    Male
    floyd, VA
    Vehicle:
    2000 Prerunner TRD
    throttle body extension, K&N dropin, custom rear sway bar, bilsteins, 2010 Tacoma 17" alloys w/265's, driveshaft mods, bullbar, .75" Bora hubcentric spacers
    something is fishy here.....

    as far as gas in oil reserve, you should never lend something to someone that has no idea, you also should have gone over the details before he took it......

    that said, if it went down like you said, flushing the oil tank and refilling should do the trick, if it still runs like crudola, I would be asking my Uncle for the real story...

    just sayin'...why, I lent my boat one time to a friend, many, many problems when I got it back, some people just don't respect other peoples shiza...
     
  10. Aug 6, 2013 at 11:53 AM
    #10
    sir1123

    sir1123 [OP] Tacomas FTMFW!!!!

    Joined:
    Nov 15, 2010
    Member:
    #46216
    Messages:
    1,378
    Gender:
    Male
    First Name:
    John
    Charleston
    Vehicle:
    99 SR5 Prerunner, Black,3.4L
    3"Ebaich with 5100 Bilstiens, K&N cai, 5% 3M Tint, Magnaflow 18", Hella 500s with 35w 3000k hid retro, 33x9.5x15 BFG A/T
    He had no reason to lie. And money isn't an issue he just wasnt going to keep paying the shop when my father and I are very mechanically capable but don't know why it's running poorly now. Yes wether it is the shop or my uncle someone isn't telling the whole truth either way that's besides the point. It already happened so I am just trying to get advice and try to fix it myself before I end up having to talk to the insurance company.
     
  11. Aug 6, 2013 at 12:06 PM
    #11
    MowTaco

    MowTaco Well-Known Member

    Joined:
    Sep 9, 2009
    Member:
    #22530
    Messages:
    3,795
    Gender:
    Male
    First Name:
    Matt
    Kansas/Iowa/South Dakota
    Vehicle:
    04 5 Lug Xtracab
    Fabtech 3" Spindles, 2" Beefed Shackles, Front light bar with 4 7" HIDs mounted, Magnaflow Exhaust, and "Taco" Badges
    I'm assuming this is a 2 stroke since it has an oil "tank"? It seems like it is to me but then you talk about oil changes so I'm a touch confused, unless you mean just flushing all the oil out.

    What was the oil level like before? They obviously get mixed together eventually so mixing them won't hurt anything I could think of. The only concern is it leaning out on the oil side and messing something up. Your compression test should reveal what's going on for sure, I agree that someone isn't giving you the full story here

    Not having enough oil I would think it would run just fine and then seize, I think that's what happened to my old JS550. That shop is taking you for a ride, did you get any kind of itemized ticket or anything?

    Good luck on this, God knows jet skis can be fickle bitches to keep running
     
  12. Aug 6, 2013 at 12:08 PM
    #12
    ANT2013taco

    ANT2013taco Well-Known Member

    Joined:
    Apr 27, 2013
    Member:
    #103007
    Messages:
    171
    Gender:
    Male
    McAllen Texas
    Vehicle:
    13 TRD OR 4wd
    How much gas was put in there would be my first question? You should be fine by pulling all the oil and gas out through all of the passages. The gas surely got into areas where it shouldn't so you will need to put a good cleaner in the engine and cycle all moving parts by hand. I would do a full fill and drain about 2-3 times and keep on checking the drained oil until you see no fuel in it.
     
  13. Aug 6, 2013 at 1:27 PM
    #13
    sir1123

    sir1123 [OP] Tacomas FTMFW!!!!

    Joined:
    Nov 15, 2010
    Member:
    #46216
    Messages:
    1,378
    Gender:
    Male
    First Name:
    John
    Charleston
    Vehicle:
    99 SR5 Prerunner, Black,3.4L
    3"Ebaich with 5100 Bilstiens, K&N cai, 5% 3M Tint, Magnaflow 18", Hella 500s with 35w 3000k hid retro, 33x9.5x15 BFG A/T
    What kind of cleaner?
     
  14. Aug 6, 2013 at 2:58 PM
    #14
    ANT2013taco

    ANT2013taco Well-Known Member

    Joined:
    Apr 27, 2013
    Member:
    #103007
    Messages:
    171
    Gender:
    Male
    McAllen Texas
    Vehicle:
    13 TRD OR 4wd
    See if Amsoil has a cleaner for the 2 stroke, I believe they do. I use Lubegard or Amsoil on my boat and used the same on my Jet boat. From reading up on the subject, what happened to your ski is a common issue.

    I am by no means an expert, but have experience in Marine equipment, so please do your due diligence.
     
  15. Aug 6, 2013 at 5:33 PM
    #15
    mntbiker2008

    mntbiker2008 First I derp.. then I herp

    Joined:
    Dec 18, 2008
    Member:
    #11718
    Messages:
    8,247
    Gender:
    Male
    First Name:
    Aaron
    Cincinnati, OH
    Vehicle:
    93 Pick up 4x4 (sold), 10' Mazda 3
    I am going to school to be a marine mechanic now. Drain that tank out and get it clean. Also bleed the oil pump since more than likely, fuel got sent in if the engine was even cranked once. Put the tank back in and refill with good oil and run the engine through a tank of gas. Also, replace the oil filter. you could probably also put a light premix in the first tank you run just as a precaution (worst case scenario it will smoke a bit, just dont put a ton in there).

    It ran like crap because of how thrown off the mixture was. Just do what I suggested above and you should be fine. It will run like crap for a little while until all that fuel gets flushed out
     
To Top