1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

New Dallas Member (kind of...)

Discussion in 'New Members' started by SilverMac, Jun 20, 2008.

  1. Jun 20, 2008 at 6:15 AM
    #1
    SilverMac

    SilverMac [OP] Mine's the silver one...

    Joined:
    Jun 20, 2008
    Member:
    #7427
    Messages:
    115
    Gender:
    Male
    Keller, TX
    Vehicle:
    2008 PreRunner DC SR5
    I got my '08 Double Cab in October of '07. I've been reading on this site since then, but never joined. I've been posting on ToyotaNation, but that is one SLOW site! Plus, I like the way that TW is dedicated to just our trucks. I look forward to a lot more good information!
     
  2. Jun 20, 2008 at 6:21 AM
    #2
    neontrail

    neontrail ✈ ✈ ✈ ✈ ✈ ✈ ✈

    Joined:
    Apr 9, 2008
    Member:
    #5844
    Messages:
    10,135
    Gender:
    Male
    Idaho
    Vehicle:
    2004 NISSAN XTERRA XE/SE
    De-badged, Tint 20%, Blue 48 LED dome-light, .......
    welcome to The forums!!! Glad to have ya.


    Lets see those pics of ur taco:D
     
  3. Jun 20, 2008 at 6:22 AM
    #3
    Khaos

    Khaos Well-Known Member

    Joined:
    Feb 4, 2008
    Member:
    #4570
    Messages:
    6,506
    Gender:
    Male
    First Name:
    Bryant
    Tallahassee FL
    Vehicle:
    2005 Prerunner TRD Off Road
    265/75/16 BFG A/T, 18" Magnaflow, K&N Intake Filter, Ultra-Gauge, Kobalt Toolbox, Metal Tail Light Guards, Cobra 19 and 4ft fiberglass antenna, Plasti dipped Badges/lower valance/rear bumper/grill/bullbar/ac controls, black DIN kit, JVC KD-X40, Wet Suit Seat Covers
    Toyota Nation is not slow at all dude. We must be going to two different sites.

    Welcome.
     
  4. Jun 20, 2008 at 6:29 AM
    #4
    SilverMac

    SilverMac [OP] Mine's the silver one...

    Joined:
    Jun 20, 2008
    Member:
    #7427
    Messages:
    115
    Gender:
    Male
    Keller, TX
    Vehicle:
    2008 PreRunner DC SR5
    Maybe it's just me... A few of the other members over there have complained about it being slow and/or the site being down. That's why I kept coming to TW. It's nice to have them both:D
     
  5. Jun 20, 2008 at 7:35 AM
    #5
    007Tacoma

    007Tacoma I dub thee malicious!

    Joined:
    Jan 4, 2007
    Member:
    #643
    Messages:
    6,703
    Gender:
    Male
    First Name:
    Mark
    San Antonio, TX
    Vehicle:
    2003 4Runner SE 4WD
    Welcome to TW from San Antonio!

    ...yeah, TN loads kinda slow for me too. It is because I block most of their ads. ;)
     
  6. Jun 20, 2008 at 8:24 AM
    #6
    Roland

    Roland My other ride has sails

    Joined:
    Jan 8, 2008
    Member:
    #4149
    Messages:
    2,406
    Gender:
    Male
    Rhode Island
    Vehicle:
    06 Impulse Red I4 2WD Access Cab
    UnderCover Tonneau, Bed mat, Bug Deflector, aFe Pro Dry S, Secondary Air Filter removed, Synthetic 5W-30 oil, Scanguage II with blendmount, WeatherTech floorliners, Toyota seat covers, Installed OEM intermittent wipers, TacomaWorld sticker, Defrost without AC mod, Hidden Hitch
    Welcome aboard!
     
  7. Jun 23, 2008 at 2:12 PM
    #7
    SilverMac

    SilverMac [OP] Mine's the silver one...

    Joined:
    Jun 20, 2008
    Member:
    #7427
    Messages:
    115
    Gender:
    Male
    Keller, TX
    Vehicle:
    2008 PreRunner DC SR5
    Well, it's running very low over at TN again... some guy called Da Hui is always complaining about how slow it is...:D
     
To Top