1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

New ECM wiring harness?

Discussion in '1st Gen. Tacomas (1995-2004)' started by natemoore2088, Jun 13, 2012.

  1. Jun 13, 2012 at 6:15 PM
    #1
    natemoore2088

    natemoore2088 [OP] Well-Known Member

    Joined:
    Dec 2, 2011
    Member:
    #68080
    Messages:
    48
    Gender:
    Male
    First Name:
    Nate
    Idaho
    Vehicle:
    '97 Tacoma 2.7
    2" lift Pre-runner bumper Deck Plate Doug Thorley header Cherry Bomb
    I put a new motor in my truck after the old one blew up because it was the wrong motor and didn't have the camshaft position sensor. More info about this problem is in this thread http://www.tacomaworld.com/forum/1st-gen-tacomas/190897-missing-camshaft-position-sensor.html

    While installing my new motor I noticed just about every wire in the wiring harness to my various sensors and other electrical connections from my ECM has been cut and spliced at least once. Whoever did the swap before me just cut all the wires and rewired them afterwards. After getting the new motor installed an hooked up with a new cam sensor it is still throwing the same codes and sputtering and stalling like the old motor.

    Does anyone know where I can find a new main wiring harness for my truck? It is a 1997 3rz-fe. It needs to be the harness with connections to all the fuel injectors, crank sensor, cam sensor, tps, etc. Been looking on the internet but all I can find is a new ECM or a harness patch/extension but not the harness itself. Any help would be awesome, thanks.
     
To Top