1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Noise from under the passenger side at 1110RPM

Discussion in 'New Members' started by anamor, Feb 23, 2014.

  1. Feb 23, 2014 at 6:44 PM
    #1
    anamor

    anamor [OP] New Member

    Joined:
    Feb 23, 2014
    Member:
    #123822
    Messages:
    3
    Gender:
    Male
    Alberta
    Vehicle:
    06 Tacoma TRD Sport
    Toyota Tacoma TRD Sport 4.0 Manual ​

    Check Engine light on. I have an intake manifold leak which I cannot locate. I apparently have got an exhaust leak with no visible signs. I took it in to midas and got the exhaust system check but they said that there isn't any problems.They checked the catalytic converter all 4 oxygen sensors and all the connections and its all solid and checked out.
    In conclusion I have the check engine on, my fuel consumption is horrible. When I accelerate and I am at around 1110 RPM I always get a major rattle from the passenger side.

    I serviced my truck regularly new belts keep up with the oil changes Synthetic only.I got new spark plugs ,new MAS airflow sensor. Midas said that all 4 O2 sensors are good. Any advice would help.
     
  2. Feb 24, 2014 at 2:29 AM
    #2
    ZEROPILOT

    ZEROPILOT Can't re-MEMBER

    Joined:
    Jan 24, 2014
    Member:
    #121347
    Messages:
    498
    Gender:
    Male
    First Name:
    ED
    SUNRISE,FLORIDA
    Vehicle:
    09 2.7 XTRA CAB 5 SPEED
    LARGER WHEELS. DIFFERENT STEREO. PUSH BAR. TAILGATE EXTENDER. WIPER MOD. TPMS LIGHT DELETE MOD.
    Find another shop. Check engine. Rattle. Poor fuel mileage. Is your cat converter plugged up?
     
  3. Feb 24, 2014 at 4:12 AM
    #3
    Delmarva

    Delmarva Mayor of TW

    Joined:
    Oct 22, 2008
    Member:
    #10148
    Messages:
    35,578
    Gender:
    Male
    First Name:
    Mike
    Tucson, AZ
    Vehicle:
    09 TRD OR S/C 4x4
    TRD S/C, Full OME Suspension, LR UCAs, Relentless Front Bumper, Derpwerx Fab HC Rear Bumper, 285/75/16 Revos, XD Hoss Wheels, Safari Snorkel, Infiniti FX-R HID Retrofit, Airbags in rear, Optima Yellow top, Besttop, All-Pro Skid, All-Pro HD Sliders
    Welcome to TW :wave:
     
  4. Feb 24, 2014 at 1:58 PM
    #4
    whisk3ythrottle

    whisk3ythrottle Well-Known Member

    Joined:
    Feb 7, 2014
    Member:
    #122515
    Messages:
    137
    Gender:
    Male
    First Name:
    Colin
    Birmingham, AL
    Vehicle:
    2010 DCSB sport 4x4
    Front windows matched tint, weathertech front husky rear mats, K & N CAI, Borla cat-back exhaust, 265/70/17 Goodyear Wrangler Authorities, fog light anytime, 5100s up front set at 1.75" on stock coils,
    I just installed a K & N intake and Borla exhaust and I have a rattle on the passenger side at about that same RPM. I don't have a check engine light on and I get about 17 mpg 70/30 city/highway. I've checked all the exhaust bolts because that is what it sounds like but they are all tight. I don't always have the rattle but it will randomly do it. I'll let you know if I find something.
     
  5. Feb 24, 2014 at 2:10 PM
    #5
    4WD

    4WD cRaZy oLdmAn

    Joined:
    Jul 2, 2009
    Member:
    #19185
    Messages:
    22,316
    Gender:
    Male
    First Name:
    Doug
    Gardnerville, Nevada
    Vehicle:
    No Truck
    Grey wire MOD, deck plate, diff breather MOD, 2nd gen. OME 883# on Tundra 5100's, OMD custom 3" leafsprings, rear shock relocation, Ivan Stewart TRD rims w/285/75/16's, '02 bumper MOD, Famous Fabrications sliders , LED interior/exterior lights, bed bar, Custom tube bumper, Old school KC day lighters,Red Ring 8" HID flood, Kenwood vhf 2M.. umm some other shit I'm forgetting right now
    He doesn't want a welcome, he wants his shit fixed
     
  6. Feb 24, 2014 at 6:17 PM
    #6
    anamor

    anamor [OP] New Member

    Joined:
    Feb 23, 2014
    Member:
    #123822
    Messages:
    3
    Gender:
    Male
    Alberta
    Vehicle:
    06 Tacoma TRD Sport
    thanx for all the quick replies....passionate Toyota owners on this site...

    I had some time today I popped in the scanner...I have a whole bunch of codes

    P0174 SYSTEM TOO LEAN (BANK 2)
    P0300 RANDOM MISFIRE DETECTED
    P0100 Mass or Volume Air Flow Circuit
    P0102 Mass or Volume Air Flow Circuit Low Input
    P0103 Mass or Volume Air Flow Circuit High Input
    P0420 Catalyst System Efficiency Below Threshold (Bank1)
    P0430 Catalyst System Efficiency Below Threshold (Bank2)
    P0441 EVAPORATIVE EMISSION SYSTEM INCORRECT PURGE FLOW
    P2195 Oxygen (A/F) Sensor Signal Stuck Lean(Bank 1 Sensor 1)
    P2196 Oxygen (A/F) Sensor Signal Stuck Rich (Bank 1 Sensor 1)
    P2197 Oxygen (A/F) Sensor Signal Stuck Rich (Bank 2 Sensor 1)
    P2198 Oxygen (A/F) Sensor Signal Stuck Rich (Bank 2 Sensor 1)
    P2A03 A/F sensor circuit slow response (Bank 2 Sensor 1)

    So yea its like a freaking X-mass on the dashboard with the engine light.

    So I have a rattle at 1100 RPM bad fuel consumption ...checked the exhaust system at midas...I cannot locate a leak in the exhaust or the intake at all...I am hopeless.......
     
To Top