1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Noise, souinds like a kazoo coming from my dash at high speeds.

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Nolazach, Jun 3, 2012.

  1. Jun 3, 2012 at 6:51 PM
    #1
    Nolazach

    Nolazach [OP] Well-Known Member

    Joined:
    Aug 9, 2011
    Member:
    #61457
    Messages:
    130
    Gender:
    Male
    New Orleans
    An ARE camper shell, a 1000w power inverter.
    I was told by someone this could be a windshield seal. It's annoying, I don't know what it is. It only does it above 70mph or when it is very windy.

    That and the spring squeak were driving me nuts, but now I know how to fix the spring squeak.

    Any idea what this is. I do all my own mechanic work but if it is a windshield seal then I guess I have to pay them to do it.
     
  2. Jun 3, 2012 at 6:55 PM
    #2
    Saskquatch11

    Saskquatch11 TRUCK YEAH

    Joined:
    Apr 25, 2011
    Member:
    #55548
    Messages:
    13,298
    I had the same issue with my 07. it would make a high pitched hum at highway speeds driving into a strong wind, I could change the tone of the sound by pressing on the windshield near the rear view mirror. had the windshield resealed/reinstalled and that fixed it for the most part, would still do it from time to time.
     
  3. Jun 3, 2012 at 7:02 PM
    #3
    landphil

    landphil Wishin' I was Fishin'

    Joined:
    Mar 3, 2011
    Member:
    #52290
    Messages:
    2,393
    Gender:
    Male
    BC, Canada
    Vehicle:
    RIP 2006 Tacoma DCSB
    Tundra 5.7 mod
    Get some wide masking tape, and tape over the windsheild edge molding so the tape is stuck to the glass and the body. Take it for a drive, if the noise is gone, you've confirmed the cause. Taking the tape off in pieces a bit at a time can pinpoint the exact location of the issue.
     
  4. Jun 3, 2012 at 7:51 PM
    #4
    bjmoose

    bjmoose Bullwinkle J. Moose

    Joined:
    Aug 31, 2010
    Member:
    #42529
    Messages:
    6,000
    Gender:
    Male
    First Name:
    Steve
    San Jose CA
    Vehicle:
    '11 Std Cab 4x4 5sp
    OME suspension, ARB Air Lockers, CBI/Relentless/Pelfrey armor, HAM radio
    You can also press out firmly on the windshield next to the rearview mirror while it's making the noise to see if it changes or stops. That' pretty much narrows it down too.

    My dealer replaced the windshield seal under warranty - but it still does it. :mad:
     
  5. Jun 3, 2012 at 7:54 PM
    #5
    Johns Taco

    Johns Taco I'm not 4x4, and have an open diff. So i'm 4x1

    Joined:
    Dec 6, 2010
    Member:
    #47253
    Messages:
    2,085
    Gender:
    Male
    First Name:
    John
    Albuquerque, NM
    Vehicle:
    05 DSM Base SR5 Slug Taco
    Full custom stereo, onboard air compressor, train horns, spacer lift, 30" tires, optima yellow top, rear slider window & tailgate anti-theft mod, pop & lock, class 3 tow hitch, lights in bed, Ultra Gauge, Weather Tech mats, yellow fog lights, camper top, air lift rear airbags, rear diff breather mod, soon to be more...
    I'm sure the maximum posted speed limit there is 65mph, your not going to post a I get bad MPG post next are you?
     
  6. Jun 3, 2012 at 8:12 PM
    #6
    05Moose

    05Moose Middle-Aged Member

    Joined:
    Jan 18, 2010
    Member:
    #29613
    Messages:
    2,535
    Gender:
    Male
    First Name:
    Jim
    In the snow (NorCal)
    Vehicle:
    '05 4x4 DC LB SR5 #8 (LSD, Tow Pkg)
    '05 4x4 DC LB SR5 (LSD & Tow Pkg), Timbrens, AAL, 5100s (.85), Owned: 12/3/04 Mods: Fog, Map/Dome Light, Illuminated 4wd Switch, Washable Cabin Air Filter
    If you do all the fixes yourself, you can do this one too. Just look up the fix in the TSB which is here on TW. It's TSB NV006-07.
     
  7. Jun 3, 2012 at 8:32 PM
    #7
    Saskquatch11

    Saskquatch11 TRUCK YEAH

    Joined:
    Apr 25, 2011
    Member:
    #55548
    Messages:
    13,298
    there is a tsb for it, so toyota recognizes this as being a problem.
     
  8. Jun 4, 2012 at 5:58 PM
    #8
    Night

    Night Well-Known Member

    Joined:
    Feb 21, 2011
    Member:
    #51613
    Messages:
    981
    Gender:
    Male
    First Name:
    Mike
    Canada
    Vehicle:
    '11 TRD OR AC MagGrey
    Banks Monster Exhaust, aFe ProGuard 7, 3M Film, UnderCoating, alpine 920 headunit, alpine 6.5 components, 20% tint all around, JL Stealthbox, PDX-V9 Amp, Avid Lightbar, Avid Sliders, Full Metal JackRabbit Tonneau, TRD S/C
    I to have windshield noises now. Has anyone got it so they are completely gone?
     
  9. Jun 4, 2012 at 7:09 PM
    #9
    landphil

    landphil Wishin' I was Fishin'

    Joined:
    Mar 3, 2011
    Member:
    #52290
    Messages:
    2,393
    Gender:
    Male
    BC, Canada
    Vehicle:
    RIP 2006 Tacoma DCSB
    Tundra 5.7 mod
    Mine is silent as the grave if that counts. If you mean curing one that was noisy, no personal experience in this case, just pointlessly adding to my post count.;)
     
  10. Jun 4, 2012 at 7:33 PM
    #10
    jassco

    jassco Well-Known Member

    Joined:
    Aug 3, 2009
    Member:
    #20568
    Messages:
    558
    Gender:
    Male
    Boston
    Vehicle:
    2010 Access Cab 2.7L SR5 5spd, 4x4
    5100 set to .85 w/ rear TSB, 2012 Rear-view Mirror, Grillecraft, Team Trails FJ Wheels, TPMS canister, Rear headrest delete, Rear console delete, Valley Hitch, Frame undercoat, $2.99 Tailgate hose clamp lock, Avid light bar, 4x4 lighted switch ala Biceman.
    TSB states within 3yr/36,000 so if outside warranty you may have to dealer for assistance.
     
  11. Jun 4, 2012 at 7:59 PM
    #11
    05Moose

    05Moose Middle-Aged Member

    Joined:
    Jan 18, 2010
    Member:
    #29613
    Messages:
    2,535
    Gender:
    Male
    First Name:
    Jim
    In the snow (NorCal)
    Vehicle:
    '05 4x4 DC LB SR5 #8 (LSD, Tow Pkg)
    '05 4x4 DC LB SR5 (LSD & Tow Pkg), Timbrens, AAL, 5100s (.85), Owned: 12/3/04 Mods: Fog, Map/Dome Light, Illuminated 4wd Switch, Washable Cabin Air Filter
    Since I didn't realize it was the windshield until I was already outside of the warranty, I just waited until I got a traveling rock impact. Of course, the stock windshields were too damn strong and I had to live with it for 5 years! But it eventually got replaced. I used to hear it in all strong cross winds and had to listen to it all the way up to Washington, twice, since the speed limits are 70. After the windshield was replaced, I've heard it twice in some very strong cross winds but it was hella quiet compared to before. It is gone though on regular freeway driving at 70. So I consider it fixed.
     
  12. Jun 4, 2012 at 8:35 PM
    #12
    Nolazach

    Nolazach [OP] Well-Known Member

    Joined:
    Aug 9, 2011
    Member:
    #61457
    Messages:
    130
    Gender:
    Male
    New Orleans
    An ARE camper shell, a 1000w power inverter.
    I like to drive 75, also I love my gas mileage, I'm coming from a Ram.
     
  13. Jun 5, 2012 at 6:24 AM
    #13
    Lurkin

    Lurkin Well-Known Member

    Joined:
    May 21, 2009
    Member:
    #17497
    Messages:
    11,021
    First Name:
    Rod
    Pearland, TX
    Vehicle:
    09 PreRunner SR5 DC
    My 09 also did the kazoo thing for a couple of years before I took it in, under warrantee. Mine only made the noise at highway speed and a strong left to right crosswind. The tech attempted to seal the windshield using the TSB method and ended up with sealant oozing outside of the seal and also cut into the seal inself when trying to clean up the "oozing". He ended up not liking how it turned out and they replaced the entire seal. I've been kazoo free since.
     
  14. Jun 5, 2012 at 6:55 AM
    #14
    acdronin

    acdronin Well-Known Member

    Joined:
    Dec 2, 2010
    Member:
    #47036
    Messages:
    19,664
    Gender:
    Male
    .
    There is a midget with a kazoo in your truck somewhere, you should get him outta there and the noise will go away
     
  15. Jun 5, 2012 at 7:09 AM
    #15
    knucklehead

    knucklehead Well-Known Member

    Joined:
    May 1, 2012
    Member:
    #77990
    Messages:
    273
    Gender:
    Male
    First Name:
    Jeff
    Ottawa
    Vehicle:
    SR5 4x4
    Hitch, nav header
    Dont waste your time with the draler.
    Get yourself a tube of clear silicon with a pointy tip and a plastic knife.

    Use the knife to lift the rubber seal away from the ROOF, stick in silicon tube, and inject a bead across the top edge of the windshield (not the sides). Clean up with paint thinner if you make a mess.

    I guarantee this will 100% eliminate all those annoying midgets with kazoos.
     
  16. Jun 5, 2012 at 7:16 AM
    #16
    acdronin

    acdronin Well-Known Member

    Joined:
    Dec 2, 2010
    Member:
    #47036
    Messages:
    19,664
    Gender:
    Male
    .
    You just refer to a vertically challenged person as an "it"? That's not very PC, then again neither are hookers that can hum 'Dixie' while they work or strippers that can play ping pong without a paddle.
     
  17. Jun 5, 2012 at 8:10 AM
    #17
    yakker1982

    yakker1982 Active Member

    Joined:
    Feb 28, 2012
    Member:
    #73809
    Messages:
    38
    Gender:
    Male
    Bay Area, CA
    Vehicle:
    12 DCLB 4WD V6 Sport
    I dropped mine off at the dealer this morning for this exact issue. Experienced it this weekend on the drive home from Santa Barbara where the cross winds were gusting like crazy. T-SB-0062-12 seems to explain my problem. We'll see what the dealer says.
     
  18. Jun 5, 2012 at 9:09 AM
    #18
    Night

    Night Well-Known Member

    Joined:
    Feb 21, 2011
    Member:
    #51613
    Messages:
    981
    Gender:
    Male
    First Name:
    Mike
    Canada
    Vehicle:
    '11 TRD OR AC MagGrey
    Banks Monster Exhaust, aFe ProGuard 7, 3M Film, UnderCoating, alpine 920 headunit, alpine 6.5 components, 20% tint all around, JL Stealthbox, PDX-V9 Amp, Avid Lightbar, Avid Sliders, Full Metal JackRabbit Tonneau, TRD S/C
    I made an appointment next week. The person who booked my appointment said she had never heard of the issue. We will see.
     
  19. Jun 12, 2012 at 9:40 PM
    #19
    cacti

    cacti New Member

    Joined:
    Mar 19, 2012
    Member:
    #75189
    Messages:
    1
    Gender:
    Male
    First Name:
    speedy
    Phoenix
    Vehicle:
    2012 SR5 2WD
    Had my 2012 Pre done at the dealer today...contracted to a glass shop. The molding was replaced, not the glass. Tiny rock chip still in the same spot! I'm somewhat surprised, because my understanding was that the windshield would be removed and resealed.

    Nevertheless, silence at speeds up to 95mph! ;)
     
  20. Jun 12, 2012 at 9:45 PM
    #20
    Juggernaut

    Juggernaut Captain

    Joined:
    Sep 21, 2009
    Member:
    #23111
    Messages:
    1,529
    Gender:
    Male
    Sacramento
    Vehicle:
    10 PreRunner AC Sport Rally 5 Spd
    Tail gate hose clamp, Front Windows 50% tint, fog lights, 894 backup light mod, LED license & interior.
    I had the entire windshield resealed and then replaced by toyota for this problem and it still happens with a left to right crosswind. Iv'e given up.
     
To Top