1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Not shifting into 5th as soon

Discussion in '2nd Gen. Tacomas (2005-2015)' started by CharlieX, Aug 23, 2007.

  1. Aug 23, 2007 at 1:27 PM
    #1
    CharlieX

    CharlieX [OP] Well-Known Member

    Joined:
    Jan 24, 2007
    Member:
    #775
    Messages:
    66
    Gender:
    Male
    Maybe I'm imagining it, but after coming back from vacation, my 07 v6 seems to be holding onto 4th gear longer than it used to. Then I filled the tank and came up with 17.3 MPG, when I was getting 18.1. I'm about 7000 miles in.

    Any ideas? It shifts smooth, not like there's a problem with the tranny, and I see that it's a sealed system so I can't check the fluid. Or perhaps I was racing around too much and the computer adjusted shift points?
     
  2. Aug 23, 2007 at 1:57 PM
    #2
    gdawg25

    gdawg25 Zoom-Zoom

    Joined:
    Oct 25, 2006
    Member:
    #136
    Messages:
    1,024
    Gender:
    Male
    Victoria, BC
    Vehicle:
    '08 Mazdaspeed 3
    Do the automatics have overdrive? Did you maybe turn overdrive off?
     
  3. Aug 24, 2007 at 12:22 AM
    #3
    hokihigh

    hokihigh Active Member

    Joined:
    Jun 4, 2007
    Member:
    #1753
    Messages:
    28
    No its not just yours, my 07 does the same thing. I reset the ECU and it still does it. I took mine to the dealership, they said nothing was wrong with it, but I have the 100k warranty, so if the tranny blows its their baby, not mine.
     
  4. Aug 24, 2007 at 6:58 AM
    #4
    nd

    nd Radical Town. It's a hell of a place!

    Joined:
    Mar 12, 2007
    Member:
    #1047
    Messages:
    12,651
    Gender:
    Male
    First Name:
    Nate
    Greenville, SC
    Vehicle:
    07 TRD Off-Road 4x4 debadged
    De badged, 5100's, Black Toyota Baja wheels
    Mine shifts into 5th with no problem. even at 30mph if i'm hardly touching the gas pedal. No problems with 5th gear here
     
  5. Aug 24, 2007 at 9:22 AM
    #5
    CharlieX

    CharlieX [OP] Well-Known Member

    Joined:
    Jan 24, 2007
    Member:
    #775
    Messages:
    66
    Gender:
    Male
    Yeah, I just reset the computer yesterday. See what happens. I commute in LA, so lots of aggressive acceleration and braking. Maybe it was assuming I'd be jumping from 30 to 45 and back down often.
     
To Top