1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

o2 sensor help

Discussion in '1st Gen. Tacomas' started by 04Prerunnertaco, May 15, 2013.

  1. May 15, 2013 at 9:54 AM
    #1
    04Prerunnertaco

    04Prerunnertaco [OP] Well-Known Member

    Joined:
    May 3, 2013
    Member:
    #103453
    Messages:
    54
    Gender:
    Male
    Vehicle:
    04 pre runner
    Hey gents. Need some help. I got a check engine lite on. Took it to auto zone they said sensor 1 bank 1. Where is this sensor located? I called toyota they said wirt just the info I gave them without doing there own diagnostic test I am looking at $370! Any help is greatly appreciated.
     
  2. May 15, 2013 at 3:13 PM
    #2
    Sittingbull2

    Sittingbull2 Old N.R.A. Hippy

    Joined:
    Sep 24, 2012
    Member:
    #87633
    Messages:
    124
    Gender:
    Male
    First Name:
    Mitch
    Southeast texas
    Vehicle:
    2000 Xtra Cab SR5 White
    3" Body lift, ARB Front Bumper w/9000 lb. Warn Winch, Chevy Alum. Rims w/ Kelly 285's M/S
    I am gonna give you a diagram of a 2000 3.4L V6 model. Take a look might help you out. It should be Bank 1 Sensor 1 is on the passenger side in front of the Cat. converter.
     

    Attached Files:

  3. May 15, 2013 at 3:15 PM
    #3
    4banger09

    4banger09 Well-Known Member

    Joined:
    Mar 30, 2012
    Member:
    #75914
    Messages:
    1,501
    Gender:
    Male
    First Name:
    Alex
    Nb, Canada
    Vehicle:
    09 Tacoma Access cab 4cyl
    Leveled
    Google it but I believe it is the o2 sensor before the cat
     
To Top