1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Oil Filter ??? Help!

Discussion in 'New Members' started by dos ballenas, Feb 25, 2010.

  1. Feb 25, 2010 at 6:30 PM
    #1
    dos ballenas

    dos ballenas [OP] New Member

    Joined:
    Feb 25, 2010
    Member:
    #32118
    Messages:
    4
    Gender:
    Male
    Vehicle:
    tacoma 4x4
    Howdy,

    First time posting... long time tacoma owner. This site seems pretty good so far... hope to help out in any way I can...

    So I just bought a 2007 tacoma regular cab 4x4 with the 2.7l 4 cyl.

    I owned a 2 wheel drive 1996 tacoma for its entire life and decided it was time to get the 4x4...

    So far I love the truck, but I recently went to change the oil and have been encountering some problems...

    So I go to NApa auto parts and they sell me the oil filter that their book says will work. Right off the bat I realize its the exact same filter for my previous tacoma... odd but its possible.

    I get home, remove the oil and filter and go to check the new filter against the old filter oring. Hmmmmn, they don't seem to be the same, the one I removed that is the toyota brand looks bigger.

    Concerned, I drive to Kragen auto and reference the fram filter.... also the same filter for both the 1996 and 2007... okay, maybe I was just trippin and the filter is the same. Guy at the store says to check it again and if its close to give it a try and it should work...

    I think he is an idiot, but decide to try it. So I get home and convince myself that the Napa filter is close enough, and hey, its the one the book says is right so I install it...

    No leaks so far but I still need to give it a test drive... Drive to work and let the truck sit all day... before leaving work I check it again , and what do you know, its leaking.... not a lot, but its leaking.

    Anyways, my QUESTION is: has anyone else had this problem? Is there an aftermarket filter even available?

    How can Napa, and Fram have the wrong part listed?

    I've been changing my oil for over ten years... so am I doing something wrong?

    You should know that when I bought the truck I had it undercoated by Rhino liners with ther spray on stuff...

    Could the rhino liner have casued any problem when installing the new filter? The original filter I removed was SUPER tight and hard to remove, but that could have been because the numnuts at the toyota dealership over tightened it... or did the rhino liner make it stick???? Or just the wrong filter???

    Where do I get the right filter?!?

    Thanks for the help, much appreciated!

    Owyn
     
  2. Feb 25, 2010 at 6:31 PM
    #2
    THXEY

    THXEY Panda Jerk

    Joined:
    Dec 15, 2008
    Member:
    #11614
    Messages:
    12,739
    Gender:
    Male
    First Name:
    Jacob
    San Diego
    Vehicle:
    2013 Subaru WRX
    STi Short Shifter.OEM floor illumination kit. Rally Armor Mud Flaps. BC BR Coilovers. Invidia N1 Exhaust
    welcome to TW from carlsbad! :wave:
     
To Top