1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Oil filter Woes

Discussion in 'Technical Chat' started by DanGer, May 19, 2009.

  1. May 19, 2009 at 10:06 AM
    #1
    DanGer

    DanGer [OP] Avatar approved by 98tacomav6

    Joined:
    Jun 7, 2008
    Member:
    #7155
    Messages:
    5,494
    Gender:
    Male
    Northern Virginia & Blacksburg
    Vehicle:
    07 Base 4Cyl 4x4 Manual
    White Head Light mod, White shorty antennae, Doug Thorley Long Tube headers, AFE Drop in air filter, Secondary Air Filter Removed,
    So I all but finished the 30k Maintenance last night. I put a mobil1 oil filter on to replace the fram that was on there. When I went to start the truck, the oil filter blew off and oil sprayed out. I inspected the thread on the mobil 1 filter compared to the fram, and the fram thread is much deeper.

    What is the deal?
     
  2. May 19, 2009 at 10:10 AM
    #2
    BSPDX

    BSPDX Well-Known Member

    Joined:
    Apr 16, 2009
    Member:
    #16048
    Messages:
    2,074
    Gender:
    Male
    :confused: Not Sure...

    I always use the Fram 7000 mile Filters and never had an issue! Fram kick's ass, the filter experts!
     
  3. May 19, 2009 at 10:11 AM
    #3
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,772
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    Oil filters don't just "blow off" unless they are installed incorrectly.
     
  4. May 19, 2009 at 10:15 AM
    #4
    DanGer

    DanGer [OP] Avatar approved by 98tacomav6

    Joined:
    Jun 7, 2008
    Member:
    #7155
    Messages:
    5,494
    Gender:
    Male
    Northern Virginia & Blacksburg
    Vehicle:
    07 Base 4Cyl 4x4 Manual
    White Head Light mod, White shorty antennae, Doug Thorley Long Tube headers, AFE Drop in air filter, Secondary Air Filter Removed,
    well that was the one thing my dad did for me and he felt so bad afterwards. I went out last night and when I woke up my mom said he feltreally responsible and stay up til 10 (very late for him) putting fresh oil in and a new filter
     
  5. May 19, 2009 at 11:44 AM
    #5
    johnecon2001

    johnecon2001 Well-Known Member

    Joined:
    Apr 26, 2009
    Member:
    #16456
    Messages:
    1,019
    Gender:
    Male
    Phoenix, AZ
    Vehicle:
    2005 TRD Sport 4x4 Access Cab
    Downey front skid, Trail Gear U-Bolt flip, Toytec AAL, Total Chaos UCA's, Bilstein 5100's x4 + Eibach adjustable coils, Doug Thorley Long Tube Headers, Custom Rear bumper, TRD OffRoad front tow hook, TRD Trail Team wheels, Federal Couragia M/T 265's, ARB rear locker + on board air (CKMA12), TRD shift knob, Alpine W205, TRD seat covers, Tom Woods 1 Piece drive shaft, Powermaster D2700, Stubbs HD-SKO Sliders.
    Either it wasn't seated correctly, or it was just the wrong filter..
     
  6. May 19, 2009 at 12:11 PM
    #6
    humanoid

    humanoid bite me

    Joined:
    Jun 27, 2007
    Member:
    #1932
    Messages:
    2,744
    Gender:
    Male
    Sunny SoCal
    Vehicle:
    I had a '99 Xtra Cab PreRunner SR5 V6
    I'm guessing your dad put the wrong filter in. Was was the number for the filter that blew off?
     
  7. May 19, 2009 at 12:13 PM
    #7
    lsocoee

    lsocoee My hair is all natural Moderator

    Joined:
    Feb 9, 2007
    Member:
    #872
    Messages:
    10,165
    First Name:
    Hotdog
    Vehicle:
    2007 PreRunner SR5 Double Cab
    Wet Okole Underwear
    I use the M1-102 (I think)
     
  8. May 19, 2009 at 12:23 PM
    #8
    DanGer

    DanGer [OP] Avatar approved by 98tacomav6

    Joined:
    Jun 7, 2008
    Member:
    #7155
    Messages:
    5,494
    Gender:
    Male
    Northern Virginia & Blacksburg
    Vehicle:
    07 Base 4Cyl 4x4 Manual
    White Head Light mod, White shorty antennae, Doug Thorley Long Tube headers, AFE Drop in air filter, Secondary Air Filter Removed,
    Well I bought the filter a few months ago when advance was having the mobile 1 5 qt plus filter for $30 and had them look up what filter. M1-104 is the number
     
  9. May 19, 2009 at 12:27 PM
    #9
    lsocoee

    lsocoee My hair is all natural Moderator

    Joined:
    Feb 9, 2007
    Member:
    #872
    Messages:
    10,165
    First Name:
    Hotdog
    Vehicle:
    2007 PreRunner SR5 Double Cab
    Wet Okole Underwear
    did you check the number on the filter? I've had the wrong filters inside the correct box.
     
  10. May 19, 2009 at 12:28 PM
    #10
    DanGer

    DanGer [OP] Avatar approved by 98tacomav6

    Joined:
    Jun 7, 2008
    Member:
    #7155
    Messages:
    5,494
    Gender:
    Male
    Northern Virginia & Blacksburg
    Vehicle:
    07 Base 4Cyl 4x4 Manual
    White Head Light mod, White shorty antennae, Doug Thorley Long Tube headers, AFE Drop in air filter, Secondary Air Filter Removed,
    The box is gone, that is the number on the filter itself
     
  11. May 19, 2009 at 12:30 PM
    #11
    lsocoee

    lsocoee My hair is all natural Moderator

    Joined:
    Feb 9, 2007
    Member:
    #872
    Messages:
    10,165
    First Name:
    Hotdog
    Vehicle:
    2007 PreRunner SR5 Double Cab
    Wet Okole Underwear
    that's really weird. It sounds to me like you either got a defective mechanic or a defective filter.
     
  12. May 19, 2009 at 12:31 PM
    #12
    DanGer

    DanGer [OP] Avatar approved by 98tacomav6

    Joined:
    Jun 7, 2008
    Member:
    #7155
    Messages:
    5,494
    Gender:
    Male
    Northern Virginia & Blacksburg
    Vehicle:
    07 Base 4Cyl 4x4 Manual
    White Head Light mod, White shorty antennae, Doug Thorley Long Tube headers, AFE Drop in air filter, Secondary Air Filter Removed,
    Well my dad has taught me everything I know about oil changes and we have never had a problem. We put a fram on for now and noticed it took 2x as many rotations before it got tight thand the m1
     
  13. May 19, 2009 at 12:35 PM
    #13
    lsocoee

    lsocoee My hair is all natural Moderator

    Joined:
    Feb 9, 2007
    Member:
    #872
    Messages:
    10,165
    First Name:
    Hotdog
    Vehicle:
    2007 PreRunner SR5 Double Cab
    Wet Okole Underwear
    I just noticed you have the 4 cyl. I've been thinking about my 6 cyl the entire time. Best of luck.
     
  14. May 19, 2009 at 12:36 PM
    #14
    DanGer

    DanGer [OP] Avatar approved by 98tacomav6

    Joined:
    Jun 7, 2008
    Member:
    #7155
    Messages:
    5,494
    Gender:
    Male
    Northern Virginia & Blacksburg
    Vehicle:
    07 Base 4Cyl 4x4 Manual
    White Head Light mod, White shorty antennae, Doug Thorley Long Tube headers, AFE Drop in air filter, Secondary Air Filter Removed,
    haha sorry I always forget to specify that!
     
  15. May 19, 2009 at 12:39 PM
    #15
    DanGer

    DanGer [OP] Avatar approved by 98tacomav6

    Joined:
    Jun 7, 2008
    Member:
    #7155
    Messages:
    5,494
    Gender:
    Male
    Northern Virginia & Blacksburg
    Vehicle:
    07 Base 4Cyl 4x4 Manual
    White Head Light mod, White shorty antennae, Doug Thorley Long Tube headers, AFE Drop in air filter, Secondary Air Filter Removed,
    Mobil1 Thread

    IMG_3817.jpg


    Fram Thread
    IMG_3818.jpg


    Mobil 1 on left, fram on right
    IMG_3820.jpg

    Spot of exxon-valdez in my garage last night
    IMG_3821.jpg
     
  16. May 19, 2009 at 12:41 PM
    #16
    LEEP

    LEEP Well-Known Member

    Joined:
    Oct 30, 2008
    Member:
    #10372
    Messages:
    236
    Gender:
    Male
    First Name:
    LEE
    CONNECTICUT
    Vehicle:
    O8 TACOMA TRD
    I use m1-209 filter on my o8 no problem
     
  17. May 19, 2009 at 12:43 PM
    #17
    lsocoee

    lsocoee My hair is all natural Moderator

    Joined:
    Feb 9, 2007
    Member:
    #872
    Messages:
    10,165
    First Name:
    Hotdog
    Vehicle:
    2007 PreRunner SR5 Double Cab
    Wet Okole Underwear
    I think you got the wrong filter. It looks like they maybe you got the one for the 6 cyl.

    I have a feeling what happened...they asked you which engine you had and you said "4" and then they selected the 4.0L.
     
  18. May 19, 2009 at 12:44 PM
    #18
    MassTaco

    MassTaco Well-Known Member

    Joined:
    Apr 24, 2009
    Member:
    #16384
    Messages:
    177
    Gender:
    Male
    Massachusetts
    Vehicle:
    V6 4x4 SR5 DC AT5
    Those two filters look completely different. Both the thread diameter and the gasket diameter differ, did the right part no come in the mobil 1 box?
     
  19. May 19, 2009 at 12:50 PM
    #19
    lsocoee

    lsocoee My hair is all natural Moderator

    Joined:
    Feb 9, 2007
    Member:
    #872
    Messages:
    10,165
    First Name:
    Hotdog
    Vehicle:
    2007 PreRunner SR5 Double Cab
    Wet Okole Underwear
    I just checked the mobil 1 site and they recommend the following

    Mobile 1 Model M1-102
    Champion Model PH2835
    Fram Model PH3614
     
  20. May 22, 2009 at 2:48 PM
    #20
    ViperR

    ViperR Active Member

    Joined:
    Nov 22, 2008
    Member:
    #10947
    Messages:
    27
    Gender:
    Male
    NC
    Vehicle:
    bare-bones
    You also have to make sure the old rubber gasket didn't come off the used filter and stuck to the mount on the block. My neighbor didn't check this and had two gaskets sandwiched. Blew oil everywhere. It's the 1st thing I check when I do an oil/filter change when I service all of our 20+ Toyotas' in our fleet.
    Vipe
     
To Top