1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

one head light works just on high, marker light on when it shouldn't be

Discussion in 'Technical Chat' started by eric801, Jan 28, 2014.

  1. Jan 28, 2014 at 4:17 PM

    eric801 [OP] Member

    Jan 22, 2013
    First Name:
    Whistler BC Canada
    07 Trd
    fixed it
    I have no idea what I did but it works now.
    don't like that it worked on it's own but now I can't get it to not work so we'll see if I actually 'fixed it' for good.

    2007 Tacoma TRD
    My right headlight on low beam is not working, on high beam it is fine.
    My right marker light is on but not bright.

    When I take the headlight bulb out and reconnect the wiring and give it a 'bump' sometimes it goes on. If I turn the lights or motor off then back on the bulb does not light up.

    wiring looks ok, can't see any problems, don't have a tester lights.

    it's a bit weird. Yes I have tried a new bulb, contacts are good. wiggling the wires doesn't seem to help

    There was previous damage to the right front end before I bought it 5 years ago, the light has been working fine since I bought it.

    any ideas?

    Last edited: Jan 28, 2014
To Top